<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '588970021688228303',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Apple Still Aims To Allow iPad Apps To Run on Macs This Year - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="Apple's push for performance and security improvements over new features will also apply to this year's Mac software, Axios reported on Wednesday, but one key feature remains on the roadmap for 2018: The ability for Macs to run iPad apps. From the report: On the Mac side, this is taking the form of ...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="apple.slashdot.org">
		<meta property="og:url" content="https://apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+Slashdot%2Fslashdot+%28Slashdot%29">
	    
		<meta property="og:title" content="Apple Still Aims To Allow iPad Apps To Run on Macs This Year - Slashdot">
		<meta property="og:description" content="Apple's push for performance and security improvements over new features will also apply to this year's Mac software, Axios reported on Wednesday, but one key feature remains on the roadmap for 2018: The ability for Macs to run iPad apps. From the report: On the Mac side, this is taking the form of ...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/mac_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/336789" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?54e62181908b7151" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?54e62181908b7151" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?54e62181908b7151" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?54e62181908b7151">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?54e62181908b7151"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?54e62181908b7151" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//apple.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotApple" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //apple.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Become a fan of Slashdot on <a href="http://www.facebook.com/pages/Slashdotorg/267995220856">Facebook</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <a href="https://slashdot.org/newsletter">Sign up for the Slashdot Daily Newsletter!</a> <strong>DEAL:</strong> For $25 - <a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-97033047" data-fhid="97033047" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">97033047</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-97033047">
			<a href="//apple.slashdot.org/index2.pl?fhfilter=mac" onclick="return addfhfilter('mac');">
			
				<img src="//a.fsdn.com/sd/topics/mac_64.png" width="64" height="64" alt="Desktops (Apple)" title="Desktops (Apple)">
			
		</a>
		
	
		
		
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=ios" onclick="return addfhfilter('ios');">
			
				<img src="//a.fsdn.com/sd/topics/ios_64.png" width="64" height="64" alt="IOS" title="IOS">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=software" onclick="return addfhfilter('software');">
			
				<img src="//a.fsdn.com/sd/topics/software_64.png" width="64" height="64" alt="Software" title="Software">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=apple" onclick="return addfhfilter('apple');">
			
				<img src="//a.fsdn.com/sd/topics/apple_64.png" width="64" height="64" alt="Apple" title="Apple">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-97033047" class="story-title"> <a   href="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year">Apple Still Aims To Allow iPad Apps To Run on Macs This Year</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://www.axios.com/apple-still-working-to-make-ipad-apps-run-on-macs-this-year-1517340185-de66e445-19de-43be-bdfd-4e0dbba164a8.html"  title="External link - https://www.axios.com/apple-still-working-to-make-ipad-apps-run-on-macs-this-year-1517340185-de66e445-19de-43be-bdfd-4e0dbba164a8.html" target="_blank"> (axios.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-97033047" >50</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year#comments" title="">50</a></span>
		
	</h2>
	<div class="details" id="details-97033047">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  msmash
			
		
		

		
		
		<time id="fhtime-97033047" datetime="on Wednesday January 31, 2018 @12:20PM">on Wednesday January 31, 2018 @12:20PM</time>
		
		
			 from the <span class="dept-text">coming-next</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-97033047">
	
		
	

	
		
		<div id="text-97033047" class="p">
			
		 	
				Apple's push for <a href="https://apple.slashdot.org/story/18/01/30/138249/apple-is-postponing-release-of-new-features-to-ios-this-year-to-focus-on-reliability-and-performance-report">performance and security improvements</a> over new features will also apply to this year's Mac software, Axios reported on Wednesday, but one key feature remains on the roadmap for 2018: <a href="https://www.axios.com/apple-still-working-to-make-ipad-apps-run-on-macs-this-year-1517340185-de66e445-19de-43be-bdfd-4e0dbba164a8.html">The ability for Macs to run iPad apps</a>. From the report:<i> On the Mac side, this is taking the form of a new project around security as well as improvements in performance when waking and unlocking the system. While users would certainly welcome changes that make their systems run better and more securely, customers tend to be more motivated to make purchases based on new features rather than promised improvements around security or performance, which can be tough to judge. The signature new feature for the Mac -- the <a href="https://apple.slashdot.org/story/17/12/20/1542205/apple-plans-combined-iphone-ipad-and-mac-apps-to-create-one-user-experience">ability to run iPad apps</a> -- is a significant undertaking that adds a high degree of complexity to this year's OS release.</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-97033047" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year"
								  data-janrain-title="Apple Still Aims To Allow iPad Apps To Run on Macs This Year"
								  data-janrain-message="Apple Still Aims To Allow iPad Apps To Run on Macs This Year @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-97033047" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/apple" target="_blank">apple</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/mac" target="_blank">mac</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/software" target="_blank">software</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//news.slashdot.org/story/18/01/31/1426251/high-school-computer-science-look-ma-no-textbooks?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/18/01/31/180234/google-chrome-to-feature-built-in-image-lazy-loading?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//news.slashdot.org/story/18/01/31/1426251/high-school-computer-science-look-ma-no-textbooks?sdsrc=prev">High School Computer Science: Look Ma, No Textbooks! </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//apple.slashdot.org/story/17/12/20/1542205/apple-plans-combined-iphone-ipad-and-mac-apps-to-create-one-user-experience?sdsrc=rel">Apple Plans Combined iPhone, iPad and Mac Apps To Create One User Experience</a></h3><h3><a href="//apple.slashdot.org/story/18/01/30/138249/apple-is-postponing-release-of-new-features-to-ios-this-year-to-focus-on-reliability-and-performance-report?sdsrc=rel">Apple is Postponing Release of New Features To iOS This Year To Focus on Reliability and Performance: Report</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/18/01/31/180234/google-chrome-to-feature-built-in-image-lazy-loading?sdsrc=next">Google Chrome To Feature Built-In Image Lazy Loading</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year" title="Back to Article - Apple Still Aims To Allow iPad Apps To Run on Macs This Year">Apple Still Aims To Allow iPad Apps To Run on Macs This Year</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Apple Still Aims To Allow iPad Apps To Run on Macs This Year" href="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year">Apple Still Aims To Allow iPad Apps To Run on Macs This Year</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=11684987" class="btn">Search <span class="totalcommentcnt">50</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//apple.slashdot.org/comments.pl?sid=11684987">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=11684987" class="ui-icon search_comments">Search <span class="totalcommentcnt">50</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//apple.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/18/01/31/1720220/apple-still-aims-to-allow-ipad-apps-to-run-on-macs-this-year/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?54e62181908b7151" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_56041137" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041137" class="commentstatus"></div>
<div id="comment_56041137" class="cw">
</div>

<div id="replyto_56041137"></div>

<ul id="group_56041137">
	<li id="hiddens_56041137" class="hide"></li>
</ul>

<ul id="commtree_56041137"><li id="tree_56041285" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041285" class="commentstatus"></div>
<div id="comment_56041285" class="cw">
</div>

<div id="replyto_56041285"></div>

<ul id="group_56041285">
	<li id="hiddens_56041285" class="hide"></li>
</ul>

</li><li id="tree_56041377" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041377" class="commentstatus"></div>
<div id="comment_56041377" class="cw">
	<div id="comment_top_56041377" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041377" name="comment_link_56041377" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041377" onclick="return D2.setFocusComment(56041377)" >Re:</a>


		 	<span id="comment_score_56041377" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041377); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dbialac">dbialac</a>  <span class="uid"><a href="//slashdot.org/~dbialac">( 320955 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041377"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041377">Well, you see, it's quite simple: Apple has completely run out of ideas.</div>
	</div>

	<div class="commentSub" id="comment_sub_56041377">

</div>
</div>

<div id="replyto_56041377"></div>

<ul id="group_56041377">
	<li id="hiddens_56041377" class="hide"></li>
</ul>

<ul id="commtree_56041377"><li id="tree_56042197" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042197" class="commentstatus"></div>
<div id="comment_56042197" class="cw">
</div>

<div id="replyto_56042197"></div>

<ul id="group_56042197">
	<li id="hiddens_56042197" class="hide"></li>
</ul>

</li><li id="hidestring_56041377"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041377">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041693" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041693" class="commentstatus"></div>
<div id="comment_56041693" class="cw">
</div>

<div id="replyto_56041693"></div>

<ul id="group_56041693">
	<li id="hiddens_56041693" class="hide"></li>
</ul>

</li><li id="tree_56041875" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041875" class="commentstatus"></div>
<div id="comment_56041875" class="cw">
	<div id="comment_top_56041875" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041875" name="comment_link_56041875" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041875" onclick="return D2.setFocusComment(56041875)" >Re:</a>


		 	<span id="comment_score_56041875" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041875); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041875"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041875"><p><div class="quote"><p>This revolutionary innovative feature is only 5 years after Microsoft pulled off the same trick with Windows, and 2 years after Google pulled off the same trick with Chrome.</p><p>Apple doesn't even have a touch friendly computer operating system... Kinda getting a bit ahead of themselves with talk of iPad apps on a Mac.</p></div><p>Hate to reply to an Anonymous COWARD; but it is not at ALL the same with iOS Apps running under macOS.</p><p>Although they have the same kernel (Darwin), iOS and macOS diverge quite a bit above that level. Windows tablets run Windows; so, duh. Don't know as much about Chrome; but thought it was designed from the ground-up to be the same across "Desktop" and "Mobile" incarnations; so again, duh.</p><p>But iOS was never originally intended to be a subset of macOS; so it is a lot less "duh" for Apple to pull that trick off.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041875">

</div>
</div>

<div id="replyto_56041875"></div>

<ul id="group_56041875">
	<li id="hiddens_56041875" class="hide"></li>
</ul>

<ul id="commtree_56041875"><li id="tree_56042095" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042095" class="commentstatus"></div>
<div id="comment_56042095" class="cw">
</div>

<div id="replyto_56042095"></div>

<ul id="group_56042095">
	<li id="hiddens_56042095" class="hide"></li>
</ul>

</li><li id="hidestring_56041875"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041875">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56041137"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041137">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041149" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56041149" class="commentstatus"></div>
<div id="comment_56041149" class="cw">
	<div id="comment_top_56041149" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041149" name="comment_link_56041149" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041149" onclick="return D2.setFocusComment(56041149)" >My Mac already does this....</a>


		 	<span id="comment_score_56041149" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041149); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kenja">Kenja</a>  <span class="uid"><a href="//slashdot.org/~Kenja">( 541830 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041149">		
		on Wednesday January 31, 2018 @12:29PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041149">#56041149</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041149">There's an iOS device emulator included with XCode.</div>
	</div>

	<div class="commentSub" id="comment_sub_56041149">
<span class="ind"></span><a id="reply_link_56041149" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56041149" onclick="D2.replyTo(56041149); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="My Mac already does this.... by Kenja @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041149" data-title="My Mac already does this....">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="My Mac already does this.... by Kenja" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041149" data-title="My Mac already does this....">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="My Mac already does this.... by Kenja" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041149" data-title="My Mac already does this....">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11684987%26cid=56041149" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56041149" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56041149" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56041149"></div>

<ul id="group_56041149">
	<li id="hiddens_56041149" class="hide"></li>
</ul>

<ul id="commtree_56041149"><li id="tree_56041205" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041205" class="commentstatus"></div>
<div id="comment_56041205" class="cw">
</div>

<div id="replyto_56041205"></div>

<ul id="group_56041205">
	<li id="hiddens_56041205" class="hide"></li>
</ul>

<ul id="commtree_56041205"><li id="tree_56041359" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041359" class="commentstatus"></div>
<div id="comment_56041359" class="cw">
	<div id="comment_top_56041359" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041359" name="comment_link_56041359" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041359" onclick="return D2.setFocusComment(56041359)" >Re:</a>


		 	<span id="comment_score_56041359" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041359); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hal_Porter">Hal_Porter</a>  <span class="uid"><a href="//slashdot.org/~Hal_Porter">( 817932 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041359"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041359"><p>Intel did an ARM on x86 emulator called libhoudini for Atom based Android phones, And Intel treat Apple like a spoiled favourite child, so I'm sure Intel would be willing to share code.</p><p><a href="https://commonsware.com/blog/2013/11/21/libhoudini-what-it-means-for-developers.html" title="commonsware.com">https://commonsware.com/blog/2...</a> [commonsware.com]</p><p>Libhoudini run 32 bit ARM code on x86 of course, not 64 bit ARM code on x64.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041359">

</div>
</div>

<div id="replyto_56041359"></div>

<ul id="group_56041359">
	<li id="hiddens_56041359" class="hide"></li>
</ul>

</li><li id="tree_56042049" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042049" class="commentstatus"></div>
<div id="comment_56042049" class="cw">
	<div id="comment_top_56042049" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042049" name="comment_link_56042049" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042049" onclick="return D2.setFocusComment(56042049)" >Re:</a>


		 	<span id="comment_score_56042049" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042049); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dgatwood">dgatwood</a>  <span class="uid"><a href="//slashdot.org/~dgatwood">( 11270 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042049"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042049"><blockquote><div><p>To be fair, that is running CocoaTouch compiled natively for x86_64. I would assume this would have an ARM emulator (until everyone had recompiled and shipped their iPad apps to contain an x86 target)</p></div></blockquote><p>Well, they <b>could</b> do that, but why would Apple spend months of effort building a sufficiently fast emulator, just so users can run ancient iOS apps that nobody cares enough about to maintain?  If they cared about keeping old apps running without recompiling, we would still be able to run 32-bit iOS apps on iOS i<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042049">

</div>
</div>

<div id="replyto_56042049"></div>

<ul id="group_56042049">
	<li id="hiddens_56042049" class="hide"></li>
</ul>

<ul id="commtree_56042049"><li id="tree_56042285" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042285" class="commentstatus"></div>
<div id="comment_56042285" class="cw">
</div>

<div id="replyto_56042285"></div>

<ul id="group_56042285">
	<li id="hiddens_56042285" class="hide"></li>
</ul>

</li><li id="hidestring_56042049"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56042049">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_56041523" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041523" class="commentstatus"></div>
<div id="comment_56041523" class="cw">
</div>

<div id="replyto_56041523"></div>

<ul id="group_56041523">
	<li id="hiddens_56041523" class="hide"></li>
</ul>

</li><li id="tree_56042021" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042021" class="commentstatus"></div>
<div id="comment_56042021" class="cw">
	<div id="comment_top_56042021" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042021" name="comment_link_56042021" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042021" onclick="return D2.setFocusComment(56042021)" >Re:</a>


		 	<span id="comment_score_56042021" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042021); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~XxtraLarGe">XxtraLarGe</a>  <span class="uid"><a href="//slashdot.org/~XxtraLarGe">( 551297 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042021"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042021"><p><div class="quote"><p>There's an iOS device emulator included with XCode.</p></div><p>I'm curious though how well they will translate though? Last time I used the emulator (haven't done iOS development in a while), and while you could do quite a bit of testing, there was a lot you can't do.  How do you handle some unique inputs such as screen tilt or multi-touch gestures? I imagine that they'd want them to run full screen too, which you can't do with the emulator either last time I checked.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042021">

</div>
</div>

<div id="replyto_56042021"></div>

<ul id="group_56042021">
	<li id="hiddens_56042021" class="hide"></li>
</ul>

</li><li id="tree_56042745" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042745" class="commentstatus"></div>
<div id="comment_56042745" class="cw">
</div>

<div id="replyto_56042745"></div>

<ul id="group_56042745">
	<li id="hiddens_56042745" class="hide"></li>
</ul>

</li><li id="hidestring_56041149"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041149">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041203" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041203" class="commentstatus"></div>
<div id="comment_56041203" class="cw">
	<div id="comment_top_56041203" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041203" name="comment_link_56041203" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041203" onclick="return D2.setFocusComment(56041203)" >finder / non store apps / root to be removed next</a>


		 	<span id="comment_score_56041203" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041203); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Joe_Dragon">Joe_Dragon</a>  <span class="uid"><a href="//slashdot.org/~Joe_Dragon">( 2206452 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041203"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041203"><p>finder / non store apps / root to be removed next and in 2019 LTE in each mac</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041203">

</div>
</div>

<div id="replyto_56041203"></div>

<ul id="group_56041203">
	<li id="hiddens_56041203" class="hide"></li>
</ul>

<ul id="commtree_56041203"><li id="tree_56041231" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041231" class="commentstatus"></div>
<div id="comment_56041231" class="cw">
	<div id="comment_top_56041231" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041231" name="comment_link_56041231" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041231" onclick="return D2.setFocusComment(56041231)" >Re:</a>


		 	<span id="comment_score_56041231" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041231); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041231"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041231"><p>Without those, on what device would people be expected to run Xcode?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041231">

</div>
</div>

<div id="replyto_56041231"></div>

<ul id="group_56041231">
	<li id="hiddens_56041231" class="hide"></li>
</ul>

<ul id="commtree_56041231"><li id="tree_56041315" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041315" class="commentstatus"></div>
<div id="comment_56041315" class="cw">
	<div id="comment_top_56041315" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041315" name="comment_link_56041315" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041315" onclick="return D2.setFocusComment(56041315)" >Re:</a>


		 	<span id="comment_score_56041315" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041315); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~llZENll">llZENll</a>  <span class="uid"><a href="//slashdot.org/~llZENll">( 545605 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041315"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041315"><p>Xcode has been a store app for quite some time.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041315">

</div>
</div>

<div id="replyto_56041315"></div>

<ul id="group_56041315">
	<li id="hiddens_56041315" class="hide"></li>
</ul>

<ul id="commtree_56041315"><li id="tree_56042137" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042137" class="commentstatus"></div>
<div id="comment_56042137" class="cw">
	<div id="comment_top_56042137" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042137" name="comment_link_56042137" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042137" onclick="return D2.setFocusComment(56042137)" >Xcode without Finder</a>


		 	<span id="comment_score_56042137" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042137); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042137"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042137"><p>True. Unlike Microsoft, Apple puts its own development tools in its own store. There's even Swift Playgrounds on iOS, with limited functionality intended for learning. Good luck seeing Microsoft squeeze a useful subset of Visual Studio onto Windows 10 S, its education-targeted OS.</p><p>But without Finder, how would a user of Xcode gather and arrange the source files (some program code, some not) needed to build an application?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042137">

</div>
</div>

<div id="replyto_56042137"></div>

<ul id="group_56042137">
	<li id="hiddens_56042137" class="hide"></li>
</ul>

<ul id="commtree_56042137"><li id="tree_56042327" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042327" class="commentstatus"></div>
<div id="comment_56042327" class="cw">
	<div id="comment_top_56042327" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042327" name="comment_link_56042327" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042327" onclick="return D2.setFocusComment(56042327)" >Re:</a>


		 	<span id="comment_score_56042327" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042327); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042327"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042327"><p>Within XCode of course, like I do on my Mac<nobr> <wbr></nobr>... never used the finder to arrange some source files. But I don't use XCode often.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042327">

</div>
</div>

<div id="replyto_56042327"></div>

<ul id="group_56042327">
	<li id="hiddens_56042327" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_56041891" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041891" class="commentstatus"></div>
<div id="comment_56041891" class="cw">
	<div id="comment_top_56041891" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041891" name="comment_link_56041891" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041891" onclick="return D2.setFocusComment(56041891)" >Re:</a>


		 	<span id="comment_score_56041891" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041891); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041891"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041891"><p><div class="quote"><p>finder / non store apps / root to be removed next and in 2019 LTE in each mac</p></div><p>Not THAT meme again!!!<br>Go the FUCK away, Hater.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041891">

</div>
</div>

<div id="replyto_56041891"></div>

<ul id="group_56041891">
	<li id="hiddens_56041891" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56041213" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041213" class="commentstatus"></div>
<div id="comment_56041213" class="cw">
</div>

<div id="replyto_56041213"></div>

<ul id="group_56041213">
	<li id="hiddens_56041213" class="hide"></li>
</ul>

</li><li id="tree_56041273" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041273" class="commentstatus"></div>
<div id="comment_56041273" class="cw">
</div>

<div id="replyto_56041273"></div>

<ul id="group_56041273">
	<li id="hiddens_56041273" class="hide"></li>
</ul>

<ul id="commtree_56041273"><li id="tree_56042217" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042217" class="commentstatus"></div>
<div id="comment_56042217" class="cw">
</div>

<div id="replyto_56042217"></div>

<ul id="group_56042217">
	<li id="hiddens_56042217" class="hide"></li>
</ul>

</li><li id="hidestring_56041273"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041273">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041287" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56041287" class="commentstatus"></div>
<div id="comment_56041287" class="cw">
	<div id="comment_top_56041287" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041287" name="comment_link_56041287" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041287" onclick="return D2.setFocusComment(56041287)" >I would bet not an ARM emulator</a>


		 	<span id="comment_score_56041287" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041287); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jtara">jtara</a>  <span class="uid"><a href="//slashdot.org/~jtara">( 133429 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041287">		
		on Wednesday January 31, 2018 @12:45PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041287">#56041287</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041287"><p>I would bet it will not be an ARM emulator.</p><p>Apple already has iOS ported to X86 and has forever. It's used by developers when testing on the iOS simulator running on MacOS. The simulator doesn't run ARM code. It runs X86 code.</p><p>Apple would likely give developers the option of including X86 platform support in their build. Developers could OPT IN to releasing on macOS. You already build for two different ARM platforms.</p><p>There is nothing revolutionary here. Just a new build option and some new App Store/ITunesConnect functionality.</p><p>I'm a cross-platform developer. I write apps that run on iOS and Android. On Android, it uses the NDK (native development kit) and I build for both ARM and X86. (Because some Android tablets are X86). What Apple is proposing is likely not much different.</p><p>Apple wouldn't likely provide an ARM emulator, because the performance would suck.</p><p>Every time Apple comes out with a new XCode version, they say "jump", and developers respond with "how high?". Or... not agaaaaainnnnn!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041287">
<span class="ind"></span><a id="reply_link_56041287" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56041287" onclick="D2.replyTo(56041287); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="I would bet not an ARM emulator by jtara @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041287" data-title="I would bet not an ARM emulator">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="I would bet not an ARM emulator by jtara" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041287" data-title="I would bet not an ARM emulator">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="I would bet not an ARM emulator by jtara" data-url="https://apple.slashdot.org/comments.pl?sid=11684987&cid=56041287" data-title="I would bet not an ARM emulator">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11684987%26cid=56041287" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56041287" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56041287" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56041287"></div>

<ul id="group_56041287">
	<li id="hiddens_56041287" class="hide"></li>
</ul>

<ul id="commtree_56041287"><li id="tree_56041689" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041689" class="commentstatus"></div>
<div id="comment_56041689" class="cw">
</div>

<div id="replyto_56041689"></div>

<ul id="group_56041689">
	<li id="hiddens_56041689" class="hide"></li>
</ul>

</li><li id="tree_56042053" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042053" class="commentstatus"></div>
<div id="comment_56042053" class="cw">
	<div id="comment_top_56042053" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042053" name="comment_link_56042053" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042053" onclick="return D2.setFocusComment(56042053)" >Re:</a>


		 	<span id="comment_score_56042053" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042053); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~stabiesoft">stabiesoft</a>  <span class="uid"><a href="//slashdot.org/~stabiesoft">( 733417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042053"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042053"><p>Question if you know... I had built some apps that used libs in the AndroWish app. I would install both the AndroWish app (which had the ndk libs in it) and my app which was stripped down TclTk + a little secret sauce to load the AndroWish stuff. This worked on my old Android Version 4 nexus 4 phone. I got a new phone which runs Oreo and while the AndroWish app worked, the apps which used AndroWish libs did not. In the end I rebuilt the AndroWish app myself, and bolted on the Tcl/Tk from my apps so that it<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042053">

</div>
</div>

<div id="replyto_56042053"></div>

<ul id="group_56042053">
	<li id="hiddens_56042053" class="hide"></li>
</ul>

</li><li id="tree_56042587" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042587" class="commentstatus"></div>
<div id="comment_56042587" class="cw">
</div>

<div id="replyto_56042587"></div>

<ul id="group_56042587">
	<li id="hiddens_56042587" class="hide"></li>
</ul>

</li><li id="hidestring_56041287"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041287">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041301" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041301" class="commentstatus"></div>
<div id="comment_56041301" class="cw">
</div>

<div id="replyto_56041301"></div>

<ul id="group_56041301">
	<li id="hiddens_56041301" class="hide"></li>
</ul>

</li><li id="tree_56041313" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041313" class="commentstatus"></div>
<div id="comment_56041313" class="cw">
</div>

<div id="replyto_56041313"></div>

<ul id="group_56041313">
	<li id="hiddens_56041313" class="hide"></li>
</ul>

<ul id="commtree_56041313"><li id="tree_56041453" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041453" class="commentstatus"></div>
<div id="comment_56041453" class="cw">
</div>

<div id="replyto_56041453"></div>

<ul id="group_56041453">
	<li id="hiddens_56041453" class="hide"></li>
</ul>

</li><li id="tree_56041675" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041675" class="commentstatus"></div>
<div id="comment_56041675" class="cw">
	<div id="comment_top_56041675" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041675" name="comment_link_56041675" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041675" onclick="return D2.setFocusComment(56041675)" >Re:</a>


		 	<span id="comment_score_56041675" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041675); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sexconker">sexconker</a>  <span class="uid"><a href="//slashdot.org/~sexconker">( 1179573 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041675"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041675"><p>OS X is dead.  It's macOS now.  Which mean's it's going to be iMac OS.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041675">

</div>
</div>

<div id="replyto_56041675"></div>

<ul id="group_56041675">
	<li id="hiddens_56041675" class="hide"></li>
</ul>

<ul id="commtree_56041675"><li id="tree_56041929" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041929" class="commentstatus"></div>
<div id="comment_56041929" class="cw">
	<div id="comment_top_56041929" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041929" name="comment_link_56041929" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041929" onclick="return D2.setFocusComment(56041929)" >Re:</a>


		 	<span id="comment_score_56041929" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041929); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041929"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041929"><p><div class="quote"><p>OS X is dead.  It's macOS now.  Which mean's it's going to be iMac OS.</p></div><p>People have been saying that since OS X 10.7, you realize. And here we are at macOS 10.13 (SIX major revisions later!) and it STILL hasn't happened to any great extent.</p><p>STFU.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041929">

</div>
</div>

<div id="replyto_56041929"></div>

<ul id="group_56041929">
	<li id="hiddens_56041929" class="hide"></li>
</ul>

<ul id="commtree_56041929"><li id="tree_56042275" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042275" class="commentstatus"></div>
<div id="comment_56042275" class="cw">
</div>

<div id="replyto_56042275"></div>

<ul id="group_56042275">
	<li id="hiddens_56042275" class="hide"></li>
</ul>

</li><li id="hidestring_56041929"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041929">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="hidestring_56041313"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041313">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56041481" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041481" class="commentstatus"></div>
<div id="comment_56041481" class="cw">
</div>

<div id="replyto_56041481"></div>

<ul id="group_56041481">
	<li id="hiddens_56041481" class="hide"></li>
</ul>

</li><li id="tree_56041555" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041555" class="commentstatus"></div>
<div id="comment_56041555" class="cw">
</div>

<div id="replyto_56041555"></div>

<ul id="group_56041555">
	<li id="hiddens_56041555" class="hide"></li>
</ul>

<ul id="commtree_56041555"><li id="tree_56041951" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041951" class="commentstatus"></div>
<div id="comment_56041951" class="cw">
	<div id="comment_top_56041951" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041951" name="comment_link_56041951" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041951" onclick="return D2.setFocusComment(56041951)" >Re:</a>


		 	<span id="comment_score_56041951" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041951); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041951"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041951"><p><div class="quote"><p>But Macs don't have touchscreen, so honestly, how is that gonna work?</p></div><p>Easy. They have multitouch trackpads on MacBooks back to at least 2011 (and possibly before), and the ones on the 2016-2017 MacBook Pros and the external Trackpad are already nearly the size of an iPad mini and have force-touch and multitouch; so...</p><p><span class="substr"> </span> <a href="https://www.apple.com/shop/product/MJ2R2LL/A/magic-trackpad-2" title="apple.com">https://www.apple.com/shop/pro...</a> [apple.com] </p><p>Problem solved!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041951">

</div>
</div>

<div id="replyto_56041951"></div>

<ul id="group_56041951">
	<li id="hiddens_56041951" class="hide"></li>
</ul>

<ul id="commtree_56041951"><li id="tree_56042107" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042107" class="commentstatus"></div>
<div id="comment_56042107" class="cw">
	<div id="comment_top_56042107" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042107" name="comment_link_56042107" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042107" onclick="return D2.setFocusComment(56042107)" >Re:</a>


		 	<span id="comment_score_56042107" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042107); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dgatwood">dgatwood</a>  <span class="uid"><a href="//slashdot.org/~dgatwood">( 11270 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042107"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042107">
<p>Almost solved.  Any app that supports independent touches on particular parts of the screen still won't be fully usable (e.g. on-screen pianos).  Unless, of course, this means Apple is finally building a laptop with a touchscreen.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042107">

</div>
</div>

<div id="replyto_56042107"></div>

<ul id="group_56042107">
	<li id="hiddens_56042107" class="hide"></li>
</ul>

<ul id="commtree_56042107"><li id="tree_56042369" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042369" class="commentstatus"></div>
<div id="comment_56042369" class="cw">
	<div id="comment_top_56042369" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042369" name="comment_link_56042369" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042369" onclick="return D2.setFocusComment(56042369)" >Re:</a>


		 	<span id="comment_score_56042369" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042369); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042369"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042369"><p>A Mouse, and a Touchpad is a mouse, works perfectly fine on an iPad.<br>And touchpads on Macs are multi touch since a decade or longer<nobr> <wbr></nobr>... no problem to interact with iOS.<br>How do you think developers are toying with their Apps in the emulator?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042369">

</div>
</div>

<div id="replyto_56042369"></div>

<ul id="group_56042369">
	<li id="hiddens_56042369" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_56041585" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041585" class="commentstatus"></div>
<div id="comment_56041585" class="cw">
	<div id="comment_top_56041585" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041585" name="comment_link_56041585" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041585" onclick="return D2.setFocusComment(56041585)" >Good but add legacy support everywhere</a>


		 	<span id="comment_score_56041585" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041585); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pubwvj">pubwvj</a>  <span class="uid"><a href="//slashdot.org/~pubwvj">( 1045960 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041585"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041585"><p>This is great but Apple should be offering legacy software support everywhere so that all iOS apps run on both iOS devices and Macs and all Mac applications run on both iOS devices and Macs. This is a fairly trivial task that would open up a huge amount of software that they have caused to be abandoned. There is a tremendous amount of excellent kids educational software that doesn't run on modern MacOSs (and iOS) that would then be available. There is also a lot of business applications and just fun other s<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041585">

</div>
</div>

<div id="replyto_56041585"></div>

<ul id="group_56041585">
	<li id="hiddens_56041585" class="hide"></li>
</ul>

<ul id="commtree_56041585"><li id="tree_56041961" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041961" class="commentstatus"></div>
<div id="comment_56041961" class="cw">
	<div id="comment_top_56041961" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041961" name="comment_link_56041961" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041961" onclick="return D2.setFocusComment(56041961)" >Re:</a>


		 	<span id="comment_score_56041961" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041961); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041961"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041961"><p><div class="quote"><p>This is great but Apple should be offering legacy software support everywhere so that all iOS apps run on both iOS devices and Macs and all Mac applications run on both iOS devices and Macs. This is a fairly trivial task that would open up a huge amount of software that they have caused to be abandoned. There is a tremendous amount of excellent kids educational software that doesn't run on modern MacOSs (and iOS) that would then be available. There is also a lot of business applications and just fun other stuff. They can sandbox it all to make it safe. Apple has the resources.</p></div><p>It is a lot easier to emulate a system with less speed and resources on a system with greater speed and resources than vice-versa.</p><p>That's why we won't be having macOS on iOS for a while yet...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041961">

</div>
</div>

<div id="replyto_56041961"></div>

<ul id="group_56041961">
	<li id="hiddens_56041961" class="hide"></li>
</ul>

<ul id="commtree_56041961"><li id="tree_56042355" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042355" class="commentstatus"></div>
<div id="comment_56042355" class="cw">
	<div id="comment_top_56042355" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042355" name="comment_link_56042355" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042355" onclick="return D2.setFocusComment(56042355)" >Re:</a>


		 	<span id="comment_score_56042355" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042355); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pubwvj">pubwvj</a>  <span class="uid"><a href="//slashdot.org/~pubwvj">( 1045960 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042355"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042355"><p>Yes, I understand, and most software does not tax the processors on either modern (&gt;2005) Macs or iOS devices. Admittedly some very heavy duty power using software will have trouble under emulation but that isn't the software in question.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56042355">

</div>
</div>

<div id="replyto_56042355"></div>

<ul id="group_56042355">
	<li id="hiddens_56042355" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_56041609" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041609" class="commentstatus"></div>
<div id="comment_56041609" class="cw">
	<div id="comment_top_56041609" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041609" name="comment_link_56041609" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041609" onclick="return D2.setFocusComment(56041609)" >No thanks</a>


		 	<span id="comment_score_56041609" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041609); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bogie">bogie</a>  <span class="uid"><a href="//slashdot.org/~bogie">( 31020 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041609"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041609"><p>Apps I can"t ever roll back, have zero control over and where any update may break/change the app fundamentally and there is nothing you can do about it? Yea, no thanks.  I don't care if it is the future I like my MacBook as is.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041609">

</div>
</div>

<div id="replyto_56041609"></div>

<ul id="group_56041609">
	<li id="hiddens_56041609" class="hide"></li>
</ul>

<ul id="commtree_56041609"><li id="tree_56041707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041707" class="commentstatus"></div>
<div id="comment_56041707" class="cw">
	<div id="comment_top_56041707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041707" name="comment_link_56041707" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041707" onclick="return D2.setFocusComment(56041707)" >Re:</a>


		 	<span id="comment_score_56041707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041707"><p>You can restore the App from a backup, just like you do right now.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041707">

</div>
</div>

<div id="replyto_56041707"></div>

<ul id="group_56041707">
	<li id="hiddens_56041707" class="hide"></li>
</ul>

</li><li id="tree_56041965" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56041965" class="commentstatus"></div>
<div id="comment_56041965" class="cw">
	<div id="comment_top_56041965" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56041965" name="comment_link_56041965" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56041965" onclick="return D2.setFocusComment(56041965)" >Re:</a>


		 	<span id="comment_score_56041965" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56041965); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheFakeTimCook">TheFakeTimCook</a>  <span class="uid"><a href="//slashdot.org/~TheFakeTimCook">( 4641057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56041965"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56041965"><p><div class="quote"><p>Apps I can"t ever roll back, have zero control over and where any update may break/change the app fundamentally and there is nothing you can do about it? Yea, no thanks.  I don't care if it is the future I like my MacBook as is.</p></div><p>WTF are you bleating about?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56041965">

</div>
</div>

<div id="replyto_56041965"></div>

<ul id="group_56041965">
	<li id="hiddens_56041965" class="hide"></li>
</ul>

<ul id="commtree_56041965"><li id="tree_56042763" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56042763" class="commentstatus"></div>
<div id="comment_56042763" class="cw">
</div>

<div id="replyto_56042763"></div>

<ul id="group_56042763">
	<li id="hiddens_56042763" class="hide"></li>
</ul>

</li><li id="hidestring_56041965"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041965">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_56041885" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041885" class="commentstatus"></div>
<div id="comment_56041885" class="cw">
</div>

<div id="replyto_56041885"></div>

<ul id="group_56041885">
	<li id="hiddens_56041885" class="hide"></li>
</ul>

</li><li id="tree_56041903" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041903" class="commentstatus"></div>
<div id="comment_56041903" class="cw">
</div>

<div id="replyto_56041903"></div>

<ul id="group_56041903">
	<li id="hiddens_56041903" class="hide"></li>
</ul>

<ul id="commtree_56041903"><li id="tree_56041995" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56041995" class="commentstatus"></div>
<div id="comment_56041995" class="cw">
</div>

<div id="replyto_56041995"></div>

<ul id="group_56041995">
	<li id="hiddens_56041995" class="hide"></li>
</ul>

</li><li id="hidestring_56041903"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56041903">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56042299" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56042299" class="commentstatus"></div>
<div id="comment_56042299" class="cw">
	<div id="comment_top_56042299" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56042299" name="comment_link_56042299" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;cid=56042299" onclick="return D2.setFocusComment(56042299)" >Hey, maybe they can let me run 32bit apps as well.</a>


		 	<span id="comment_score_56042299" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56042299); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~c120plus">c120plus</a>  <span class="uid"><a href="//slashdot.org/~c120plus">( 3825447 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56042299"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56042299">Hey, maybe they can let me run 32bit apps as well.
So I can finally switch from iOS10 to 11...</div>
	</div>

	<div class="commentSub" id="comment_sub_56042299">

</div>
</div>

<div id="replyto_56042299"></div>

<ul id="group_56042299">
	<li id="hiddens_56042299" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11684987&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">9 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//apple.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 24;
		D2.currents()['full']     = 2;
		D2.currents()['oneline']  = 24;
		// D2.currents_total(50);

		D2.abbrev_comments({56041585:515,56041951:363,56042049:565,56042053:514});
		D2.noshow_comments([56041137,56041285,56042197,56041693,56042095,56041205,56042285,56041523,56042745,56041213,56041273,56042217,56041689,56042587,56041301,56041313,56041453,56042275,56041481,56041555,56042763,56041885,56041903,56041995]);
		D2.pieces_comments([56041377,56041875,56041359,56042049,56042021,56041203,56041231,56041315,56042137,56042327,56041891,56042053,56041675,56041929,56041951,56042107,56042369,56041585,56041961,56042355,56041609,56041707,56041965,56042299]);
		D2.init_hiddens([56041377,56041875,56041137,56042049,56041149,56041273,56041287,56041929,56041313,56041965,56041903,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(336789);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>757<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/05/02/1916223/ask-slashdot-what-is-the-special-appeal-of-apple-products?sdsrc=popbyskidbtmprev">Ask Slashdot: What Is the 'Special Appeal' of Apple Products?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>594<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/18/01/25/188239/apples-whats-a-computer-ad-is-annoying-people-business-insider?sdsrc=popbyskidbtmprev">Apple's 'What's a Computer?' Ad is Annoying People: Business Insider</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>529<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/10/18/1530202/maybe-its-a-piece-of-dust?sdsrc=popbyskidbtmprev">"Maybe It's a Piece of Dust"</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>517<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/07/26/1956206/tech-leaders-speak-out-against-trump-ban-on-transgender-troops?sdsrc=popbyskidbtmprev">Tech Leaders Speak Out Against Trump Ban on Transgender Troops</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>497<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/11/22/1659230/apple-only-wants-to-put-its-stores-where-white-people-live-investigation-reveals?sdsrc=popbyskidbtmprev">Apple Only Wants To Put Its Stores Where White People Live, Investigation Reveals</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/01/31/180234/google-chrome-to-feature-built-in-image-lazy-loading?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/chrome_64.png" width="64" height="64" alt="Chrome"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/01/31/180234/google-chrome-to-feature-built-in-image-lazy-loading?sdsrc=nextbtmprev">Google Chrome To Feature Built-In Image Lazy Loading</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>83<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//news.slashdot.org/story/18/01/31/1426251/high-school-computer-science-look-ma-no-textbooks?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/education_64.png" width="64" height="64" alt="Education"></span>
	    
					<p class="grid_12"><a href="//news.slashdot.org/story/18/01/31/1426251/high-school-computer-science-look-ma-no-textbooks?sdsrc=prevbtmprev">High School Computer Science: Look Ma, No Textbooks!</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>76<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=11684987&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">50</span> of <span class="totalcommentcnt">50</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>panic: can't find /</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?172">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?345">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->