<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '204744714395679306',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="An anonymous reader writes: One of the more surprising stories of the past year was Microsoft's announcement that it was going to use the Git version control system for Windows development. Microsoft had to modify Git to handle the demands of Windows development but said that it wanted to get these ...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="apple.slashdot.org">
		<meta property="og:url" content="https://apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux?utm_medium=feed&utm_source=rss1.0mainlinkanon">
	    
		<meta property="og:title" content="Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux - Slashdot">
		<meta property="og:description" content="An anonymous reader writes: One of the more surprising stories of the past year was Microsoft's announcement that it was going to use the Git version control system for Windows development. Microsoft had to modify Git to handle the demands of Windows development but said that it wanted to get these ...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/microsoft_64100.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/333795" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?acf4e08ef95906a6" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?acf4e08ef95906a6" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?acf4e08ef95906a6" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?acf4e08ef95906a6">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?acf4e08ef95906a6"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?acf4e08ef95906a6" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//apple.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotApple" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //apple.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Become a fan of Slashdot on <a href="http://www.facebook.com/pages/Slashdotorg/267995220856">Facebook</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 #NetNeutrality is STILL in danger - <strong><a href="https://www.battleforthenet.com/">Click here to help.</a></strong> <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 Internet speed test.</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-95299841" data-fhid="95299841" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">95299841</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-95299841">
			<a href="//apple.slashdot.org/index2.pl?fhfilter=microsoft" onclick="return addfhfilter('microsoft');">
			
				<img src="//a.fsdn.com/sd/topics/microsoft_64100.png" width="100" height="64" alt="Microsoft" title="Microsoft">
			
		</a>
		
	
		
		
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=os" onclick="return addfhfilter('os');">
			
				<img src="//a.fsdn.com/sd/topics/os_64.png" width="64" height="64" alt="Operating Systems" title="Operating Systems">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=macosx" onclick="return addfhfilter('macosx');">
			
				<img src="//a.fsdn.com/sd/topics/macosx_64.png" width="64" height="64" alt="OS X" title="OS X">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=opensource" onclick="return addfhfilter('opensource');">
			
				<img src="//a.fsdn.com/sd/topics/opensource_64.png" width="64" height="64" alt="Open Source" title="Open Source">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=software" onclick="return addfhfilter('software');">
			
				<img src="//a.fsdn.com/sd/topics/software_64.png" width="64" height="64" alt="Software" title="Software">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=linux" onclick="return addfhfilter('linux');">
			
				<img src="//a.fsdn.com/sd/topics/linux_64.png" width="64" height="64" alt="Linux" title="Linux">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=technology" onclick="return addfhfilter('technology');">
			
				<img src="//a.fsdn.com/sd/topics/technology_64.png" width="64" height="64" alt="Technology" title="Technology">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-95299841" class="story-title"> <a   href="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux">Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://arstechnica.com/gadgets/2017/11/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/"  title="External link - https://arstechnica.com/gadgets/2017/11/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/" target="_blank"> (arstechnica.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-95299841" >69</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux#comments" title="">69</a></span>
		
	</h2>
	<div class="details" id="details-95299841">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  <a href="https://twitter.com/BeauHD" rel="nofollow">BeauHD</a>
			
		
		

		
		
		<time id="fhtime-95299841" datetime="on Friday November 17, 2017 @05:10PM">on Friday November 17, 2017 @05:10PM</time>
		
		
			 from the <span class="dept-text">up-scale</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-95299841">
	
		
	

	
		
		<div id="text-95299841" class="p">
			
		 	
				An anonymous reader writes: <i>One of the more surprising stories of the past year was Microsoft's announcement that it was going to use the <a href="https://developers.slashdot.org/story/17/02/03/1427213/microsoft-introduces-gvfs-git-virtual-file-system">Git version control system for Windows development</a>. Microsoft had to modify Git to handle the demands of Windows development but said that it wanted to get these modifications accepted upstream and integrated into the standard Git client. That plan appears to be going well. Yesterday, the company announced that GitHub was adopting its modifications and that the two would be <a href="https://arstechnica.com/gadgets/2017/11/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/">working together to bring suitable clients to macOS and Linux</a>. Microsoft says that, so far, about half of its modifications have been accepted upstream, with upstream Git developers broadly approving of the approach the company has taken to improve the software's scaling. Redmond also says that it has been willing to make changes to its approach to satisfy the demands of upstream Git. The biggest complexity is that Git has a very conservative approach to compatibility, requiring that repositories remain compatible across versions. <br> <br>

Microsoft and GitHub are also working to bring similar capabilities to other platforms, with macOS coming first, and later Linux. The obvious way to do this on both systems is to use FUSE, an infrastructure for building file systems that run in user mode rather than kernel mode (desirable because user-mode development is easier and safer than kernel mode). However, the companies have discovered that FUSE isn't fast enough for this -- a lesson Dropbox also learned when developing a similar capability, Project Infinite. Currently, the companies believe that tapping into a macOS extensibility mechanism called Kauth (or KAuth) will be the best way forward.</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-95299841" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux"
								  data-janrain-title="Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux"
								  data-janrain-message="Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-95299841" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/git" target="_blank">git</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/linux" target="_blank">linux</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/macosx" target="_blank">macosx</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/17/11/17/215258/even-new-phones-are-no-longer-guaranteed-to-have-the-latest-version-of-android?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//apple.slashdot.org/story/17/11/17/2138208/apples-homepod-gets-delayed-until-2018?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/17/11/17/215258/even-new-phones-are-no-longer-guaranteed-to-have-the-latest-version-of-android?sdsrc=prev">Even New Phones Are No Longer Guaranteed To Have the Latest Version of Android </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/17/02/03/1427213/microsoft-introduces-gvfs-git-virtual-file-system?sdsrc=rel">Microsoft Introduces GVFS (Git Virtual File System)</a></h3><h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//apple.slashdot.org/submission/7620035/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux?sdsrc=rel" href="#">Submission: Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//apple.slashdot.org/story/17/11/17/2138208/apples-homepod-gets-delayed-until-2018?sdsrc=next">Apple's HomePod Gets Delayed Until 2018</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux" title="Back to Article - Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux">Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux" href="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux">Microsoft and GitHub Team Up To Take Git Virtual File System To MacOS, Linux</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=11372285" class="btn">Search <span class="totalcommentcnt">69</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//apple.slashdot.org/comments.pl?sid=11372285">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=11372285" class="ui-icon search_comments">Search <span class="totalcommentcnt">69</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//apple.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/11/17/2119235/microsoft-and-github-team-up-to-take-git-virtual-file-system-to-macos-linux/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?acf4e08ef95906a6" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55573023" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573023" class="commentstatus"></div>
<div id="comment_55573023" class="cw">
</div>

<div id="replyto_55573023"></div>

<ul id="group_55573023">
	<li id="hiddens_55573023" class="hide"></li>
</ul>

<ul id="commtree_55573023"><li id="tree_55573417" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573417" class="commentstatus"></div>
<div id="comment_55573417" class="cw">
	<div id="comment_top_55573417" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573417" name="comment_link_55573417" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573417" onclick="return D2.setFocusComment(55573417)" >Re: Microsoft kernel module for Linux</a>


		 	<span id="comment_score_55573417" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573417); return false"><span class=opt>Score:</span>1</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573417"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573417"><p>... and systemd. No, wait, that abomination isn't Microsoft.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573417">

</div>
</div>

<div id="replyto_55573417"></div>

<ul id="group_55573417">
	<li id="hiddens_55573417" class="hide"></li>
</ul>

</li><li id="tree_55573637" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573637" class="commentstatus"></div>
<div id="comment_55573637" class="cw">
	<div id="comment_top_55573637" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573637" name="comment_link_55573637" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573637" onclick="return D2.setFocusComment(55573637)" >Re: Microsoft kernel module for Linux</a>


		 	<span id="comment_score_55573637" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573637); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hackwrench">hackwrench</a>  <span class="uid"><a href="//slashdot.org/~hackwrench">( 573697 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573637"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573637">No, Microsoft comes with too easy to get root-type access. Android has no root access.</div>
	</div>

	<div class="commentSub" id="comment_sub_55573637">

</div>
</div>

<div id="replyto_55573637"></div>

<ul id="group_55573637">
	<li id="hiddens_55573637" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55573037" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573037" class="commentstatus"></div>
<div id="comment_55573037" class="cw">
</div>

<div id="replyto_55573037"></div>

<ul id="group_55573037">
	<li id="hiddens_55573037" class="hide"></li>
</ul>

</li><li id="tree_55573051" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573051" class="commentstatus"></div>
<div id="comment_55573051" class="cw">
	<div id="comment_top_55573051" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573051" name="comment_link_55573051" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573051" onclick="return D2.setFocusComment(55573051)" >Embrace, Extend, Extinguish</a>


		 	<span id="comment_score_55573051" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573051); return false"><span class=opt>Score:</span>1</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dffuller">dffuller</a>  <span class="uid"><a href="//slashdot.org/~dffuller">( 200455 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573051"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573051"><p>Business as usual.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573051">

</div>
</div>

<div id="replyto_55573051"></div>

<ul id="group_55573051">
	<li id="hiddens_55573051" class="hide"></li>
</ul>

<ul id="commtree_55573051"><li id="tree_55573099" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573099" class="commentstatus"></div>
<div id="comment_55573099" class="cw">
</div>

<div id="replyto_55573099"></div>

<ul id="group_55573099">
	<li id="hiddens_55573099" class="hide"></li>
</ul>

<ul id="commtree_55573099"><li id="tree_55573171" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573171" class="commentstatus"></div>
<div id="comment_55573171" class="cw">
	<div id="comment_top_55573171" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573171" name="comment_link_55573171" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573171" onclick="return D2.setFocusComment(55573171)" >Re:</a>


		 	<span id="comment_score_55573171" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573171); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573171"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573171"><blockquote><div><p>Seemed like a way to torture programmers</p></div></blockquote><p>And that's not a part of Git today?</p><p>It's a sad thing when you start to agree with Hitler: https://www.youtube.com/watch?v=CDeG4S-mJts</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573171">

</div>
</div>

<div id="replyto_55573171"></div>

<ul id="group_55573171">
	<li id="hiddens_55573171" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55573269" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573269" class="commentstatus"></div>
<div id="comment_55573269" class="cw">
	<div id="comment_top_55573269" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573269" name="comment_link_55573269" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573269" onclick="return D2.setFocusComment(55573269)" >It's more like Embrace and Extend. No Extinguish.</a>


		 	<span id="comment_score_55573269" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573269); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573269"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573269"><p>It's not 1995. Microsoft of today is very different of the Microsoft from two decades ago. The presence of Azure alone guarantees that their old business approaches are irrelevant in today's market.</p><p>Microsoft has become one of the premiere open source providers. They've released a huge amount of great open source software, from<nobr> <wbr></nobr>.NET Core to Visual Studio Code to TypeScript and beyond.</p><p>Maybe it isn't apparent to people firmly stuck in the past, such as yourself, but Microsoft has leapfrogged many of the tradit<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573269">

</div>
</div>

<div id="replyto_55573269"></div>

<ul id="group_55573269">
	<li id="hiddens_55573269" class="hide"></li>
</ul>

<ul id="commtree_55573269"><li id="tree_55573405" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573405" class="commentstatus"></div>
<div id="comment_55573405" class="cw">
</div>

<div id="replyto_55573405"></div>

<ul id="group_55573405">
	<li id="hiddens_55573405" class="hide"></li>
</ul>

</li><li id="tree_55573447" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573447" class="commentstatus"></div>
<div id="comment_55573447" class="cw">
	<div id="comment_top_55573447" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573447" name="comment_link_55573447" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573447" onclick="return D2.setFocusComment(55573447)" >Re:</a>


		 	<span id="comment_score_55573447" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573447); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573447"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573447"><p>Yeah, yeah. We've all heard it before. Shut up. Microsoft has a track record stretching over 30 years of being a bunch of assholes and crooks. A few token efforts is nowhere enough to re-establish any kind of credibility. Establishing yourself as a shill and an apologist is pretty quickly done though, so congrats to that.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573447">

</div>
</div>

<div id="replyto_55573447"></div>

<ul id="group_55573447">
	<li id="hiddens_55573447" class="hide"></li>
</ul>

<ul id="commtree_55573447"><li id="tree_55574143" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574143" class="commentstatus"></div>
<div id="comment_55574143" class="cw">
	<div id="comment_top_55574143" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574143" name="comment_link_55574143" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574143" onclick="return D2.setFocusComment(55574143)" >Re:</a>


		 	<span id="comment_score_55574143" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574143); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~FatdogHaiku">FatdogHaiku</a>  <span class="uid"><a href="//slashdot.org/~FatdogHaiku">( 978357 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574143"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574143">I agree with that last bit. Mr. Coward, you will never be trusted again!</div>
	</div>

	<div class="commentSub" id="comment_sub_55574143">

</div>
</div>

<div id="replyto_55574143"></div>

<ul id="group_55574143">
	<li id="hiddens_55574143" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55573509" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573509" class="commentstatus"></div>
<div id="comment_55573509" class="cw">
	<div id="comment_top_55573509" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573509" name="comment_link_55573509" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573509" onclick="return D2.setFocusComment(55573509)" >Re:</a>


		 	<span id="comment_score_55573509" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573509); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ctilsie242">ctilsie242</a>  <span class="uid"><a href="//slashdot.org/~ctilsie242">( 4841247 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573509"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573509"><p>The Microsoft of the Halloween Documents doesn't exist anymore.  If Linux does something well, Microsoft can make money from it selling Azure to run tasks on.  If Android does well, Microsoft gets a chunk of every Android device going out there.  So, unlike the past, their revenue streams don't depend on just Windows for an OS.  For example, MS SQL server runs on Linux... and MS still gets their cut for licensing.</p><p>MS is still a corporation, and they are beholden to the bottom line above all, but MS hitching<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573509">

</div>
</div>

<div id="replyto_55573509"></div>

<ul id="group_55573509">
	<li id="hiddens_55573509" class="hide"></li>
</ul>

<ul id="commtree_55573509"><li id="tree_55573573" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573573" class="commentstatus"></div>
<div id="comment_55573573" class="cw">
	<div id="comment_top_55573573" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573573" name="comment_link_55573573" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573573" onclick="return D2.setFocusComment(55573573)" >Re: It's more like Embrace and Extend. No Extingui</a>


		 	<span id="comment_score_55573573" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573573); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573573"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573573">So Microsoft hasn't changed because they will stop at nothing to make more money any way they can, regardless of it's impact on society or computing? Microsoft hasn't changed. Windows 10 proves that they will get away with whatever they can and leverage ignorance to line their pockets at every opportunity.</div>
	</div>

	<div class="commentSub" id="comment_sub_55573573">

</div>
</div>

<div id="replyto_55573573"></div>

<ul id="group_55573573">
	<li id="hiddens_55573573" class="hide"></li>
</ul>

<ul id="commtree_55573573"><li id="tree_55573711" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573711" class="commentstatus"></div>
<div id="comment_55573711" class="cw">
</div>

<div id="replyto_55573711"></div>

<ul id="group_55573711">
	<li id="hiddens_55573711" class="hide"></li>
</ul>

</li><li id="tree_55573767" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573767" class="commentstatus"></div>
<div id="comment_55573767" class="cw">
	<div id="comment_top_55573767" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573767" name="comment_link_55573767" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573767" onclick="return D2.setFocusComment(55573767)" >Re:</a>


		 	<span id="comment_score_55573767" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573767); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Scaba">Scaba</a>  <span class="uid"><a href="//slashdot.org/~Scaba">( 183684 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573767"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573767">Can you provide the data you used to make these claims?</div>
	</div>

	<div class="commentSub" id="comment_sub_55573767">

</div>
</div>

<div id="replyto_55573767"></div>

<ul id="group_55573767">
	<li id="hiddens_55573767" class="hide"></li>
</ul>

<ul id="commtree_55573767"><li id="tree_55573825" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573825" class="commentstatus"></div>
<div id="comment_55573825" class="cw">
	<div id="comment_top_55573825" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573825" name="comment_link_55573825" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573825" onclick="return D2.setFocusComment(55573825)" >Re:  It's more like Embrace and Extend. No Extingu</a>


		 	<span id="comment_score_55573825" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573825); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573825"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573825">Sure. <a href="https://google.com/" title="google.com">Here you go<nobr> <wbr></nobr>...</a> [google.com]</div>
	</div>

	<div class="commentSub" id="comment_sub_55573825">

</div>
</div>

<div id="replyto_55573825"></div>

<ul id="group_55573825">
	<li id="hiddens_55573825" class="hide"></li>
</ul>

<ul id="commtree_55573825"><li id="tree_55574011" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574011" class="commentstatus"></div>
<div id="comment_55574011" class="cw">
	<div id="comment_top_55574011" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574011" name="comment_link_55574011" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574011" onclick="return D2.setFocusComment(55574011)" >Re:</a>


		 	<span id="comment_score_55574011" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574011); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Scaba">Scaba</a>  <span class="uid"><a href="//slashdot.org/~Scaba">( 183684 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574011"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574011">Ah, you don't have any data, so you doubled down on your ignorance. Let me guess - you're a Trump supporter?</div>
	</div>

	<div class="commentSub" id="comment_sub_55574011">

</div>
</div>

<div id="replyto_55574011"></div>

<ul id="group_55574011">
	<li id="hiddens_55574011" class="hide"></li>
</ul>

<ul id="commtree_55574011"><li id="tree_55574077" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574077" class="commentstatus"></div>
<div id="comment_55574077" class="cw">
	<div id="comment_top_55574077" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574077" name="comment_link_55574077" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574077" onclick="return D2.setFocusComment(55574077)" >Re:  It's more like Embrace and Extend. No Extingu</a>


		 	<span id="comment_score_55574077" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574077); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574077"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574077">If you can't find the information there you are too stupid to understand it anyway. Just as there is no question that Trump is a degenerate sociopath who takes advantage of the weak and ignorant, so to is it well proven throughout the years that Microsoft is the corporate equivalent.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574077">

</div>
</div>

<div id="replyto_55574077"></div>

<ul id="group_55574077">
	<li id="hiddens_55574077" class="hide"></li>
</ul>

<ul id="commtree_55574077"><li id="tree_55574263" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574263" class="commentstatus"></div>
<div id="comment_55574263" class="cw">
	<div id="comment_top_55574263" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574263" name="comment_link_55574263" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574263" onclick="return D2.setFocusComment(55574263)" >Re:</a>


		 	<span id="comment_score_55574263" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574263); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Scaba">Scaba</a>  <span class="uid"><a href="//slashdot.org/~Scaba">( 183684 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574263"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574263">The larger point, which you missed whilst sniffing your farts, is that those who are challenged to provide data to to back their claims but actually have no data will more likely than not often post a link to Google and demand the challenger find the data themselves while simultaneously trying to "blame the victim". You are weak and ignorant, so my guess that you are a Trump supporter is not without merit.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574263">

</div>
</div>

<div id="replyto_55574263"></div>

<ul id="group_55574263">
	<li id="hiddens_55574263" class="hide"></li>
</ul>

</li><li id="tree_55574577" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574577" class="commentstatus"></div>
<div id="comment_55574577" class="cw">
	<div id="comment_top_55574577" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574577" name="comment_link_55574577" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574577" onclick="return D2.setFocusComment(55574577)" >Re:</a>


		 	<span id="comment_score_55574577" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574577); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574577"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574577"><p>From just an information theory perspective, you've demanded that research be done but you haven't actually specified anything more specific than "MicroSoft hasn't changed."</p><p>And I impeach that by pointing out that once upon a time their product was a computer language written by hand by Bill and Paul. And now, Bill and Paul are off doing other things, they don't write the code by hand from the datasheet without a computer anymore. Somebody completely different is blindly pounding out code now! So we know tha<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574577">

</div>
</div>

<div id="replyto_55574577"></div>

<ul id="group_55574577">
	<li id="hiddens_55574577" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="hidestring_55573573"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573573">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="hidestring_55573269"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573269">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573271" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573271" class="commentstatus"></div>
<div id="comment_55573271" class="cw">
</div>

<div id="replyto_55573271"></div>

<ul id="group_55573271">
	<li id="hiddens_55573271" class="hide"></li>
</ul>

<ul id="commtree_55573271"><li id="tree_55573565" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573565" class="commentstatus"></div>
<div id="comment_55573565" class="cw">
	<div id="comment_top_55573565" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573565" name="comment_link_55573565" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573565" onclick="return D2.setFocusComment(55573565)" >Re:</a>


		 	<span id="comment_score_55573565" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573565); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ctilsie242">ctilsie242</a>  <span class="uid"><a href="//slashdot.org/~ctilsie242">( 4841247 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573565"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573565"><p>Microsoft was a strong mobile player.  The problem is that Apple changed the entirety of what people expected in mobile phones, and MS had to pivot to keep up with it.  Before the iPhone, the stylus was part of the interface, as well as a physical hardware keyboard.  The iPhone set user expectations to a completely different style.</p><p>I will give credit to MS for several things.  There is nothing out there as scalable as AD for users, computers, and other core organization in a company.  The DHCP protocol is al<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573565">

</div>
</div>

<div id="replyto_55573565"></div>

<ul id="group_55573565">
	<li id="hiddens_55573565" class="hide"></li>
</ul>

<ul id="commtree_55573565"><li id="tree_55573761" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573761" class="commentstatus"></div>
<div id="comment_55573761" class="cw">
</div>

<div id="replyto_55573761"></div>

<ul id="group_55573761">
	<li id="hiddens_55573761" class="hide"></li>
</ul>

<ul id="commtree_55573761"><li id="tree_55574315" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574315" class="commentstatus"></div>
<div id="comment_55574315" class="cw">
	<div id="comment_top_55574315" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574315" name="comment_link_55574315" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574315" onclick="return D2.setFocusComment(55574315)" >Re:</a>


		 	<span id="comment_score_55574315" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574315); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~barbariccow">barbariccow</a>  <span class="uid"><a href="//slashdot.org/~barbariccow">( 1476631 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574315"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574315">Microsoft doesn't even follow the DHCP spec in several ways...</div>
	</div>

	<div class="commentSub" id="comment_sub_55574315">

</div>
</div>

<div id="replyto_55574315"></div>

<ul id="group_55574315">
	<li id="hiddens_55574315" class="hide"></li>
</ul>

</li><li id="tree_55574317" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574317" class="commentstatus"></div>
<div id="comment_55574317" class="cw">
	<div id="comment_top_55574317" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574317" name="comment_link_55574317" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574317" onclick="return D2.setFocusComment(55574317)" >Re:</a>


		 	<span id="comment_score_55574317" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574317); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~barbariccow">barbariccow</a>  <span class="uid"><a href="//slashdot.org/~barbariccow">( 1476631 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574317"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574317">Also, github is a web interface on top of git. gitlab is a shitty alternative. Both use "git' as the underlying server and client tools.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574317">

</div>
</div>

<div id="replyto_55574317"></div>

<ul id="group_55574317">
	<li id="hiddens_55574317" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55573565"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573565">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55573421" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573421" class="commentstatus"></div>
<div id="comment_55573421" class="cw">
</div>

<div id="replyto_55573421"></div>

<ul id="group_55573421">
	<li id="hiddens_55573421" class="hide"></li>
</ul>

<ul id="commtree_55573421"><li id="tree_55573505" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573505" class="commentstatus"></div>
<div id="comment_55573505" class="cw">
</div>

<div id="replyto_55573505"></div>

<ul id="group_55573505">
	<li id="hiddens_55573505" class="hide"></li>
</ul>

<ul id="commtree_55573505"><li id="tree_55573541" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573541" class="commentstatus"></div>
<div id="comment_55573541" class="cw">
</div>

<div id="replyto_55573541"></div>

<ul id="group_55573541">
	<li id="hiddens_55573541" class="hide"></li>
</ul>

</li><li id="hidestring_55573505"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573505">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55573421"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573421">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55574549" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574549" class="commentstatus"></div>
<div id="comment_55574549" class="cw">
	<div id="comment_top_55574549" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574549" name="comment_link_55574549" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574549" onclick="return D2.setFocusComment(55574549)" >Re:</a>


		 	<span id="comment_score_55574549" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574549); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574549"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574549"><p>The truth is, even though MS are the good guys these days I still put black tape over their keyboard logo.</p><p>But they are pretty nice keyboards.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574549">

</div>
</div>

<div id="replyto_55574549"></div>

<ul id="group_55574549">
	<li id="hiddens_55574549" class="hide"></li>
</ul>

</li><li id="hidestring_55573051"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573051">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573073" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573073" class="commentstatus"></div>
<div id="comment_55573073" class="cw">
</div>

<div id="replyto_55573073"></div>

<ul id="group_55573073">
	<li id="hiddens_55573073" class="hide"></li>
</ul>

<ul id="commtree_55573073"><li id="tree_55573591" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573591" class="commentstatus"></div>
<div id="comment_55573591" class="cw">
	<div id="comment_top_55573591" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573591" name="comment_link_55573591" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573591" onclick="return D2.setFocusComment(55573591)" >Re: The obvious solution is to use gitd</a>


		 	<span id="comment_score_55573591" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573591); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573591"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573591">There are no git performance issues. There are Windows performance issues. In typical Microsoft fashion they aren't going to make their product better, but rather try to get others to behave differently so that they don't have to fix their garbage.</div>
	</div>

	<div class="commentSub" id="comment_sub_55573591">

</div>
</div>

<div id="replyto_55573591"></div>

<ul id="group_55573591">
	<li id="hiddens_55573591" class="hide"></li>
</ul>

</li><li id="tree_55573949" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573949" class="commentstatus"></div>
<div id="comment_55573949" class="cw">
	<div id="comment_top_55573949" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573949" name="comment_link_55573949" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573949" onclick="return D2.setFocusComment(55573949)" >Re:</a>


		 	<span id="comment_score_55573949" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573949); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jeremyp">jeremyp</a>  <span class="uid"><a href="//slashdot.org/~jeremyp">( 130771 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573949"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573949"><p>You mean systemd-git</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573949">

</div>
</div>

<div id="replyto_55573949"></div>

<ul id="group_55573949">
	<li id="hiddens_55573949" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55573087" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573087" class="commentstatus"></div>
<div id="comment_55573087" class="cw">
</div>

<div id="replyto_55573087"></div>

<ul id="group_55573087">
	<li id="hiddens_55573087" class="hide"></li>
</ul>

<ul id="commtree_55573087"><li id="tree_55573249" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55573249" class="commentstatus"></div>
<div id="comment_55573249" class="cw">
	<div id="comment_top_55573249" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573249" name="comment_link_55573249" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573249" onclick="return D2.setFocusComment(55573249)" >Re:Fuck GitHub</a>


		 	<span id="comment_score_55573249" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573249); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TFlan91">TFlan91</a>  <span class="uid"><a href="//slashdot.org/~TFlan91">( 2615727 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573249">		
		on Friday November 17, 2017 @05:50PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573249">#55573249</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573249"><p>Cool story bro.</p><p>Good thing you don't need GitHub to use Git, right?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573249">
<span class="ind"></span><a id="reply_link_55573249" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573249" onclick="D2.replyTo(55573249); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55573087" onclick="return D2.selectParent(55573087)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Fuck GitHub by TFlan91 @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573249" data-title="Re:Fuck GitHub">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Fuck GitHub by TFlan91" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573249" data-title="Re:Fuck GitHub">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Fuck GitHub by TFlan91" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573249" data-title="Re:Fuck GitHub">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11372285%26cid=55573249" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55573249" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573249" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55573249"></div>

<ul id="group_55573249">
	<li id="hiddens_55573249" class="hide"></li>
</ul>

<ul id="commtree_55573249"><li id="tree_55573373" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573373" class="commentstatus"></div>
<div id="comment_55573373" class="cw">
</div>

<div id="replyto_55573373"></div>

<ul id="group_55573373">
	<li id="hiddens_55573373" class="hide"></li>
</ul>

<ul id="commtree_55573373"><li id="tree_55573487" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573487" class="commentstatus"></div>
<div id="comment_55573487" class="cw">
</div>

<div id="replyto_55573487"></div>

<ul id="group_55573487">
	<li id="hiddens_55573487" class="hide"></li>
</ul>

</li><li id="tree_55573533" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573533" class="commentstatus"></div>
<div id="comment_55573533" class="cw">
	<div id="comment_top_55573533" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573533" name="comment_link_55573533" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573533" onclick="return D2.setFocusComment(55573533)" >Re:</a>


		 	<span id="comment_score_55573533" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573533); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573533"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573533"><p>It's not hard to put git on a server that users have access to in a small corporate setting that then provides a central location to push to and pull from without needing GitLab to front it. It's nicer with something like that there, but not essential. The main issues with development are still communications and resolving branching for business needs, and merging when the communication regarding changes was insufficient. A nice front end to git doesn't currently fix that.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573533">

</div>
</div>

<div id="replyto_55573533"></div>

<ul id="group_55573533">
	<li id="hiddens_55573533" class="hide"></li>
</ul>

</li><li id="tree_55574243" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574243" class="commentstatus"></div>
<div id="comment_55574243" class="cw">
	<div id="comment_top_55574243" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574243" name="comment_link_55574243" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574243" onclick="return D2.setFocusComment(55574243)" >Re:</a>


		 	<span id="comment_score_55574243" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574243); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MSG">MSG</a>  <span class="uid"><a href="//slashdot.org/~MSG">( 12810 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574243"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574243"><p>Exactly.  And what better authority than git's author?  If you want to send him a patch, you just make a pull request, right?</p><p>Wait, the Linux team doesn't use github?  Isn't that peculiar?<nobr> <wbr></nobr>:)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574243">

</div>
</div>

<div id="replyto_55574243"></div>

<ul id="group_55574243">
	<li id="hiddens_55574243" class="hide"></li>
</ul>

</li><li id="hidestring_55573373"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573373">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573845" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573845" class="commentstatus"></div>
<div id="comment_55573845" class="cw">
</div>

<div id="replyto_55573845"></div>

<ul id="group_55573845">
	<li id="hiddens_55573845" class="hide"></li>
</ul>

</li><li id="hidestring_55573249"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573249">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55573135" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573135" class="commentstatus"></div>
<div id="comment_55573135" class="cw">
</div>

<div id="replyto_55573135"></div>

<ul id="group_55573135">
	<li id="hiddens_55573135" class="hide"></li>
</ul>

<ul id="commtree_55573135"><li id="tree_55573469" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573469" class="commentstatus"></div>
<div id="comment_55573469" class="cw">
</div>

<div id="replyto_55573469"></div>

<ul id="group_55573469">
	<li id="hiddens_55573469" class="hide"></li>
</ul>

</li><li id="hidestring_55573135"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573135">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573161" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573161" class="commentstatus"></div>
<div id="comment_55573161" class="cw">
	<div id="comment_top_55573161" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573161" name="comment_link_55573161" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573161" onclick="return D2.setFocusComment(55573161)" >ClearCase again</a>


		 	<span id="comment_score_55573161" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573161); return false"><span class=opt>Score:</span>2</a>, Troll)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gillbates">gillbates</a>  <span class="uid"><a href="//slashdot.org/~gillbates">( 106458 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573161"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573161"><p>
So, if I understand it right, they've just reinvented the MVFS system pioneered by ClearCase decades ago?
</p><p>
The whole point of git was to have a decentralized repository, so that the repository could be rebuilt from anyone's local repository in the case of failure.
</p><p>
But the larger problem is that if your dependencies aren't properly managed, you end up downloading the whole repository when you build anyway, so the only thing they've accomplished is delaying the build step rather than the clone step.
</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573161">

</div>
</div>

<div id="replyto_55573161"></div>

<ul id="group_55573161">
	<li id="hiddens_55573161" class="hide"></li>
</ul>

<ul id="commtree_55573161"><li id="tree_55573225" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573225" class="commentstatus"></div>
<div id="comment_55573225" class="cw">
</div>

<div id="replyto_55573225"></div>

<ul id="group_55573225">
	<li id="hiddens_55573225" class="hide"></li>
</ul>

</li><li id="tree_55573379" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573379" class="commentstatus"></div>
<div id="comment_55573379" class="cw">
	<div id="comment_top_55573379" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573379" name="comment_link_55573379" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573379" onclick="return D2.setFocusComment(55573379)" >Re:</a>


		 	<span id="comment_score_55573379" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573379); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlhIngan">tlhIngan</a>  <span class="uid"><a href="//slashdot.org/~tlhIngan">( 30335 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573379"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573379"><blockquote><div><p>But the larger problem is that if your dependencies aren't properly managed, you end up downloading the whole repository when you build anyway, so the only thing they've accomplished is delaying the build step rather than the clone step.</p></div><span class="substr"> </span></blockquote><p>Which is generally fine, since you clone the code so you can dive into it - look at it, make changes, etc. If the first build takes longer because you have to grab the repository, I'm OK with that - I usually schedule the build to happen overnight anyways, so whether it fin</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573379">

</div>
</div>

<div id="replyto_55573379"></div>

<ul id="group_55573379">
	<li id="hiddens_55573379" class="hide"></li>
</ul>

<ul id="commtree_55573379"><li id="tree_55574211" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55574211" class="commentstatus"></div>
<div id="comment_55574211" class="cw">
	<div id="comment_top_55574211" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574211" name="comment_link_55574211" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574211" onclick="return D2.setFocusComment(55574211)" >Re: ClearCase again</a>


		 	<span id="comment_score_55574211" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574211); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Zero__Kelvin">Zero__Kelvin</a>  <span class="uid"><a href="//slashdot.org/~Zero__Kelvin">( 151819 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574211">		
		on Friday November 17, 2017 @09:10PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574211">#55574211</a>)
		<small><a href="http://127.0.0.1/" title="http://127.0.0.1/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574211">No, it isn't generally fine. You can't have a distributed SCM and break the distributed part. Microsoft literally breaks git. I am guessing the half that was accepted upstream was the part that doesn't, and the half that does break it will never be accepted.  Make no mistake about it their approach breaks git by design, intentional or otherwise.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574211">
<span class="ind"></span><a id="reply_link_55574211" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55574211" onclick="D2.replyTo(55574211); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55573379" onclick="return D2.selectParent(55573379)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: ClearCase again by Zero__Kelvin @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574211" data-title="Re: ClearCase again">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: ClearCase again by Zero__Kelvin" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574211" data-title="Re: ClearCase again">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: ClearCase again by Zero__Kelvin" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574211" data-title="Re: ClearCase again">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11372285%26cid=55574211" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55574211" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55574211" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55574211"></div>

<ul id="group_55574211">
	<li id="hiddens_55574211" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55574711" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574711" class="commentstatus"></div>
<div id="comment_55574711" class="cw">
	<div id="comment_top_55574711" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574711" name="comment_link_55574711" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574711" onclick="return D2.setFocusComment(55574711)" >Re: ClearCase again</a>


		 	<span id="comment_score_55574711" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574711); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dwater">dwater</a>  <span class="uid"><a href="//slashdot.org/~dwater">( 72834 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574711"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574711"><p>Troll?? I noticed the similarly too, though I've not looked into the details.<br>I actually liked ClearCase...first used it when it was an Atria product and then when it was part of the CaseVision suite on SGI platforms. I have yet find anyone else who feels the same though.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574711">

</div>
</div>

<div id="replyto_55574711"></div>

<ul id="group_55574711">
	<li id="hiddens_55574711" class="hide"></li>
</ul>

</li><li id="hidestring_55573161"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573161">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573211" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573211" class="commentstatus"></div>
<div id="comment_55573211" class="cw">
	<div id="comment_top_55573211" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573211" name="comment_link_55573211" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573211" onclick="return D2.setFocusComment(55573211)" >Oblg. "Its a trap!"</a>


		 	<span id="comment_score_55573211" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573211); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~UnknownSoldier">UnknownSoldier</a>  <span class="uid"><a href="//slashdot.org/~UnknownSoldier">( 67820 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573211"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573211"><p>The <i>skeptical</i> side of my is saying <a href="https://www.youtube.com/watch?v=4F4qzPbcFiA" title="youtube.com">"It's a trap!"</a> [youtube.com]</p><p>The <i>practical</i> side of me is suspending judgement and waiting to see how this play outs because MS, at this point, has ZERO confidence that they won't hijack this.</p><p>--<br><i>"Those who forget history are doomed to repeat it, badly"</i> -- paraphrasing George Santayana</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573211">

</div>
</div>

<div id="replyto_55573211"></div>

<ul id="group_55573211">
	<li id="hiddens_55573211" class="hide"></li>
</ul>

<ul id="commtree_55573211"><li id="tree_55573287" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573287" class="commentstatus"></div>
<div id="comment_55573287" class="cw">
</div>

<div id="replyto_55573287"></div>

<ul id="group_55573287">
	<li id="hiddens_55573287" class="hide"></li>
</ul>

<ul id="commtree_55573287"><li id="tree_55573435" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573435" class="commentstatus"></div>
<div id="comment_55573435" class="cw">
	<div id="comment_top_55573435" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573435" name="comment_link_55573435" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573435" onclick="return D2.setFocusComment(55573435)" >Re:</a>


		 	<span id="comment_score_55573435" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573435); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MightyYar">MightyYar</a>  <span class="uid"><a href="//slashdot.org/~MightyYar">( 622222 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573435"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573435"><p>Not for network access, for local file access - just like all the other filesystem drivers.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573435">

</div>
</div>

<div id="replyto_55573435"></div>

<ul id="group_55573435">
	<li id="hiddens_55573435" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55573763" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573763" class="commentstatus"></div>
<div id="comment_55573763" class="cw">
	<div id="comment_top_55573763" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573763" name="comment_link_55573763" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573763" onclick="return D2.setFocusComment(55573763)" >Re:</a>


		 	<span id="comment_score_55573763" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573763); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~eclectro">eclectro</a>  <span class="uid"><a href="//slashdot.org/~eclectro">( 227083 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573763"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573763"><p>Brother, any Slashdotter whose blood is Slashdot green would be saying the same things, or maybe "We are in the embrace phase, just before the "hug of death."</p><p>I really can't help but wonder myself how they're going to twist the knife.here.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573763">

</div>
</div>

<div id="replyto_55573763"></div>

<ul id="group_55573763">
	<li id="hiddens_55573763" class="hide"></li>
</ul>

</li><li id="hidestring_55573211"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573211">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573291" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573291" class="commentstatus"></div>
<div id="comment_55573291" class="cw">
</div>

<div id="replyto_55573291"></div>

<ul id="group_55573291">
	<li id="hiddens_55573291" class="hide"></li>
</ul>

</li><li id="tree_55573391" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573391" class="commentstatus"></div>
<div id="comment_55573391" class="cw">
	<div id="comment_top_55573391" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573391" name="comment_link_55573391" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573391" onclick="return D2.setFocusComment(55573391)" >First...</a>


		 	<span id="comment_score_55573391" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573391); return false"><span class=opt>Score:</span>2</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hallux-F-Sinister">Hallux-F-Sinister</a>  <span class="uid"><a href="//slashdot.org/~Hallux-F-Sinister">( 5127197 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573391"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573391">Not to be that guy, but 'typo in headline.'  "GNU/Linux" is misspelled.  (Sorry, I guess it turns out that I <b>AM</b> that guy.)  Second... it's Micro$oft, and therefore, the fact that it's a trap kind of goes without saying.</div>
	</div>

	<div class="commentSub" id="comment_sub_55573391">

</div>
</div>

<div id="replyto_55573391"></div>

<ul id="group_55573391">
	<li id="hiddens_55573391" class="hide"></li>
</ul>

<ul id="commtree_55573391"><li id="tree_55573431" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55573431" class="commentstatus"></div>
<div id="comment_55573431" class="cw">
</div>

<div id="replyto_55573431"></div>

<ul id="group_55573431">
	<li id="hiddens_55573431" class="hide"></li>
</ul>

<ul id="commtree_55573431"><li id="tree_55573463" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573463" class="commentstatus"></div>
<div id="comment_55573463" class="cw">
	<div id="comment_top_55573463" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573463" name="comment_link_55573463" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573463" onclick="return D2.setFocusComment(55573463)" >Re:</a>


		 	<span id="comment_score_55573463" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573463); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~david.emery">david.emery</a>  <span class="uid"><a href="//slashdot.org/~david.emery">( 127135 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573463"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573463"><p>4 Decimal or 4 Hex digits?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573463">

</div>
</div>

<div id="replyto_55573463"></div>

<ul id="group_55573463">
	<li id="hiddens_55573463" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55573391"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573391">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573415" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573415" class="commentstatus"></div>
<div id="comment_55573415" class="cw">
	<div id="comment_top_55573415" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573415" name="comment_link_55573415" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573415" onclick="return D2.setFocusComment(55573415)" >Oh Great</a>


		 	<span id="comment_score_55573415" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573415); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NicknameUnavailable">NicknameUnavailable</a>  <span class="uid"><a href="//slashdot.org/~NicknameUnavailable">( 4134147 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573415"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573415">So what backdoors did they manage to stick in the upstream version of the Git source?</div>
	</div>

	<div class="commentSub" id="comment_sub_55573415">

</div>
</div>

<div id="replyto_55573415"></div>

<ul id="group_55573415">
	<li id="hiddens_55573415" class="hide"></li>
</ul>

<ul id="commtree_55573415"><li id="tree_55573859" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573859" class="commentstatus"></div>
<div id="comment_55573859" class="cw">
	<div id="comment_top_55573859" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573859" name="comment_link_55573859" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573859" onclick="return D2.setFocusComment(55573859)" >Re:</a>


		 	<span id="comment_score_55573859" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573859); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Scaba">Scaba</a>  <span class="uid"><a href="//slashdot.org/~Scaba">( 183684 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573859"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573859">The source is available, so you tell us</div>
	</div>

	<div class="commentSub" id="comment_sub_55573859">

</div>
</div>

<div id="replyto_55573859"></div>

<ul id="group_55573859">
	<li id="hiddens_55573859" class="hide"></li>
</ul>

<ul id="commtree_55573859"><li id="tree_55574557" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574557" class="commentstatus"></div>
<div id="comment_55574557" class="cw">
	<div id="comment_top_55574557" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574557" name="comment_link_55574557" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574557" onclick="return D2.setFocusComment(55574557)" >Re:</a>


		 	<span id="comment_score_55574557" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574557); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NicknameUnavailable">NicknameUnavailable</a>  <span class="uid"><a href="//slashdot.org/~NicknameUnavailable">( 4134147 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574557"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574557">What a lazy attempt to shill.  Looks like the same thing they did to corrupt Skype by changing it from a distributed system to a central repository.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574557">

</div>
</div>

<div id="replyto_55574557"></div>

<ul id="group_55574557">
	<li id="hiddens_55574557" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_55573599" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55573599" class="commentstatus"></div>
<div id="comment_55573599" class="cw">
	<div id="comment_top_55573599" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573599" name="comment_link_55573599" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573599" onclick="return D2.setFocusComment(55573599)" >Git virtual file system...</a>


		 	<span id="comment_score_55573599" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573599); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~B1ackDragon">B1ackDragon</a>  <span class="uid"><a href="//slashdot.org/~B1ackDragon">( 543470 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573599">		
		on Friday November 17, 2017 @06:52PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573599">#55573599</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573599"><p>I've heard of people using git for strange purposes (blogging?!) but for a second reading this headline I had the horrific thought that someone was attempting to create a filesystem backed by git.</p><p>Fortunately that's not the case, <a href="https://github.com/Microsoft/GVFS" title="github.com">GVFS</a> [github.com] (not that <a href="https://github.com/Microsoft/GVFS/issues/7" title="github.com">other GVFS</a> [github.com]) provides a git-compatible filesystem abstraction on Windows 10. </p><p>Although I'm not a big git fan, I do have to say I'm impressed with Microsoft's recent moves toward open-source and interoperability. If the Linux Subsystem is ever a first-class citizen in the MS ecosystem, I could even see myself using Windows again.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573599">
<span class="ind"></span><a id="reply_link_55573599" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573599" onclick="D2.replyTo(55573599); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Git virtual file system... by B1ackDragon @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573599" data-title="Git virtual file system...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Git virtual file system... by B1ackDragon" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573599" data-title="Git virtual file system...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Git virtual file system... by B1ackDragon" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573599" data-title="Git virtual file system...">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11372285%26cid=55573599" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55573599" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573599" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55573599"></div>

<ul id="group_55573599">
	<li id="hiddens_55573599" class="hide"></li>
</ul>

</li><li id="tree_55573623" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55573623" class="commentstatus"></div>
<div id="comment_55573623" class="cw">
	<div id="comment_top_55573623" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573623" name="comment_link_55573623" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573623" onclick="return D2.setFocusComment(55573623)" >Being trendy has a cost</a>


		 	<span id="comment_score_55573623" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573623); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573623">		
		on Friday November 17, 2017 @06:55PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573623">#55573623</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573623"><p>This is what happens when you pick technologies by popularity and groupthink.  Git has very real flaws: the worst UI of any source control system I've ever used, inability to deal with large repositories, a confused and overcomplicated operational model, trouble with storing large binaries.  You can always spot the people who learned Git as their first VCS: when confronted with these problems, they'll say things like "monorepos are bad" or "the CLI tools were always meant to have 'porcelain' built on top of them, not used directly, so it's fine if they suck" -- they have drunk the koolaid and can't see things any other way or explain real counterexamples to the contrary.</p><p>For hobby projects these are academic problems, but if you're working at the scale of a complete operating system then you have to confront Git's weaknesses head-on and fix them.  The fact that MS felt it was worth going down this rabbithole just to follow the crowd is sad.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55573623">
<span class="ind"></span><a id="reply_link_55573623" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573623" onclick="D2.replyTo(55573623); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Being trendy has a cost by Anonymous Coward @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573623" data-title="Being trendy has a cost">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Being trendy has a cost by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573623" data-title="Being trendy has a cost">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Being trendy has a cost by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55573623" data-title="Being trendy has a cost">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11372285%26cid=55573623" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55573623" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55573623" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55573623"></div>

<ul id="group_55573623">
	<li id="hiddens_55573623" class="hide"></li>
</ul>

<ul id="commtree_55573623"><li id="tree_55574251" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574251" class="commentstatus"></div>
<div id="comment_55574251" class="cw">
	<div id="comment_top_55574251" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574251" name="comment_link_55574251" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574251" onclick="return D2.setFocusComment(55574251)" >Re:</a>


		 	<span id="comment_score_55574251" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574251); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Daltorak">Daltorak</a>  <span class="uid"><a href="//slashdot.org/~Daltorak">( 122403 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574251"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574251"><p><div class="quote"><p>This is what happens when you pick technologies by popularity and groupthink.  Git has very real flaws: the worst UI of any source control system I've ever used,</p></div><p>Whoah, whoah, whoah, now wait a sec here.  We're talking about a program invented by Linus Torvalds, the creator of a kernel that routinely sits under userlands where a synonym of "feline" prints the contents of files, where a household cleaner (vim) is a text editor, where "more" and "less" do the same thing despite being literal opposites, and where sometimes, but not always, parameter names are case-sensitive (<b>rm -r == rm -R</b> but <b>rm -i != rm -I</b>).</p><p>So of <i>course</i> git is hard to learn.  Just like Linux itself,<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574251">

</div>
</div>

<div id="replyto_55574251"></div>

<ul id="group_55574251">
	<li id="hiddens_55574251" class="hide"></li>
</ul>

<ul id="commtree_55574251"><li id="tree_55574469" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55574469" class="commentstatus"></div>
<div id="comment_55574469" class="cw">
</div>

<div id="replyto_55574469"></div>

<ul id="group_55574469">
	<li id="hiddens_55574469" class="hide"></li>
</ul>

</li><li id="hidestring_55574251"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55574251">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55574271" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55574271" class="commentstatus"></div>
<div id="comment_55574271" class="cw">
</div>

<div id="replyto_55574271"></div>

<ul id="group_55574271">
	<li id="hiddens_55574271" class="hide"></li>
</ul>

</li><li id="tree_55574467" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55574467" class="commentstatus"></div>
<div id="comment_55574467" class="cw">
</div>

<div id="replyto_55574467"></div>

<ul id="group_55574467">
	<li id="hiddens_55574467" class="hide"></li>
</ul>

</li><li id="tree_55574869" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574869" class="commentstatus"></div>
<div id="comment_55574869" class="cw">
	<div id="comment_top_55574869" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574869" name="comment_link_55574869" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574869" onclick="return D2.setFocusComment(55574869)" >Re:</a>


		 	<span id="comment_score_55574869" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574869); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574869"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574869"><p><div class="quote"><p>Git has very real flaws: the worst UI of any source control system I've ever used</p></div><p>Whenever someone says this, ask them if they are comfortable with the command-line. The answer is always no.</p><p><div class="quote"><p>For hobby projects these are academic problems, but if you're working at the scale of a complete operating system then you have to confront Git's weaknesses head-on and fix them.</p></div><p>Nah, there are huge, professional projects already using GIT.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574869">

</div>
</div>

<div id="replyto_55574869"></div>

<ul id="group_55574869">
	<li id="hiddens_55574869" class="hide"></li>
</ul>

</li><li id="hidestring_55573623"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55573623">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55573695" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55573695" class="commentstatus"></div>
<div id="comment_55573695" class="cw">
	<div id="comment_top_55573695" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55573695" name="comment_link_55573695" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55573695" onclick="return D2.setFocusComment(55573695)" >Microsoft is irrelevant </a>


		 	<span id="comment_score_55573695" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55573695); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~newdsfornerds">newdsfornerds</a>  <span class="uid"><a href="//slashdot.org/~newdsfornerds">( 899401 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55573695"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55573695">They can suck my codpiece.</div>
	</div>

	<div class="commentSub" id="comment_sub_55573695">

</div>
</div>

<div id="replyto_55573695"></div>

<ul id="group_55573695">
	<li id="hiddens_55573695" class="hide"></li>
</ul>

</li><li id="tree_55574213" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55574213" class="commentstatus"></div>
<div id="comment_55574213" class="cw">
	<div id="comment_top_55574213" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574213" name="comment_link_55574213" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574213" onclick="return D2.setFocusComment(55574213)" >git was made to make version control decentralized</a>


		 	<span id="comment_score_55574213" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574213); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ffkom">ffkom</a>  <span class="uid"><a href="//slashdot.org/~ffkom">( 3519199 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574213">		
		on Friday November 17, 2017 @09:10PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574213">#55574213</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574213">Now MicroSoft tries to turn it into the opposite, asking developers to depend on some remote repository in order to be able to work.<br> <br>
The obvious agenda here is to make repository hosting first more centralized, then more "hosted at MicroSoft", then, once people depend on the hosted service, demand monthly fees for it.</div>
	</div>

	<div class="commentSub" id="comment_sub_55574213">
<span class="ind"></span><a id="reply_link_55574213" class="btn link" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55574213" onclick="D2.replyTo(55574213); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="git was made to make version control decentralized by ffkom @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574213" data-title="git was made to make version control decentralized">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="git was made to make version control decentralized by ffkom" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574213" data-title="git was made to make version control decentralized">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="git was made to make version control decentralized by ffkom" data-url="https://apple.slashdot.org/comments.pl?sid=11372285&cid=55574213" data-title="git was made to make version control decentralized">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=11372285%26cid=55574213" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55574213" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55574213" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55574213"></div>

<ul id="group_55574213">
	<li id="hiddens_55574213" class="hide"></li>
</ul>

<ul id="commtree_55574213"><li id="tree_55574755" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574755" class="commentstatus"></div>
<div id="comment_55574755" class="cw">
	<div id="comment_top_55574755" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574755" name="comment_link_55574755" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574755" onclick="return D2.setFocusComment(55574755)" >Re:</a>


		 	<span id="comment_score_55574755" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574755); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z34107">Z34107</a>  <span class="uid"><a href="//slashdot.org/~Z34107">( 925136 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574755"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574755"><blockquote><div><p>The obvious agenda here is to make repository hosting first more centralized, then more "hosted at MicroSoft", then, once people depend on the hosted service, demand monthly fees for it.</p></div></blockquote><p>
Nobody tell him <a href="https://github.com/pricing" title="github.com">GitHub<span class="substr"> </span></a> [github.com] already exists and charges money.  Microsoft's interested in GVFS is because 1) Git sucks at handling large repos, and 2) <a href="https://blogs.msdn.microsoft.com/devops/2017/02/03/announcing-gvfs-git-virtual-file-system/" title="microsoft.com">Microsoft has a 270GB repo</a> [microsoft.com].<br>

The <a href="https://developers.slashdot.org/story/17/02/03/1427213/microsoft-introduces-gvfs-git-virtual-file-system" title="slashdot.org">original<nobr> <wbr></nobr>/. article</a> [slashdot.org] back in Friday had better comments, including one linking <a href="https://blogs.msdn.microsoft.com/bharry/2017/02/03/scaling-git-and-some-back-story/" title="microsoft.com">an article describing why they chose Git for source control</a> [microsoft.com], and what</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574755">

</div>
</div>

<div id="replyto_55574755"></div>

<ul id="group_55574755">
	<li id="hiddens_55574755" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55574307" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574307" class="commentstatus"></div>
<div id="comment_55574307" class="cw">
	<div id="comment_top_55574307" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574307" name="comment_link_55574307" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574307" onclick="return D2.setFocusComment(55574307)" >apple?</a>


		 	<span id="comment_score_55574307" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574307); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~barbariccow">barbariccow</a>  <span class="uid"><a href="//slashdot.org/~barbariccow">( 1476631 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574307"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574307">Why is this story at apple.slashdot.org ?</div>
	</div>

	<div class="commentSub" id="comment_sub_55574307">

</div>
</div>

<div id="replyto_55574307"></div>

<ul id="group_55574307">
	<li id="hiddens_55574307" class="hide"></li>
</ul>

</li><li id="tree_55574851" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55574851" class="commentstatus"></div>
<div id="comment_55574851" class="cw">
	<div id="comment_top_55574851" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55574851" name="comment_link_55574851" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;cid=55574851" onclick="return D2.setFocusComment(55574851)" >Nah</a>


		 	<span id="comment_score_55574851" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55574851); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55574851"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55574851"><p><div class="quote"><p>Microsoft had to modify Git to handle the demands of Windows development but said that it wanted to get these modifications accepted upstream and integrated into the standard Git client.</p></div><p>They're very likely doing something wrong here.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55574851">

</div>
</div>

<div id="replyto_55574851"></div>

<ul id="group_55574851">
	<li id="hiddens_55574851" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=11372285&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">6 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//apple.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 24;
		D2.currents()['full']     = 5;
		D2.currents()['oneline']  = 40;
		// D2.currents_total(69);

		D2.abbrev_comments({55574577:522,55573509:521,55573565:522,55573379:267,55574755:311,55573269:547,55574251:738});
		D2.noshow_comments([55573023,55573037,55573099,55573405,55573711,55573271,55573761,55573421,55573505,55573541,55573073,55573087,55573373,55573487,55573845,55573135,55573469,55573225,55573287,55573291,55573431,55574469,55574271,55574467]);
		D2.pieces_comments([55573417,55573637,55573051,55573171,55573269,55573447,55574143,55573509,55573573,55573767,55573825,55574011,55574077,55574263,55574577,55573565,55574315,55574317,55574549,55573591,55573949,55573533,55574243,55573161,55573379,55574711,55573211,55573435,55573763,55573391,55573463,55573415,55573859,55574557,55574251,55574869,55573695,55574755,55574307,55574851]);
		D2.init_hiddens([55573573,55573269,55573565,55573505,55573421,55573051,55573373,55573249,55573135,55573161,55573211,55573391,55574251,55573623,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(333795);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>757<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/05/02/1916223/ask-slashdot-what-is-the-special-appeal-of-apple-products?sdsrc=popbyskidbtmprev">Ask Slashdot: What Is the 'Special Appeal' of Apple Products?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>529<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/10/18/1530202/maybe-its-a-piece-of-dust?sdsrc=popbyskidbtmprev">"Maybe It's a Piece of Dust"</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>517<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/07/26/1956206/tech-leaders-speak-out-against-trump-ban-on-transgender-troops?sdsrc=popbyskidbtmprev">Tech Leaders Speak Out Against Trump Ban on Transgender Troops</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>471<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/16/11/23/210222/trump-says-hes-going-to-get-apple-to-build-a-big-plant-in-the-united-states?sdsrc=popbyskidbtmprev">Trump Says He's Going To 'Get Apple To Build a Big Plant In the United States'</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>455<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/01/02/2031244/family-sues-apple-for-not-making-thing-it-patented?sdsrc=popbyskidbtmprev">Family Sues Apple For Not Making Thing It Patented</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//apple.slashdot.org/story/17/11/17/2138208/apples-homepod-gets-delayed-until-2018?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/music_64.png" width="64" height="64" alt="Music"></span>
	    
					<p class="grid_12"><a href="//apple.slashdot.org/story/17/11/17/2138208/apples-homepod-gets-delayed-until-2018?sdsrc=nextbtmprev">Apple's HomePod Gets Delayed Until 2018</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>33<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/11/17/215258/even-new-phones-are-no-longer-guaranteed-to-have-the-latest-version-of-android?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/android_64.png" width="64" height="64" alt="Android"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/11/17/215258/even-new-phones-are-no-longer-guaranteed-to-have-the-latest-version-of-android?sdsrc=prevbtmprev">Even New Phones Are No Longer Guaranteed To Have the Latest Version of Android</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>107<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=11372285&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">65</span> of <span class="totalcommentcnt">65</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Scientists will study your brain to learn more about your distant cousin, Man.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?908">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?996">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->