<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '224126248650846773',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="Slack, valued at $5 billion, has received buyout pitches from several companies including Amazon and Microsoft. But the team collaborations service, which has over 5 million active users, continues to offer one of the most resource intensive apps you could find on Mac and iOS. From an article: TLDR;...">
		<meta itemprop="name" content="Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App - Slashdot">
		<meta itemprop="description" content="Slack, valued at $5 billion, has received buyout pitches from several companies including Amazon and Microsoft. But the team collaborations service, which has over 5 million active users, continues to offer one of the most resource intensive apps you could find on Mac and iOS. From an article: TLDR;...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/business_64.png">
	
	
		<link rel="canonical" href="https://apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/329265" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?b44e3ae3434d951a" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?b44e3ae3434d951a" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?b44e3ae3434d951a" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?b44e3ae3434d951a">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: business mac money macos slack
  
  var backend_tpc = [[ "business", "mac", "money", "apple", "macos", "slack" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?b44e3ae3434d951a"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?b44e3ae3434d951a" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//apple.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotApple" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //apple.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Follow <a href="//slashdot.org/blog">Slashdot blog</a> updates by <a href="http://feeds.feedburner.com/SlashdotSitenews">subscribing to our blog RSS feed</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Also, <strong>Slashdot's <a href="https://ifttt.com/slashdot" rel="nofollow">now on IFTTT.</a></strong> Check it out! Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 Internet speed test!</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-92669199" data-fhid="92669199" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">92669199</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-92669199">
			<a href="//apple.slashdot.org/index2.pl?fhfilter=business" onclick="return addfhfilter('business');">
			
				<img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses" title="Businesses">
			
		</a>
		
	
		
		
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=mac" onclick="return addfhfilter('mac');">
			
				<img src="//a.fsdn.com/sd/topics/mac_64.png" width="64" height="64" alt="Desktops (Apple)" title="Desktops (Apple)">
			
		</a>
		
	
		
		

		
		<a href="//apple.slashdot.org/index2.pl?fhfilter=money" onclick="return addfhfilter('money');">
			
				<img src="//a.fsdn.com/sd/topics/money_64.png" width="64" height="64" alt="The Almighty Buck" title="The Almighty Buck">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-92669199" class="story-title"> <a   href="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app">Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://medium.com/@matt.at.ably/wheres-all-my-cpu-and-memory-gone-the-answer-slack-9e5c39207cab"  title="External link - https://medium.com/@matt.at.ably/wheres-all-my-cpu-and-memory-gone-the-answer-slack-9e5c39207cab" target="_blank"> (medium.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-92669199" >170</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app#comments" title="">170</a></span>
		
	</h2>
	<div class="details" id="details-92669199">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  msmash
			
		
		

		
		
		<time id="fhtime-92669199" datetime="on Thursday July 27, 2017 @04:49PM">on Thursday July 27, 2017 @04:49PM</time>
		
		
			 from the <span class="dept-text">dog-app</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-92669199">
	
		
	

	
		
		<div id="text-92669199" class="p">
			
		 	
				Slack, valued at $5 billion, has received buyout pitches from several companies including Amazon and Microsoft. But the team collaborations service, which has over 5 million active users, continues to offer one of the most resource intensive apps you could find on Mac and iOS. From an article:<i> TLDR; If you care about battery life or availability of your finite CPU and memory on your computer, then you probably won't want to use Slack desktop with more than one or two accounts. Slack resource usage <a href="https://medium.com/@matt.at.ably/wheres-all-my-cpu-and-memory-gone-the-answer-slack-9e5c39207cab">increases linearly as you add more accounts, and it quickly adds up</a>. [...] I noticed that my machine has been sluggish and its battery life has become poor. Whilst investigating this, it turns out that Slack desktop fails badly when used with multiple accounts. This is because CPU and memory usage increases linearly as you add more accounts to your Slack desktop client. As a result, I believe the growing trend to use Slack to be part of multiple communities is seriously flawed until Slack resolve this problem.</i> The author, Matthew O'Riordan, has shared screenshots of Activity Monitor which shows that Slack application on his Mac was consuming more than 1.5GB of memory, and as much as 70 percent of the energy. The company's iOS app instills several more issues.<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-92669199" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app"
								  data-janrain-title="Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App"
								  data-janrain-message="Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-92669199" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/business" target="_blank">business</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/mac" target="_blank">mac</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/money" target="_blank">money</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/17/07/27/1957200/why-your-call-center-is-only-getting-noisier?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//yro.slashdot.org/story/17/07/27/2018258/german-court-rules-bosses-cant-use-keyboard-tracking-software-to-spy-on-workers?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/17/07/27/1957200/why-your-call-center-is-only-getting-noisier?sdsrc=prev">Why Your Call Center is Only Getting Noisier </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//apple.slashdot.org/story/16/09/07/2328217/apple-cites-courage-as-reason-to-remove-35mm-headphone-jack?sdsrc=popbyskid">Apple Cites 'Courage' As Reason To Remove 3.5mm Headphone Jack</a><br></h2>
																				<h2><a href="//apple.slashdot.org/story/17/05/02/1916223/ask-slashdot-what-is-the-special-appeal-of-apple-products?sdsrc=popbyskid">Ask Slashdot: What Is the 'Special Appeal' of Apple Products?</a><br></h2>
																				<h2><a href="//apple.slashdot.org/story/16/11/14/1240245/china-threatens-to-cut-sales-of-iphones-and-us-cars-if-naive-trump-pursues-trade-war?sdsrc=popbyskid">China Threatens To Cut Sales of iPhones and US Cars if 'Naive' Trump Pursues Trade War</a><br></h2>
																				<h2><a href="//apple.slashdot.org/story/16/11/02/1544214/phil-schiller-says-the-macbook-pro-doesnt-need-an-sd-card-slot?sdsrc=popbyskid">Phil Schiller Says the MacBook Pro Doesn't Need an SD Card Slot</a><br></h2>
																				<h2><a href="//apple.slashdot.org/story/16/08/30/1423225/apple-ordered-to-pay-up-to-145-billion-in-eu-tax-crackdown-cook-refutes-eus-conclusion?sdsrc=popbyskid">Apple Ordered To Pay Up To $14.5 Billion in EU Tax Crackdown, Cook Refutes EU's Conclusion</a><br></h2>
									
								
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//yro.slashdot.org/story/17/07/27/2018258/german-court-rules-bosses-cant-use-keyboard-tracking-software-to-spy-on-workers?sdsrc=next">German Court Rules Bosses Can't Use Keyboard-Tracking Software To Spy On Workers</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app" title="Back to Article - Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App">Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App" href="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app">Where's All My CPU and Memory Gone? The Answer: $5B Worth Slack App</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=10919483" class="btn">Search <span class="totalcommentcnt">171</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//apple.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//apple.slashdot.org/comments.pl?sid=10919483">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//apple.slashdot.org/search.pl?op=comments&amp;sid=10919483" class="ui-icon search_comments">Search <span class="totalcommentcnt">171</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//apple.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//apple.slashdot.org/story/17/07/27/2048258/wheres-all-my-cpu-and-memory-gone-the-answer-5b-worth-slack-app/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?b44e3ae3434d951a" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_54894403" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894403" class="commentstatus"></div>
<div id="comment_54894403" class="cw">
	<div id="comment_top_54894403" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894403" name="comment_link_54894403" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894403" onclick="return D2.setFocusComment(54894403)" >Norton and McAfee can use more cpu they should buy</a>


		 	<span id="comment_score_54894403" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894403); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Joe_Dragon">Joe_Dragon</a>  <span class="uid"><a href="//slashdot.org/~Joe_Dragon">( 2206452 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894403">		
		on Thursday July 27, 2017 @04:52PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894403">#54894403</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894403"><p>Norton and McAfee can use more cpu they should buy this!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894403">
<span class="ind"></span><a id="reply_link_54894403" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894403" onclick="D2.replyTo(54894403); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Norton and McAfee can use more cpu they should buy by Joe_Dragon @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894403" data-title="Norton and McAfee can use more cpu they should buy">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Norton and McAfee can use more cpu they should buy by Joe_Dragon" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894403" data-title="Norton and McAfee can use more cpu they should buy">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Norton and McAfee can use more cpu they should buy by Joe_Dragon" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894403" data-title="Norton and McAfee can use more cpu they should buy">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894403" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894403" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894403" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894403"></div>

<ul id="group_54894403">
	<li id="hiddens_54894403" class="hide"></li>
</ul>

</li><li id="tree_54894417" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894417" class="commentstatus"></div>
<div id="comment_54894417" class="cw">
	<div id="comment_top_54894417" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894417" name="comment_link_54894417" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894417" onclick="return D2.setFocusComment(54894417)" >This is to be expected</a>


		 	<span id="comment_score_54894417" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894417); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894417">		
		on Thursday July 27, 2017 @04:54PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894417">#54894417</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894417"><p>After all, Slack is originally based on IRC. And IRC is very resource-intensive. It would be difficult to make an IRC-based chat client that doesn't tax the system.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894417">
<span class="ind"></span><a id="reply_link_54894417" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894417" onclick="D2.replyTo(54894417); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="This is to be expected by Anonymous Coward @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894417" data-title="This is to be expected">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="This is to be expected by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894417" data-title="This is to be expected">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="This is to be expected by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894417" data-title="This is to be expected">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894417" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894417" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894417" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894417"></div>

<ul id="group_54894417">
	<li id="hiddens_54894417" class="hide"></li>
</ul>

<ul id="commtree_54894417"><li id="tree_54894547" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894547" class="commentstatus"></div>
<div id="comment_54894547" class="cw">
	<div id="comment_top_54894547" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894547" name="comment_link_54894547" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894547" onclick="return D2.setFocusComment(54894547)" >Re:</a>


		 	<span id="comment_score_54894547" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894547); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Anubis+IV">Anubis IV</a>  <span class="uid"><a href="//slashdot.org/~Anubis+IV">( 1279820 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894547"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894547"><p>There are IRC clients on his platform that perform just fine. I used to regularly use Colloquy on OS X for my IRC needs and I never observed any of the issues the author is describing. Moreover, while Slack basically boils down to a prettified version of IRC, I don't think I've ever seen it suggested that it's "based on IRC" in any way other than in concept. If it shares any internals, I've love more info. After all, I wouldn't mind being able to connect to Slack channels using a standard IRC client.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894547">

</div>
</div>

<div id="replyto_54894547"></div>

<ul id="group_54894547">
	<li id="hiddens_54894547" class="hide"></li>
</ul>

<ul id="commtree_54894547"><li id="tree_54894633" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894633" class="commentstatus"></div>
<div id="comment_54894633" class="cw">
	<div id="comment_top_54894633" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894633" name="comment_link_54894633" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894633" onclick="return D2.setFocusComment(54894633)" >Re:This is to be expected</a>


		 	<span id="comment_score_54894633" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894633); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~txsable">txsable</a>  <span class="uid"><a href="//slashdot.org/~txsable">( 169665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894633">		
		on Thursday July 27, 2017 @05:22PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894633">#54894633</a>)
		<small><a href="http://www.noidea.us/" title="http://www.noidea.us/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894633"><p><a href="https://get.slack.help/hc/en-us/articles/201727913-Connect-to-Slack-over-IRC-and-XMPP" title="slack.help">Connect to Slack over IRC and XMPP</a> [slack.help].  I tried this for I while but it was awkward in my experience.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894633">
<span class="ind"></span><a id="reply_link_54894633" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894633" onclick="D2.replyTo(54894633); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894547" onclick="return D2.selectParent(54894547)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:This is to be expected by txsable @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894633" data-title="Re:This is to be expected">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:This is to be expected by txsable" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894633" data-title="Re:This is to be expected">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:This is to be expected by txsable" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894633" data-title="Re:This is to be expected">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894633" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894633" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894633" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894633"></div>

<ul id="group_54894633">
	<li id="hiddens_54894633" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894753" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894753" class="commentstatus"></div>
<div id="comment_54894753" class="cw">
	<div id="comment_top_54894753" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894753" name="comment_link_54894753" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894753" onclick="return D2.setFocusComment(54894753)" >Re: This is to be expected</a>


		 	<span id="comment_score_54894753" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894753); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Brockmire">Brockmire</a>  <span class="uid"><a href="//slashdot.org/~Brockmire">( 4931623 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894753"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894753">What? Steve Gibson wrote an IRC client in assembly to catch some hackers one time. I don't think it took him long.

IRC was popular when we ran 100Mhz Pentium with 64MB Ram.

What the fuck are you talking about?

Slack has a shit ton more features than any IRC client.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894753">

</div>
</div>

<div id="replyto_54894753"></div>

<ul id="group_54894753">
	<li id="hiddens_54894753" class="hide"></li>
</ul>

<ul id="commtree_54894753"><li id="tree_54894761" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894761" class="commentstatus"></div>
<div id="comment_54894761" class="cw">
	<div id="comment_top_54894761" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894761" name="comment_link_54894761" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894761" onclick="return D2.setFocusComment(54894761)" >Re:  This is to be expected</a>


		 	<span id="comment_score_54894761" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894761); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Brockmire">Brockmire</a>  <span class="uid"><a href="//slashdot.org/~Brockmire">( 4931623 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894761"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894761">Shit, did I just get whooshed?</div>
	</div>

	<div class="commentSub" id="comment_sub_54894761">

</div>
</div>

<div id="replyto_54894761"></div>

<ul id="group_54894761">
	<li id="hiddens_54894761" class="hide"></li>
</ul>

<ul id="commtree_54894761"><li id="tree_54894799" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894799" class="commentstatus"></div>
<div id="comment_54894799" class="cw">
	<div id="comment_top_54894799" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894799" name="comment_link_54894799" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894799" onclick="return D2.setFocusComment(54894799)" >Re:</a>


		 	<span id="comment_score_54894799" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894799); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aliquis">aliquis</a>  <span class="uid"><a href="//slashdot.org/~aliquis">( 678370 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894799"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894799"><p><div class="quote"><p>Shit, did I just get whooshed?</p></div><p>Don't worry.</p><p>The drowned don't suffer any longer.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894799">

</div>
</div>

<div id="replyto_54894799"></div>

<ul id="group_54894799">
	<li id="hiddens_54894799" class="hide"></li>
</ul>

<ul id="commtree_54894799"><li id="tree_54894959" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894959" class="commentstatus"></div>
<div id="comment_54894959" class="cw">
	<div id="comment_top_54894959" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894959" name="comment_link_54894959" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894959" onclick="return D2.setFocusComment(54894959)" >Re: This is to be expected</a>


		 	<span id="comment_score_54894959" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894959); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~haruchai">haruchai</a>  <span class="uid"><a href="//slashdot.org/~haruchai">( 17472 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894959">		
		on Thursday July 27, 2017 @06:08PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894959">#54894959</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894959"><p><div class="quote"><p><div class="quote"><p>Shit, did I just get whooshed?</p></div><p>Don't worry.</p><p>The drowned don't suffer any longer.</p></div><p>What is dead may never die</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894959">
<span class="ind"></span><a id="reply_link_54894959" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894959" onclick="D2.replyTo(54894959); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894799" onclick="return D2.selectParent(54894799)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: This is to be expected by haruchai @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894959" data-title="Re: This is to be expected">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: This is to be expected by haruchai" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894959" data-title="Re: This is to be expected">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: This is to be expected by haruchai" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894959" data-title="Re: This is to be expected">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894959" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894959" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894959" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894959"></div>

<ul id="group_54894959">
	<li id="hiddens_54894959" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54895217" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895217" class="commentstatus"></div>
<div id="comment_54895217" class="cw">
	<div id="comment_top_54895217" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895217" name="comment_link_54895217" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895217" onclick="return D2.setFocusComment(54895217)" >Re:</a>


		 	<span id="comment_score_54895217" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895217); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sexconker">sexconker</a>  <span class="uid"><a href="//slashdot.org/~sexconker">( 1179573 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895217"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895217"><p>You got whooshed, yes.<br>But even writing "Hello World" in assembly takes forever.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895217">

</div>
</div>

<div id="replyto_54895217"></div>

<ul id="group_54895217">
	<li id="hiddens_54895217" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54895283" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895283" class="commentstatus"></div>
<div id="comment_54895283" class="cw">
	<div id="comment_top_54895283" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895283" name="comment_link_54895283" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895283" onclick="return D2.setFocusComment(54895283)" >Re:</a>


		 	<span id="comment_score_54895283" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895283); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DontBeAMoran">DontBeAMoran</a>  <span class="uid"><a href="//slashdot.org/~DontBeAMoran">( 4843879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895283"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895283"><p>IRC is nothing compared to displaying plain ASCII text files.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895283">

</div>
</div>

<div id="replyto_54895283"></div>

<ul id="group_54895283">
	<li id="hiddens_54895283" class="hide"></li>
</ul>

</li><li id="tree_54894603" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54894603" class="commentstatus"></div>
<div id="comment_54894603" class="cw">
</div>

<div id="replyto_54894603"></div>

<ul id="group_54894603">
	<li id="hiddens_54894603" class="hide"></li>
</ul>

<ul id="commtree_54894603"><li id="tree_54895155" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895155" class="commentstatus"></div>
<div id="comment_54895155" class="cw">
</div>

<div id="replyto_54895155"></div>

<ul id="group_54895155">
	<li id="hiddens_54895155" class="hide"></li>
</ul>

<ul id="commtree_54895155"><li id="tree_54895707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895707" class="commentstatus"></div>
<div id="comment_54895707" class="cw">
	<div id="comment_top_54895707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895707" name="comment_link_54895707" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895707" onclick="return D2.setFocusComment(54895707)" >Re:</a>


		 	<span id="comment_score_54895707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rholtzjr">rholtzjr</a>  <span class="uid"><a href="//slashdot.org/~rholtzjr">( 928771 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895707">You know, I never really like contractions.  It seems that all most of them (at least the ones that are most misused) do is eliminate a single space and a letter.  I try and avoid them in written communications.  Let's (here's one) (and another) take a look at some of them.  Instead of "let us" one would use "let's"  Saved space, and time = 1 letter and a space.  "Here's" instead of "here is", again same savings. <p> I am sure there are some like "You're" that increase this time saving (oh wait, yet another si<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895707">

</div>
</div>

<div id="replyto_54895707"></div>

<ul id="group_54895707">
	<li id="hiddens_54895707" class="hide"></li>
</ul>

<ul id="commtree_54895707"><li id="tree_54895985" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895985" class="commentstatus"></div>
<div id="comment_54895985" class="cw">
	<div id="comment_top_54895985" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895985" name="comment_link_54895985" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895985" onclick="return D2.setFocusComment(54895985)" >Re:</a>


		 	<span id="comment_score_54895985" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895985); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bored_engineer">bored_engineer</a>  <span class="uid"><a href="//slashdot.org/~bored_engineer">( 951004 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895985"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895985"><p>I see what you mean, but it seems to me that written language follows, rather than leads, spoken language.  Speak what you wrote with and without the contractions, and you'll find that (some of) the contractions flow better than the longer form. (I did, though the fourth and fifth sentences were pretty awkward.</p><p>Here's an example:</p><p>I cannot argue with your assessment that they do not save any significant time, and in the case of "you're" and "it's" are a source of significant confusion.</p><p>I can't argue with your a<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895985">

</div>
</div>

<div id="replyto_54895985"></div>

<ul id="group_54895985">
	<li id="hiddens_54895985" class="hide"></li>
</ul>

<ul id="commtree_54895985"><li id="tree_54896567" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896567" class="commentstatus"></div>
<div id="comment_54896567" class="cw">
	<div id="comment_top_54896567" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896567" name="comment_link_54896567" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896567" onclick="return D2.setFocusComment(54896567)" >Re:</a>


		 	<span id="comment_score_54896567" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896567); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rholtzjr">rholtzjr</a>  <span class="uid"><a href="//slashdot.org/~rholtzjr">( 928771 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896567"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896567">Yea, that is the bizarre part about the English language.  Spoken does not always follow the written.  I have condition myself to not use them in writing, however spoken is another story.  I sometimes use them unless I am trying to emphasize a point.  Such as:  "I don't use contractions" in normal speak.  And when I want to emphasize that same statement with "I DO NOT use contractions" instead of "I DON'T use contractions".
<p>Ahhh, you have to love the little subtleties of this language.
</p><p>On a side note you al<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896567">

</div>
</div>

<div id="replyto_54896567"></div>

<ul id="group_54896567">
	<li id="hiddens_54896567" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54896659" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896659" class="commentstatus"></div>
<div id="comment_54896659" class="cw">
	<div id="comment_top_54896659" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896659" name="comment_link_54896659" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896659" onclick="return D2.setFocusComment(54896659)" >Re:</a>


		 	<span id="comment_score_54896659" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896659); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JustAnotherOldGuy">JustAnotherOldGuy</a>  <span class="uid"><a href="//slashdot.org/~JustAnotherOldGuy">( 4145623 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896659"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896659"><p><div class="quote"><p>You know, I never really like contractions.  It seems that all most of them (at least the ones that are most misused) do is eliminate a single space and a letter.</p></div><p>Contractions are not about saving a couple of characters. They're about presenting a more natural form of communication. They're an attempt to portray everyday speech, rather than some stilted kind of English that almost no one actually uses.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896659">

</div>
</div>

<div id="replyto_54896659"></div>

<ul id="group_54896659">
	<li id="hiddens_54896659" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="tree_54894429" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894429" class="commentstatus"></div>
<div id="comment_54894429" class="cw">
	<div id="comment_top_54894429" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894429" name="comment_link_54894429" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894429" onclick="return D2.setFocusComment(54894429)" >IRC, done poorly.</a>


		 	<span id="comment_score_54894429" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894429); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~0100010001010011">0100010001010011</a>  <span class="uid"><a href="//slashdot.org/~0100010001010011">( 652467 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894429">		
		on Thursday July 27, 2017 @04:55PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894429">#54894429</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894429"><p>A while ago I tried to be in a larger facebook group and having more than one window open would grind my machine to a halt. Every single tab wanted it own Ajaxy Chat GUI.</p><p>Slack should have just made a pretty GUI on top of the existing IRC protocol. I remember being able to be in dozens of chat rooms on a machine less powerful than a RaspberryPi.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894429">
<span class="ind"></span><a id="reply_link_54894429" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894429" onclick="D2.replyTo(54894429); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="IRC, done poorly. by 0100010001010011 @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894429" data-title="IRC, done poorly.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="IRC, done poorly. by 0100010001010011" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894429" data-title="IRC, done poorly.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="IRC, done poorly. by 0100010001010011" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894429" data-title="IRC, done poorly.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894429" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894429" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894429" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894429"></div>

<ul id="group_54894429">
	<li id="hiddens_54894429" class="hide"></li>
</ul>

<ul id="commtree_54894429"><li id="tree_54894689" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894689" class="commentstatus"></div>
<div id="comment_54894689" class="cw">
	<div id="comment_top_54894689" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894689" name="comment_link_54894689" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894689" onclick="return D2.setFocusComment(54894689)" >Re:IRC, done poorly.</a>


		 	<span id="comment_score_54894689" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894689); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894689">		
		on Thursday July 27, 2017 @05:29PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894689">#54894689</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894689"><p>That's because "old school" code had to be small and efficient, and the programmers needed to know how to do that.</p><p>Increasingly, programmers rely on an ever expanding set of tools to do all of the hard work, don't know or care about performance or efficiency, and write bloated messes.</p><p>Windows is a fine example of this.  Some days, it feels like it runs no faster on a modern multi-core machine with a lot of RAM than it did on an old 386.</p><p>Modern software is frequently crap, written with the mantra that "CPU and RAM is cheap, it'll be fine".</p><p>Having hand optimized code to fit in small memory footprints or slow CPUs, I question if the average modern programmer has the slightest idea of what it would mean to do that.  And once you've had to do it, you keep it in mind forever in terms of "no, that would be a bad idea".  I've lost count of the number of times I've seen people write n^2 code which calls n^2 code which calls n^2 code and end up with something which can't possibly work -- all because they don't really know what is happening under the covers.</p><p>I've met far too many programmers who say "there's no point in optimizing".  Invariably they write shitty, inefficient code which is a monument to "elegance" which they can't even maintain.</p><p>I've worked with people who would get a feature request and be like "I can't, I'd have to rebuild the entire thing", or who spend hours trying to figure out how their code works.  The old school coders who spent time in C and the like?  Pretty much they can open up their code and go "I'd need to tweak here and here, and extend here".</p><p>In 1993, my 8MB  Linux machine on a 486 positively ran rings around anything else I'd seen.</p><p>The average code seems to be built in 10+ frameworks nobody really knows anything about.  Software has become bloated trash steadily over the last 25 years.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894689">
<span class="ind"></span><a id="reply_link_54894689" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894689" onclick="D2.replyTo(54894689); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894429" onclick="return D2.selectParent(54894429)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:IRC, done poorly. by Anonymous Coward @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894689" data-title="Re:IRC, done poorly.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:IRC, done poorly. by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894689" data-title="Re:IRC, done poorly.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:IRC, done poorly. by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894689" data-title="Re:IRC, done poorly.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894689" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894689" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894689" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894689"></div>

<ul id="group_54894689">
	<li id="hiddens_54894689" class="hide"></li>
</ul>

<ul id="commtree_54894689"><li id="tree_54895295" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895295" class="commentstatus"></div>
<div id="comment_54895295" class="cw">
	<div id="comment_top_54895295" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895295" name="comment_link_54895295" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895295" onclick="return D2.setFocusComment(54895295)" >Re:</a>


		 	<span id="comment_score_54895295" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895295); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DontBeAMoran">DontBeAMoran</a>  <span class="uid"><a href="//slashdot.org/~DontBeAMoran">( 4843879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895295"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895295"><p>I say we start again from scratch.</p><p>Here, I'll help and start with the basic building blocks:<br>0<br>1</p><p>You're welcome.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895295">

</div>
</div>

<div id="replyto_54895295"></div>

<ul id="group_54895295">
	<li id="hiddens_54895295" class="hide"></li>
</ul>

</li><li id="tree_54895889" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895889" class="commentstatus"></div>
<div id="comment_54895889" class="cw">
	<div id="comment_top_54895889" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895889" name="comment_link_54895889" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895889" onclick="return D2.setFocusComment(54895889)" >Re:</a>


		 	<span id="comment_score_54895889" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895889); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Entropius">Entropius</a>  <span class="uid"><a href="//slashdot.org/~Entropius">( 188861 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895889"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895889"><p>At one point I had to use Windows Update to download a new version of the "Microsoft Visual C++ Redistributable" which, for whatever reason, there are 23492834 versions of.</p><p>This was on a computer with an i7-6700K, a SSD, 16GB RAM, and fast internet.</p><p>It took four hours. I have no fucking clue what that machine was doing during that time.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895889">

</div>
</div>

<div id="replyto_54895889"></div>

<ul id="group_54895889">
	<li id="hiddens_54895889" class="hide"></li>
</ul>

<ul id="commtree_54895889"><li id="tree_54896719" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896719" class="commentstatus"></div>
<div id="comment_54896719" class="cw">
	<div id="comment_top_54896719" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896719" name="comment_link_54896719" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896719" onclick="return D2.setFocusComment(54896719)" >Re:</a>


		 	<span id="comment_score_54896719" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896719); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Khyber">Khyber</a>  <span class="uid"><a href="//slashdot.org/~Khyber">( 864651 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896719"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896719"><p>It was searching for other competing shit it could surreptitiously wipe from your system.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896719">

</div>
</div>

<div id="replyto_54896719"></div>

<ul id="group_54896719">
	<li id="hiddens_54896719" class="hide"></li>
</ul>

</li><li id="tree_54897843" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897843" class="commentstatus"></div>
<div id="comment_54897843" class="cw">
	<div id="comment_top_54897843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897843" name="comment_link_54897843" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897843" onclick="return D2.setFocusComment(54897843)" >Re:</a>


		 	<span id="comment_score_54897843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897843); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lord_Jeremy">Lord_Jeremy</a>  <span class="uid"><a href="//slashdot.org/~Lord_Jeremy">( 1612839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897843"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897843">You undoubtedly were bitten by the ages old Windows 7 bug/feature where Windows Update has to reindex some idiotic database with dependency graphs for every update. It's one of the reasons why if you make a new install of Windows 7, it'll take something approaching 24 hours to download the update to windows update, the next update to windows update, the update to the reindexer, reindex, then then 500+ updates after SP1, etc...</div>
	</div>

	<div class="commentSub" id="comment_sub_54897843">

</div>
</div>

<div id="replyto_54897843"></div>

<ul id="group_54897843">
	<li id="hiddens_54897843" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54896707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896707" class="commentstatus"></div>
<div id="comment_54896707" class="cw">
	<div id="comment_top_54896707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896707" name="comment_link_54896707" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896707" onclick="return D2.setFocusComment(54896707)" >Re: IRC, done poorly.</a>


		 	<span id="comment_score_54896707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jimbo">jimbo</a>  <span class="uid"><a href="//slashdot.org/~jimbo">( 1370 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896707"><p>Well, Somebody require fully functional app with "acceptable" number of bugs in record time, made cheaply you use high level frameworks and shit on memory and CPU resources.</p><p>I've been using Atom recently and it's a bloated whale (not to mention that they think they can call something without macro recording a programmers editor). I wish Electron would just go away.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896707">

</div>
</div>

<div id="replyto_54896707"></div>

<ul id="group_54896707">
	<li id="hiddens_54896707" class="hide"></li>
</ul>

</li><li id="tree_54896997" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896997" class="commentstatus"></div>
<div id="comment_54896997" class="cw">
	<div id="comment_top_54896997" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896997" name="comment_link_54896997" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896997" onclick="return D2.setFocusComment(54896997)" >Re:</a>


		 	<span id="comment_score_54896997" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896997); return false"><span class=opt>Score:</span>2</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896997"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896997"><p><div class="quote"><p>Increasingly, programmers rely on an ever expanding set of tools to do all of the hard work, don't know or care about performance or efficiency, and write bloated messes.</p></div><p>I've had other programmers remove optimized code because "premature optimization is the root of all evil."</p><p>Despite the fact that had been optimized because I had run a profiler over the code and verified that it was a bottleneck.</p><p>Nope.</p><p>Optimization is evil. Don't do it.</p><p>Also once had a five line loop ripped out and replaced with a 2MB library, because "we shouldn't reinvent the wheel."</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896997">

</div>
</div>

<div id="replyto_54896997"></div>

<ul id="group_54896997">
	<li id="hiddens_54896997" class="hide"></li>
</ul>

</li><li id="tree_54897155" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897155" class="commentstatus"></div>
<div id="comment_54897155" class="cw">
	<div id="comment_top_54897155" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897155" name="comment_link_54897155" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897155" onclick="return D2.setFocusComment(54897155)" >Re:</a>


		 	<span id="comment_score_54897155" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897155); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897155"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897155"><p><div class="quote"><p>Increasingly, programmers rely on an ever expanding set of tools to do all of the hard work, don't know or care about performance or efficiency, and write bloated messes.</p></div><p>There's nothing wrong with using tools.  If there's a well-written library that does something, then you can focus on the things that you're an expert in and allow people who are experts in something else to optimise their library.  The problem is that programmers are increasingly bad at judging the quality of the libraries that they use.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897155">

</div>
</div>

<div id="replyto_54897155"></div>

<ul id="group_54897155">
	<li id="hiddens_54897155" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894739" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894739" class="commentstatus"></div>
<div id="comment_54894739" class="cw">
	<div id="comment_top_54894739" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894739" name="comment_link_54894739" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894739" onclick="return D2.setFocusComment(54894739)" >Re:IRC, done poorly.</a>


		 	<span id="comment_score_54894739" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894739); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlhIngan">tlhIngan</a>  <span class="uid"><a href="//slashdot.org/~tlhIngan">( 30335 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894739">		 &lt;<a href="mailto:slashdot%40wor%5B+%5Det+%5B'f.n'+in+gap%5D">slashdot@wor[ ]et ['f.n' in gap]</a>&gt;
		on Thursday July 27, 2017 @05:37PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894739">#54894739</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894739"><p>Finally the truth comes out.</p><p>The happiest day was when I could uninstall slack. (Slack is not a corporate standard where I work, however, a project I was on, the customer insisted on using slack). Took me less than a day to figure out why Firefox was consuming 30% of the CPU (slack web pages...) so I installed the app hoping it would be less resource hungry  Was I wrong... but at least it wasn't bogging Firefox down</p><p>Turned off all the effects so I could at least get some usability out of my PC - it cut CPU usage done somewhat. I come to believe that the slack app is one of those node.js things that embed electron and turn a web app into a native app by running it under Chrome or something.</p><p>I know it's got a lot of stuff, but when things like Discord could exist happily on my machine taking 0% most of the time, or in a browser window taking practically no CPU cycles as well, there is no reason Slack has to be so inefficient. We shouldn't need to have Core i7's or top of the line Ryzens just to use a chat app.</p><p>Maybe we should replace all their developer PCs with what we can scrounge up at Goodwill</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894739">
<span class="ind"></span><a id="reply_link_54894739" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894739" onclick="D2.replyTo(54894739); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894429" onclick="return D2.selectParent(54894429)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:IRC, done poorly. by tlhIngan @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894739" data-title="Re:IRC, done poorly.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:IRC, done poorly. by tlhIngan" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894739" data-title="Re:IRC, done poorly.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:IRC, done poorly. by tlhIngan" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894739" data-title="Re:IRC, done poorly.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894739" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894739" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894739" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894739"></div>

<ul id="group_54894739">
	<li id="hiddens_54894739" class="hide"></li>
</ul>

<ul id="commtree_54894739"><li id="tree_54895827" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895827" class="commentstatus"></div>
<div id="comment_54895827" class="cw">
	<div id="comment_top_54895827" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895827" name="comment_link_54895827" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895827" onclick="return D2.setFocusComment(54895827)" >Re:</a>


		 	<span id="comment_score_54895827" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895827); return false"><span class=opt>Score:</span>2</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895827"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895827"><p>"I come to believe that the slack app is one of those node.js things that embed electron and turn a web app into a native app by running it under Chrome or something."</p><p>Correct.  Well, if you want to be pedantic, it's a JS thing running under Electron, which is essentially "node.js and chromium" fused into one whole.  I suspect there is still efficient ways of writing such applications, and I suspect the Slack team don't consider "reducing resource consumption" to be a worthwhile feature.</p><p>And it has terrible u<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895827">

</div>
</div>

<div id="replyto_54895827"></div>

<ul id="group_54895827">
	<li id="hiddens_54895827" class="hide"></li>
</ul>

<ul id="commtree_54895827"><li id="tree_54897999" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897999" class="commentstatus"></div>
<div id="comment_54897999" class="cw">
	<div id="comment_top_54897999" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897999" name="comment_link_54897999" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897999" onclick="return D2.setFocusComment(54897999)" >Re:</a>


		 	<span id="comment_score_54897999" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897999); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lord_Jeremy">Lord_Jeremy</a>  <span class="uid"><a href="//slashdot.org/~Lord_Jeremy">( 1612839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897999"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897999">A couple months ago, the Slack team released an update with significantly curbed memory usage on macOS, perhaps other platforms. Evidently there were some nasty bugs in their code that would result in gigabytes of leaked or wasted memory after a few days of use. TFA was almost certainly written <em>after</em> this memory usage reduction patch, and of course the performance characteristics are still absolutely terrible.<br>
<br>
This whole issue is amusing to me because with the past couple days there was another Slashdot he</div>
	</div>

	<div class="commentSub" id="comment_sub_54897999">

</div>
</div>

<div id="replyto_54897999"></div>

<ul id="group_54897999">
	<li id="hiddens_54897999" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54895189" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895189" class="commentstatus"></div>
<div id="comment_54895189" class="cw">
</div>

<div id="replyto_54895189"></div>

<ul id="group_54895189">
	<li id="hiddens_54895189" class="hide"></li>
</ul>

<ul id="commtree_54895189"><li id="tree_54895251" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54895251" class="commentstatus"></div>
<div id="comment_54895251" class="cw">
	<div id="comment_top_54895251" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895251" name="comment_link_54895251" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895251" onclick="return D2.setFocusComment(54895251)" >Re:IRC, done poorly.</a>


		 	<span id="comment_score_54895251" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895251); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sexconker">sexconker</a>  <span class="uid"><a href="//slashdot.org/~sexconker">( 1179573 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895251">		
		on Thursday July 27, 2017 @06:50PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895251">#54895251</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895251"><p>But mIRC let you slap people around a bit with a large trout.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895251">
<span class="ind"></span><a id="reply_link_54895251" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895251" onclick="D2.replyTo(54895251); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54895189" onclick="return D2.selectParent(54895189)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:IRC, done poorly. by sexconker @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895251" data-title="Re:IRC, done poorly.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:IRC, done poorly. by sexconker" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895251" data-title="Re:IRC, done poorly.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:IRC, done poorly. by sexconker" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895251" data-title="Re:IRC, done poorly.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54895251" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54895251" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895251" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54895251"></div>

<ul id="group_54895251">
	<li id="hiddens_54895251" class="hide"></li>
</ul>

<ul id="commtree_54895251"><li id="tree_54896055" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896055" class="commentstatus"></div>
<div id="comment_54896055" class="cw">
	<div id="comment_top_54896055" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896055" name="comment_link_54896055" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896055" onclick="return D2.setFocusComment(54896055)" >Re:</a>


		 	<span id="comment_score_54896055" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896055); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~0100010001010011">0100010001010011</a>  <span class="uid"><a href="//slashdot.org/~0100010001010011">( 652467 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896055"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896055"><p>/me understands this reference.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896055">

</div>
</div>

<div id="replyto_54896055"></div>

<ul id="group_54896055">
	<li id="hiddens_54896055" class="hide"></li>
</ul>

</li><li id="tree_54897463" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897463" class="commentstatus"></div>
<div id="comment_54897463" class="cw">
	<div id="comment_top_54897463" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897463" name="comment_link_54897463" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897463" onclick="return D2.setFocusComment(54897463)" >Re:</a>


		 	<span id="comment_score_54897463" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897463); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897463"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897463"><p>I still prefer docow. epic+wctb 4ever</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897463">

</div>
</div>

<div id="replyto_54897463"></div>

<ul id="group_54897463">
	<li id="hiddens_54897463" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_54894433" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894433" class="commentstatus"></div>
<div id="comment_54894433" class="cw">
	<div id="comment_top_54894433" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894433" name="comment_link_54894433" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894433" onclick="return D2.setFocusComment(54894433)" >Not surprised</a>


		 	<span id="comment_score_54894433" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894433); return false"><span class=opt>Score:</span>3</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894433">		
		on Thursday July 27, 2017 @04:56PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894433">#54894433</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894433"><p>We have to use Slack at work (because people that think it's cool said we do), and it's such a resource hog it isn't funny. I've disabled every feature and blocked animated images and it's still annoying.<br>You can connect with pidgin if you want a semi-functional version of it, but the XMPP support is missing critical things, like when someone opens a new group chat with you (you won't see it).<br>I would love for it die, but I know that won't happen.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894433">
<span class="ind"></span><a id="reply_link_54894433" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894433" onclick="D2.replyTo(54894433); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Not surprised by Anonymous Coward @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894433" data-title="Not surprised">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Not surprised by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894433" data-title="Not surprised">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Not surprised by Anonymous Coward" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894433" data-title="Not surprised">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894433" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894433" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894433" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894433"></div>

<ul id="group_54894433">
	<li id="hiddens_54894433" class="hide"></li>
</ul>

<ul id="commtree_54894433"><li id="tree_54894779" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894779" class="commentstatus"></div>
<div id="comment_54894779" class="cw">
	<div id="comment_top_54894779" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894779" name="comment_link_54894779" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894779" onclick="return D2.setFocusComment(54894779)" >Re:</a>


		 	<span id="comment_score_54894779" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894779); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlhIngan">tlhIngan</a>  <span class="uid"><a href="//slashdot.org/~tlhIngan">( 30335 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894779"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894779"><blockquote><div><p>We have to use Slack at work (because people that think it's cool said we do), and it's such a resource hog it isn't funny. I've disabled every feature and blocked animated images and it's still annoying.<br>You can connect with pidgin if you want a semi-functional version of it, but the XMPP support is missing critical things, like when someone opens a new group chat with you (you won't see it).<br>I would love for it die, but I know that won't happen.</p></div></blockquote><p>I'm thankful it's not corporate standard here, though some peop<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894779">

</div>
</div>

<div id="replyto_54894779"></div>

<ul id="group_54894779">
	<li id="hiddens_54894779" class="hide"></li>
</ul>

</li><li id="tree_54895441" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895441" class="commentstatus"></div>
<div id="comment_54895441" class="cw">
	<div id="comment_top_54895441" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895441" name="comment_link_54895441" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895441" onclick="return D2.setFocusComment(54895441)" >Re:</a>


		 	<span id="comment_score_54895441" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895441); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Orphis">Orphis</a>  <span class="uid"><a href="//slashdot.org/~Orphis">( 1356561 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895441"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895441"><p>I just used the IRC bridge at work instead, it worked alright, but I don't remember using the group chat feature at all, we just had regular channels.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895441">

</div>
</div>

<div id="replyto_54895441"></div>

<ul id="group_54895441">
	<li id="hiddens_54895441" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894435" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894435" class="commentstatus"></div>
<div id="comment_54894435" class="cw">
	<div id="comment_top_54894435" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894435" name="comment_link_54894435" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894435" onclick="return D2.setFocusComment(54894435)" >Node.js &amp; Chromium</a>


		 	<span id="comment_score_54894435" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894435); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tonique">tonique</a>  <span class="uid"><a href="//slashdot.org/~tonique">( 1176513 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894435">		
		on Thursday July 27, 2017 @04:56PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894435">#54894435</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894435"><p> <em>Fide</em> Wikipedia:</p><blockquote><div><p>Slack: Written in Electron</p></div></blockquote><blockquote><div><p>[Electron] allows for the development of desktop GUI applications using front and back end components originally developed for web applications: Node.js runtime for the backend and Chromium for the frontend</p></div></blockquote><p>The beginning does promise lots of memory usage already...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894435">
<span class="ind"></span><a id="reply_link_54894435" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894435" onclick="D2.replyTo(54894435); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Node.js &amp;amp; Chromium by tonique @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894435" data-title="Node.js &amp;amp; Chromium">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Node.js &amp;amp; Chromium by tonique" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894435" data-title="Node.js &amp;amp; Chromium">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Node.js &amp;amp; Chromium by tonique" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894435" data-title="Node.js &amp;amp; Chromium">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894435" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894435" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894435" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894435"></div>

<ul id="group_54894435">
	<li id="hiddens_54894435" class="hide"></li>
</ul>

<ul id="commtree_54894435"><li id="tree_54894505" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894505" class="commentstatus"></div>
<div id="comment_54894505" class="cw">
	<div id="comment_top_54894505" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894505" name="comment_link_54894505" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894505" onclick="return D2.setFocusComment(54894505)" >Re:</a>


		 	<span id="comment_score_54894505" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894505); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~theurge14">theurge14</a>  <span class="uid"><a href="//slashdot.org/~theurge14">( 820596 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894505"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894505"><p>Just like Atom.</p><p>Reminds me of "Write once, run slowly everywhere."</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894505">

</div>
</div>

<div id="replyto_54894505"></div>

<ul id="group_54894505">
	<li id="hiddens_54894505" class="hide"></li>
</ul>

<ul id="commtree_54894505"><li id="tree_54894813" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894813" class="commentstatus"></div>
<div id="comment_54894813" class="cw">
	<div id="comment_top_54894813" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894813" name="comment_link_54894813" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894813" onclick="return D2.setFocusComment(54894813)" >Re:</a>


		 	<span id="comment_score_54894813" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894813); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aliquis">aliquis</a>  <span class="uid"><a href="//slashdot.org/~aliquis">( 678370 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894813"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894813"><p><div class="quote"><p>Reminds me of "Write once, run slowly everywhere."</p></div><p>To be fair for most JAVA applications it was:<br>Write once; don't get used anywhere.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894813">

</div>
</div>

<div id="replyto_54894813"></div>

<ul id="group_54894813">
	<li id="hiddens_54894813" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894995" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894995" class="commentstatus"></div>
<div id="comment_54894995" class="cw">
	<div id="comment_top_54894995" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894995" name="comment_link_54894995" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894995" onclick="return D2.setFocusComment(54894995)" >Re:</a>


		 	<span id="comment_score_54894995" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894995); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~scdeimos">scdeimos</a>  <span class="uid"><a href="//slashdot.org/~scdeimos">( 632778 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894995"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894995">Oh, it's better than that. I once complained to Slack support about its tendency to slurp up CPU and RAM on the system. They said it launches a new instance of Chromium for every channel you subscribe to, but that they were working on improving its resource usage.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894995">

</div>
</div>

<div id="replyto_54894995"></div>

<ul id="group_54894995">
	<li id="hiddens_54894995" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894451" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894451" class="commentstatus"></div>
<div id="comment_54894451" class="cw">
	<div id="comment_top_54894451" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894451" name="comment_link_54894451" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894451" onclick="return D2.setFocusComment(54894451)" >Easy Fix!</a>


		 	<span id="comment_score_54894451" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894451); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894451"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894451"><p>Don't use Slack. There are countless chat applications available, including free and open source ones. Most of them are not resource intensive.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894451">

</div>
</div>

<div id="replyto_54894451"></div>

<ul id="group_54894451">
	<li id="hiddens_54894451" class="hide"></li>
</ul>

</li><li id="tree_54894457" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894457" class="commentstatus"></div>
<div id="comment_54894457" class="cw">
	<div id="comment_top_54894457" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894457" name="comment_link_54894457" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894457" onclick="return D2.setFocusComment(54894457)" >sadly</a>


		 	<span id="comment_score_54894457" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894457); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894457"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894457"><p>This isn't even a matter of it being a bloated web app on Electron.   It's just a badly written bloated web app on Electron.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894457">

</div>
</div>

<div id="replyto_54894457"></div>

<ul id="group_54894457">
	<li id="hiddens_54894457" class="hide"></li>
</ul>

</li><li id="tree_54894461" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894461" class="commentstatus"></div>
<div id="comment_54894461" class="cw">
	<div id="comment_top_54894461" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894461" name="comment_link_54894461" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894461" onclick="return D2.setFocusComment(54894461)" >For a moment I got scared</a>


		 	<span id="comment_score_54894461" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894461); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~future+assassin">future assassin</a>  <span class="uid"><a href="//slashdot.org/~future+assassin">( 639396 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894461">		
		on Thursday July 27, 2017 @04:59PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894461">#54894461</a>)
		<small><a href="http://www.blunt.audio/" title="http://www.blunt.audio/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894461"><p>and thought something bad and corporate  happened to Slack aka Slackware.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894461">
<span class="ind"></span><a id="reply_link_54894461" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894461" onclick="D2.replyTo(54894461); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="For a moment I got scared by future assassin @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894461" data-title="For a moment I got scared">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="For a moment I got scared by future assassin" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894461" data-title="For a moment I got scared">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="For a moment I got scared by future assassin" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894461" data-title="For a moment I got scared">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894461" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894461" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894461" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894461"></div>

<ul id="group_54894461">
	<li id="hiddens_54894461" class="hide"></li>
</ul>

<ul id="commtree_54894461"><li id="tree_54894553" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894553" class="commentstatus"></div>
<div id="comment_54894553" class="cw">
	<div id="comment_top_54894553" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894553" name="comment_link_54894553" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894553" onclick="return D2.setFocusComment(54894553)" >Re:</a>


		 	<span id="comment_score_54894553" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894553); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MangoCats">MangoCats</a>  <span class="uid"><a href="//slashdot.org/~MangoCats">( 2757129 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894553"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894553"><p>AlienBob got fired...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894553">

</div>
</div>

<div id="replyto_54894553"></div>

<ul id="group_54894553">
	<li id="hiddens_54894553" class="hide"></li>
</ul>

</li><li id="tree_54896673" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896673" class="commentstatus"></div>
<div id="comment_54896673" class="cw">
	<div id="comment_top_54896673" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896673" name="comment_link_54896673" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896673" onclick="return D2.setFocusComment(54896673)" >Re:</a>


		 	<span id="comment_score_54896673" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896673); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rtb61">rtb61</a>  <span class="uid"><a href="//slashdot.org/~rtb61">( 674572 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896673"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896673"><p>I am a slacker and I recognise slack it is software for slackers. Make it look like you are really busy and contributing but in reality you are just slacking off and playing the corporate social media game. I am the other kind of slacker, manage yourself to be far more productive so as to increase slack time. This software is bad, chews up productivity to fill it with empty make busy work, gets socially effective manipulative douche bags promoted and the real productive people fired because they are not pla<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896673">

</div>
</div>

<div id="replyto_54896673"></div>

<ul id="group_54896673">
	<li id="hiddens_54896673" class="hide"></li>
</ul>

</li><li id="tree_54894781" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54894781" class="commentstatus"></div>
<div id="comment_54894781" class="cw">
</div>

<div id="replyto_54894781"></div>

<ul id="group_54894781">
	<li id="hiddens_54894781" class="hide"></li>
</ul>

<ul id="commtree_54894781"><li id="tree_54895039" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895039" class="commentstatus"></div>
<div id="comment_54895039" class="cw">
</div>

<div id="replyto_54895039"></div>

<ul id="group_54895039">
	<li id="hiddens_54895039" class="hide"></li>
</ul>

<ul id="commtree_54895039"><li id="tree_54895237" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895237" class="commentstatus"></div>
<div id="comment_54895237" class="cw">
	<div id="comment_top_54895237" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895237" name="comment_link_54895237" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895237" onclick="return D2.setFocusComment(54895237)" >Well Trump</a>


		 	<span id="comment_score_54895237" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895237); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~future+assassin">future assassin</a>  <span class="uid"><a href="//slashdot.org/~future+assassin">( 639396 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895237"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895237"><p>you cared enough to reply.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895237">

</div>
</div>

<div id="replyto_54895237"></div>

<ul id="group_54895237">
	<li id="hiddens_54895237" class="hide"></li>
</ul>

<ul id="commtree_54895237"><li id="tree_54895579" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895579" class="commentstatus"></div>
<div id="comment_54895579" class="cw">
</div>

<div id="replyto_54895579"></div>

<ul id="group_54895579">
	<li id="hiddens_54895579" class="hide"></li>
</ul>

<ul id="commtree_54895579"><li id="tree_54895735" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895735" class="commentstatus"></div>
<div id="comment_54895735" class="cw">
	<div id="comment_top_54895735" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895735" name="comment_link_54895735" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895735" onclick="return D2.setFocusComment(54895735)" >Re:</a>


		 	<span id="comment_score_54895735" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895735); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~future+assassin">future assassin</a>  <span class="uid"><a href="//slashdot.org/~future+assassin">( 639396 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895735"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895735"><p>Its still an effort that shows you care enough to to post first and then fart.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895735">

</div>
</div>

<div id="replyto_54895735"></div>

<ul id="group_54895735">
	<li id="hiddens_54895735" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_54894487" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894487" class="commentstatus"></div>
<div id="comment_54894487" class="cw">
	<div id="comment_top_54894487" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894487" name="comment_link_54894487" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894487" onclick="return D2.setFocusComment(54894487)" >M$ Teams Has the Same Problem</a>


		 	<span id="comment_score_54894487" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894487); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894487"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894487"><p>The number one application by resource usage on my system is Microsoft Teams. I don't know why these chat programs are so poorly written.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894487">

</div>
</div>

<div id="replyto_54894487"></div>

<ul id="group_54894487">
	<li id="hiddens_54894487" class="hide"></li>
</ul>

</li><li id="tree_54894493" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894493" class="commentstatus"></div>
<div id="comment_54894493" class="cw">
	<div id="comment_top_54894493" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894493" name="comment_link_54894493" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894493" onclick="return D2.setFocusComment(54894493)" >The memory obesity problem.</a>


		 	<span id="comment_score_54894493" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894493); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894493"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894493"><p>The problem: Modern coders get taught hipster programming languages instead of traditional programming languages that were made back when there was memory conservatism in place.All programmers that know document.write() as their first hello world should be replaced by those who learned printf() instead.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894493">

</div>
</div>

<div id="replyto_54894493"></div>

<ul id="group_54894493">
	<li id="hiddens_54894493" class="hide"></li>
</ul>

<ul id="commtree_54894493"><li id="tree_54894937" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894937" class="commentstatus"></div>
<div id="comment_54894937" class="cw">
	<div id="comment_top_54894937" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894937" name="comment_link_54894937" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894937" onclick="return D2.setFocusComment(54894937)" >Re:The memory obesity problem.</a>


		 	<span id="comment_score_54894937" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894937); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fisted">fisted</a>  <span class="uid"><a href="//slashdot.org/~fisted">( 2295862 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894937">		
		on Thursday July 27, 2017 @06:05PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894937">#54894937</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894937"><p>Now now, why use the heavyweight printf for hello world when you have no formatting and might as well use puts instead?</p><p>Kids these days.</p><p>Now get off my lawn.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894937">
<span class="ind"></span><a id="reply_link_54894937" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894937" onclick="D2.replyTo(54894937); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894493" onclick="return D2.selectParent(54894493)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The memory obesity problem. by fisted @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894937" data-title="Re:The memory obesity problem.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The memory obesity problem. by fisted" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894937" data-title="Re:The memory obesity problem.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The memory obesity problem. by fisted" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894937" data-title="Re:The memory obesity problem.">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894937" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894937" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894937" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894937"></div>

<ul id="group_54894937">
	<li id="hiddens_54894937" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894575" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894575" class="commentstatus"></div>
<div id="comment_54894575" class="cw">
	<div id="comment_top_54894575" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894575" name="comment_link_54894575" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894575" onclick="return D2.setFocusComment(54894575)" >oh boy yes!</a>


		 	<span id="comment_score_54894575" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894575); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~citylivin">citylivin</a>  <span class="uid"><a href="//slashdot.org/~citylivin">( 1250770 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894575">		
		on Thursday July 27, 2017 @05:13PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894575">#54894575</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894575"><p>i hate slack. It copies to the machine like your entire history in every conversation, including all media. Most people here, there appdata slack folder is like 1.5gb and growing all the time. And we have only been using the software for a year, when someone decided that we had to adopt this fad.</p><p>And its all just animated gifs and useless other crap.</p><p>I hate slack, and i dont understand why people can't just use email for communication. Instant messaging made sense in the days of ICQ when email servers often took 15 minutes to relay messages. But now with exchange active sync and push emails it seems unnecessary to me.</p><p>To me, the people that like slack, are the ones that want you to respond to every little thing ASAP and they see it as a way to force people to respond quicker. Only thing is that this manic quickness destroys the mind, trains of thought, and makes it very hard to concentrate on project work when you are being distracted constantly by "chatters" (or i suppose, slackers). At least with email there is an expectation that you may take an hour or two to read it. That expectation goes away with IM clients, psychologically. For some personality types, this is a positive, and those personality types are sadly winning out.</p><p>I blame phone culture personally, but i certainly had younger friends in the ICQ days who would send 10 messages for every one response you made. Each one getting more and more desperate for a connection. Sad that the world has moved more and more in this direction, as reasoned responses take time to generate.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894575">
<span class="ind"></span><a id="reply_link_54894575" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894575" onclick="D2.replyTo(54894575); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="oh boy yes! by citylivin @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894575" data-title="oh boy yes!">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="oh boy yes! by citylivin" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894575" data-title="oh boy yes!">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="oh boy yes! by citylivin" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894575" data-title="oh boy yes!">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894575" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894575" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894575" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894575"></div>

<ul id="group_54894575">
	<li id="hiddens_54894575" class="hide"></li>
</ul>

<ul id="commtree_54894575"><li id="tree_54894691" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894691" class="commentstatus"></div>
<div id="comment_54894691" class="cw">
	<div id="comment_top_54894691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894691" name="comment_link_54894691" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894691" onclick="return D2.setFocusComment(54894691)" >Re:oh boy yes!</a>


		 	<span id="comment_score_54894691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894691); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~langelgjm">langelgjm</a>  <span class="uid"><a href="//slashdot.org/~langelgjm">( 860756 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894691">		
		on Thursday July 27, 2017 @05:29PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894691">#54894691</a>)
		<small><a href="//slashdot.org/~langelgjm/journal/" title="Thursday July 09, 2009 @04:09PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894691"><p>At my company, Slack fosters an "always-on" culture that fosters the expectation that people should always immediately respond to any request (even when not at work), and in my case, takes away from the ability to sustain focus on any complex problem for more than a few minutes. It's terrible, and I hate it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894691">
<span class="ind"></span><a id="reply_link_54894691" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894691" onclick="D2.replyTo(54894691); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894575" onclick="return D2.selectParent(54894575)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:oh boy yes! by langelgjm @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894691" data-title="Re:oh boy yes!">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:oh boy yes! by langelgjm" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894691" data-title="Re:oh boy yes!">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:oh boy yes! by langelgjm" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894691" data-title="Re:oh boy yes!">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894691" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894691" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894691" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894691"></div>

<ul id="group_54894691">
	<li id="hiddens_54894691" class="hide"></li>
</ul>

<ul id="commtree_54894691"><li id="tree_54894821" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894821" class="commentstatus"></div>
<div id="comment_54894821" class="cw">
	<div id="comment_top_54894821" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894821" name="comment_link_54894821" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894821" onclick="return D2.setFocusComment(54894821)" >Re:</a>


		 	<span id="comment_score_54894821" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894821); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894821"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894821"><p><div class="quote"><p>At my company, Slack fosters an "always-on" culture that fosters the expectation that people should always immediately respond to any request (even when not at work), and in my case, takes away from the ability to sustain focus on any complex problem for more than a few minutes. It's terrible, and I hate it.</p></div><p>We've actually been asked to install in on our personal phones as well as our workstations so that we can keep up with what is going on at work when we're not there.<br>I shit you not.<br>No, I'm not salary and I'm not paid to be on call.<br>I'm not talking to people at work all day long when I'm not punched in, and I work 3rd shift so you KNOW they will be talking when I'm off work.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894821">

</div>
</div>

<div id="replyto_54894821"></div>

<ul id="group_54894821">
	<li id="hiddens_54894821" class="hide"></li>
</ul>

</li><li id="tree_54898367" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898367" class="commentstatus"></div>
<div id="comment_54898367" class="cw">
	<div id="comment_top_54898367" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898367" name="comment_link_54898367" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898367" onclick="return D2.setFocusComment(54898367)" >Re:</a>


		 	<span id="comment_score_54898367" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898367); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~enjar">enjar</a>  <span class="uid"><a href="//slashdot.org/~enjar">( 249223 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898367"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898367">I heard the exact same complaint about email 20 years ago, and co-incident with effectively dealing with office interruptions. It's not a Slack problem, it's a people/culture problem. You can find books written decades ago that are filled with effective techniques to manage interruptions and work/life balance, as twenty years ago there were people staying late at work, who were emailing at all hours and expecting responses. You can work (meaning take some leadership) to establish reasonable boundaries, you</div>
	</div>

	<div class="commentSub" id="comment_sub_54898367">

</div>
</div>

<div id="replyto_54898367"></div>

<ul id="group_54898367">
	<li id="hiddens_54898367" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894855" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894855" class="commentstatus"></div>
<div id="comment_54894855" class="cw">
	<div id="comment_top_54894855" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894855" name="comment_link_54894855" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894855" onclick="return D2.setFocusComment(54894855)" >Re:oh boy yes!</a>


		 	<span id="comment_score_54894855" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894855); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wraithlyn">Wraithlyn</a>  <span class="uid"><a href="//slashdot.org/~Wraithlyn">( 133796 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894855">		
		on Thursday July 27, 2017 @05:54PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894855">#54894855</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894855"><p>Email is not optimal at back-and-forth *group* conversations, where Slack excels.</p><blockquote><div><p>this manic quickness destroys the mind</p></div></blockquote><p>This is a weird complaint.  If someone chats with you in person, or you have an in-person meeting, does this immediacy "destroy your mind"?  Email still has its place but sometimes you just need to have a quick chat about something.</p><blockquote><div><p>makes it very hard to concentrate on project work when you are being distracted constantly by "chatters" (or i suppose, slackers)</p></div></blockquote><p>Found the problem.  Turn off notifications except for messages specifically mentioning you, and learn to ignore Slack when you're busy.</p><p>All of the above being said, Slack is a big fat resource hog and deserves all the criticism it gets for that.  But group-focused messaging platforms have value.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894855">
<span class="ind"></span><a id="reply_link_54894855" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894855" onclick="D2.replyTo(54894855); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894575" onclick="return D2.selectParent(54894575)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:oh boy yes! by Wraithlyn @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894855" data-title="Re:oh boy yes!">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:oh boy yes! by Wraithlyn" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894855" data-title="Re:oh boy yes!">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:oh boy yes! by Wraithlyn" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894855" data-title="Re:oh boy yes!">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894855" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894855" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894855" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894855"></div>

<ul id="group_54894855">
	<li id="hiddens_54894855" class="hide"></li>
</ul>

<ul id="commtree_54894855"><li id="tree_54894931" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894931" class="commentstatus"></div>
<div id="comment_54894931" class="cw">
	<div id="comment_top_54894931" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894931" name="comment_link_54894931" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894931" onclick="return D2.setFocusComment(54894931)" >Re:oh boy yes!</a>


		 	<span id="comment_score_54894931" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894931); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~maliqua">maliqua</a>  <span class="uid"><a href="//slashdot.org/~maliqua">( 1316471 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894931">		
		on Thursday July 27, 2017 @06:03PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894931">#54894931</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894931"><p><div class="quote"><p> This is a weird complaint. If someone chats with you in person, or you have an in-person meeting, does this immediacy "destroy your mind"? Email still has its place but sometimes you just need to have a quick chat about something.</p></div><p>Do you have meetings every 30 seconds for an hour that last 2 seconds each?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894931">
<span class="ind"></span><a id="reply_link_54894931" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894931" onclick="D2.replyTo(54894931); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54894855" onclick="return D2.selectParent(54894855)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:oh boy yes! by maliqua @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894931" data-title="Re:oh boy yes!">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:oh boy yes! by maliqua" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894931" data-title="Re:oh boy yes!">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:oh boy yes! by maliqua" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894931" data-title="Re:oh boy yes!">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894931" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894931" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894931" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894931"></div>

<ul id="group_54894931">
	<li id="hiddens_54894931" class="hide"></li>
</ul>

<ul id="commtree_54894931"><li id="tree_54899115" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54899115" class="commentstatus"></div>
<div id="comment_54899115" class="cw">
	<div id="comment_top_54899115" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54899115" name="comment_link_54899115" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54899115" onclick="return D2.setFocusComment(54899115)" >Re:</a>


		 	<span id="comment_score_54899115" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54899115); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wraithlyn">Wraithlyn</a>  <span class="uid"><a href="//slashdot.org/~Wraithlyn">( 133796 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54899115"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54899115"><p>No. And I don't have people bothering me on Slack every 2 minutes either.</p><p>If you have people bothering you every 2 minutes, that's the problem.  Not the medium.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54899115">

</div>
</div>

<div id="replyto_54899115"></div>

<ul id="group_54899115">
	<li id="hiddens_54899115" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54895521" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895521" class="commentstatus"></div>
<div id="comment_54895521" class="cw">
	<div id="comment_top_54895521" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895521" name="comment_link_54895521" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895521" onclick="return D2.setFocusComment(54895521)" >Re:</a>


		 	<span id="comment_score_54895521" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895521); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895521"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895521"><p><div class="quote"><p>Email is not optimal at back-and-forth *group* conversations, where Slack excels.</p></div><p>This is false. Take any group of people who can communicate clearly and effectively in a manner that respects other people's time, and email is just as good as Slack. If you have a problem with communicating via email, you aren't going to solve it with Slack.</p><p><div class="quote"><p>Found the problem. Turn off notifications except for messages specifically mentioning you, and learn to ignore Slack when you're busy.</p></div><p>A real "let them eat cake" sentiment. The entire point of Slack is so that people who need an immediate response to their every mental twitch have an "efficient" way of getting it. Subscribe only to specific mentions and they will skyrocket. Worse, you<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895521">

</div>
</div>

<div id="replyto_54895521"></div>

<ul id="group_54895521">
	<li id="hiddens_54895521" class="hide"></li>
</ul>

</li><li id="tree_54897935" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897935" class="commentstatus"></div>
<div id="comment_54897935" class="cw">
	<div id="comment_top_54897935" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897935" name="comment_link_54897935" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897935" onclick="return D2.setFocusComment(54897935)" >Re:</a>


		 	<span id="comment_score_54897935" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897935); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~langelgjm">langelgjm</a>  <span class="uid"><a href="//slashdot.org/~langelgjm">( 860756 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897935"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897935"><blockquote><div><p>f someone chats with you in person, or you have an in-person meeting, does this immediacy "destroy your mind"?</p></div></blockquote><p>Um, yes? I can't the stand the constant "Got a minute?" questions, where someone walks up to your desk and interrupts whatever you're doing (thanks, open floor plans). Or a string of meetings with a half hour or hour between each, so that you don't really have enough time to get into a flow in between.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897935">

</div>
</div>

<div id="replyto_54897935"></div>

<ul id="group_54897935">
	<li id="hiddens_54897935" class="hide"></li>
</ul>

<ul id="commtree_54897935"><li id="tree_54899291" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54899291" class="commentstatus"></div>
<div id="comment_54899291" class="cw">
	<div id="comment_top_54899291" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54899291" name="comment_link_54899291" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54899291" onclick="return D2.setFocusComment(54899291)" >Re:</a>


		 	<span id="comment_score_54899291" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54899291); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wraithlyn">Wraithlyn</a>  <span class="uid"><a href="//slashdot.org/~Wraithlyn">( 133796 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54899291"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54899291"><p>So you're incapable of thinking on your feet or holding a conversation?  If this were actually true you'd be completely unemployable.</p><p>Carving out time for uninterrupted work is of course important.  If you have challenges with this where you work I suspect Slack is not the real problem.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54899291">

</div>
</div>

<div id="replyto_54899291"></div>

<ul id="group_54899291">
	<li id="hiddens_54899291" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54897637" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54897637" class="commentstatus"></div>
<div id="comment_54897637" class="cw">
</div>

<div id="replyto_54897637"></div>

<ul id="group_54897637">
	<li id="hiddens_54897637" class="hide"></li>
</ul>

<ul id="commtree_54897637"><li id="tree_54899211" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54899211" class="commentstatus"></div>
<div id="comment_54899211" class="cw">
	<div id="comment_top_54899211" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54899211" name="comment_link_54899211" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54899211" onclick="return D2.setFocusComment(54899211)" >Re:</a>


		 	<span id="comment_score_54899211" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54899211); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Wraithlyn">Wraithlyn</a>  <span class="uid"><a href="//slashdot.org/~Wraithlyn">( 133796 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54899211"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54899211"><p>Yes, there are other group communication protocols.  So why has Slack taken off?  (If your analysis is really, "uhh... hipsters" sorry but you're a fucking idiot)  Because Slack has a great UI, and is very easy to use.  It's really that simple.</p><p>Do you really think you're going to get everyone at a company using USENET or IRC?  Seriously?  EVERYONE, not just the techies.</p><p>Tech geeks tend to downplay the value of ease-of-use and good UX, because they'll happily wallow in a complex UI and tinker with configuratio<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54899211">

</div>
</div>

<div id="replyto_54899211"></div>

<ul id="group_54899211">
	<li id="hiddens_54899211" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54898319" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898319" class="commentstatus"></div>
<div id="comment_54898319" class="cw">
	<div id="comment_top_54898319" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898319" name="comment_link_54898319" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898319" onclick="return D2.setFocusComment(54898319)" >Re:</a>


		 	<span id="comment_score_54898319" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898319); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~enjar">enjar</a>  <span class="uid"><a href="//slashdot.org/~enjar">( 249223 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898319"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898319"><p><div class="quote"><p>And its all just animated gifs and useless other crap.</p></div><p>If you are using this for work, you can establish a policy for professional communication that keeps things on topic and excludes animated gifs.</p><p><div class="quote"><p>I hate slack, and i dont understand why people can't just use email for communication. </p></div><p>Slack (and other things like it) allow group conversations to happen where new group members can be added to the conversation and see all the history and discussion. This group discussion remains as a artifact to be referred to later by others who may find it useful. For example, marketing and development may discuss a new feature in a group chat to clarify details<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54898319">

</div>
</div>

<div id="replyto_54898319"></div>

<ul id="group_54898319">
	<li id="hiddens_54898319" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894579" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894579" class="commentstatus"></div>
<div id="comment_54894579" class="cw">
	<div id="comment_top_54894579" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894579" name="comment_link_54894579" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894579" onclick="return D2.setFocusComment(54894579)" >Poor Multiple Group Support</a>


		 	<span id="comment_score_54894579" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894579); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Feneric">Feneric</a>  <span class="uid"><a href="//slashdot.org/~Feneric">( 765069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894579">		
		on Thursday July 27, 2017 @05:14PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894579">#54894579</a>)
		<small><a href="http://feneric.blogspot.com/" title="http://feneric.blogspot.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894579">In general Slack's support for being members of multiple groups seems to be poor. Basically it looks like it doesn't have the concept of a single user simultaneously being members of multiple groups, and duplicates everything. It's particularly painful for 2FA.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894579">
<span class="ind"></span><a id="reply_link_54894579" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894579" onclick="D2.replyTo(54894579); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Poor Multiple Group Support by Feneric @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894579" data-title="Poor Multiple Group Support">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Poor Multiple Group Support by Feneric" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894579" data-title="Poor Multiple Group Support">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Poor Multiple Group Support by Feneric" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894579" data-title="Poor Multiple Group Support">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894579" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894579" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894579" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894579"></div>

<ul id="group_54894579">
	<li id="hiddens_54894579" class="hide"></li>
</ul>

</li><li id="tree_54894587" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894587" class="commentstatus"></div>
<div id="comment_54894587" class="cw">
	<div id="comment_top_54894587" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894587" name="comment_link_54894587" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894587" onclick="return D2.setFocusComment(54894587)" >Slack Desktop</a>


		 	<span id="comment_score_54894587" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894587); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Junior+Samples">Junior Samples</a>  <span class="uid"><a href="//slashdot.org/~Junior+Samples">( 550792 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894587">		
		on Thursday July 27, 2017 @05:14PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894587">#54894587</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894587"><p>What is Slack Desktop and why would I want it?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894587">
<span class="ind"></span><a id="reply_link_54894587" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894587" onclick="D2.replyTo(54894587); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Slack Desktop by Junior Samples @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894587" data-title="Slack Desktop">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Slack Desktop by Junior Samples" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894587" data-title="Slack Desktop">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Slack Desktop by Junior Samples" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894587" data-title="Slack Desktop">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894587" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894587" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894587" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894587"></div>

<ul id="group_54894587">
	<li id="hiddens_54894587" class="hide"></li>
</ul>

<ul id="commtree_54894587"><li id="tree_54894609" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894609" class="commentstatus"></div>
<div id="comment_54894609" class="cw">
	<div id="comment_top_54894609" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894609" name="comment_link_54894609" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894609" onclick="return D2.setFocusComment(54894609)" >Re:</a>


		 	<span id="comment_score_54894609" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894609); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CoolCash">CoolCash</a>  <span class="uid"><a href="//slashdot.org/~CoolCash">( 528004 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894609"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894609">I would rather have 1 slack app open, then 10 browser tabs open.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894609">

</div>
</div>

<div id="replyto_54894609"></div>

<ul id="group_54894609">
	<li id="hiddens_54894609" class="hide"></li>
</ul>

</li><li id="tree_54894775" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894775" class="commentstatus"></div>
<div id="comment_54894775" class="cw">
	<div id="comment_top_54894775" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894775" name="comment_link_54894775" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894775" onclick="return D2.setFocusComment(54894775)" >Re:</a>


		 	<span id="comment_score_54894775" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894775); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DarkRookie">DarkRookie</a>  <span class="uid"><a href="//slashdot.org/~DarkRookie">( 5030953 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894775"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894775">Custom Chrome browser and you don't. I has Chromes feature of eating your proc and RAM.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894775">

</div>
</div>

<div id="replyto_54894775"></div>

<ul id="group_54894775">
	<li id="hiddens_54894775" class="hide"></li>
</ul>

</li><li id="tree_54894929" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894929" class="commentstatus"></div>
<div id="comment_54894929" class="cw">
	<div id="comment_top_54894929" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894929" name="comment_link_54894929" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894929" onclick="return D2.setFocusComment(54894929)" >Re:</a>


		 	<span id="comment_score_54894929" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894929); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~silas_moeckel">silas_moeckel</a>  <span class="uid"><a href="//slashdot.org/~silas_moeckel">( 234313 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894929"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894929"><p>Especially when it has a semi functional xmpp gateway to use a real chat app with.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894929">

</div>
</div>

<div id="replyto_54894929"></div>

<ul id="group_54894929">
	<li id="hiddens_54894929" class="hide"></li>
</ul>

</li><li id="tree_54896691" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896691" class="commentstatus"></div>
<div id="comment_54896691" class="cw">
	<div id="comment_top_54896691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896691" name="comment_link_54896691" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896691" onclick="return D2.setFocusComment(54896691)" >Re:</a>


		 	<span id="comment_score_54896691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896691); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~freeze128">freeze128</a>  <span class="uid"><a href="//slashdot.org/~freeze128">( 544774 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896691"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896691">Your question is more appropriate than you think. I remember seeing commercials on TV for a new product called "Slack". It consisted of an office building populated by CGI anthropomorphic animals. The voice over was saying something about "when you have a creative idea and you want to get it to market as fast as possible"... It wasn't at all clear what Slack was or what it did. The office animals noticed rain clouds and then started to deliver umbrellas to the people on the street via parachute.<br> <br>
Brilliant</div>
	</div>

	<div class="commentSub" id="comment_sub_54896691">

</div>
</div>

<div id="replyto_54896691"></div>

<ul id="group_54896691">
	<li id="hiddens_54896691" class="hide"></li>
</ul>

</li><li id="tree_54898095" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898095" class="commentstatus"></div>
<div id="comment_54898095" class="cw">
	<div id="comment_top_54898095" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898095" name="comment_link_54898095" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898095" onclick="return D2.setFocusComment(54898095)" >Re:</a>


		 	<span id="comment_score_54898095" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898095); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~coofercat">coofercat</a>  <span class="uid"><a href="//slashdot.org/~coofercat">( 719737 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898095"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898095"><p>Slack is an instant messenger style 'chat' app, primarily aimed at business user, although they also gently court 'groups', such as open source projects and whatnot. It has some nifty features, such as chat history (even when you're not logged on), private/public groups, private chats, bots for many popular apps and easy developer integration APIs (so it's super easy to have your monitoring system write messages on alerts, for example). Conversations can have media in them (pictures, videos, file attachment<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54898095">

</div>
</div>

<div id="replyto_54898095"></div>

<ul id="group_54898095">
	<li id="hiddens_54898095" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894643" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894643" class="commentstatus"></div>
<div id="comment_54894643" class="cw">
	<div id="comment_top_54894643" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894643" name="comment_link_54894643" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894643" onclick="return D2.setFocusComment(54894643)" >So what you're saying...</a>


		 	<span id="comment_score_54894643" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894643); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MachineShedFred">MachineShedFred</a>  <span class="uid"><a href="//slashdot.org/~MachineShedFred">( 621896 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894643"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894643"><p>So what you're saying is that Slack's resource utilization increases linearly as you add more accounts to your Slack desktop client?  But does it increase linearly as you add more accounts?</p><p>(for the sarcasm impaired, the summary is basically the same sentence repeated)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894643">

</div>
</div>

<div id="replyto_54894643"></div>

<ul id="group_54894643">
	<li id="hiddens_54894643" class="hide"></li>
</ul>

</li><li id="tree_54894645" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894645" class="commentstatus"></div>
<div id="comment_54894645" class="cw">
	<div id="comment_top_54894645" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894645" name="comment_link_54894645" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894645" onclick="return D2.setFocusComment(54894645)" >Static binaries?</a>


		 	<span id="comment_score_54894645" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894645); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Nutria">Nutria</a>  <span class="uid"><a href="//slashdot.org/~Nutria">( 679911 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894645"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894645"><p>But I thought that modern OSs figured out how to share even them in RAM.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894645">

</div>
</div>

<div id="replyto_54894645"></div>

<ul id="group_54894645">
	<li id="hiddens_54894645" class="hide"></li>
</ul>

</li><li id="tree_54894693" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894693" class="commentstatus"></div>
<div id="comment_54894693" class="cw">
	<div id="comment_top_54894693" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894693" name="comment_link_54894693" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894693" onclick="return D2.setFocusComment(54894693)" >WTF? This is an IRC client and a few bots at most!</a>


		 	<span id="comment_score_54894693" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894693); return false"><span class=opt>Score:</span>2</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894693"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894693"><p>Jesus H! People want to buy slack as a company?  Wow, simply just wow.</p><p>and IRC server and a couple of bots would sort most of this out.  (And fuck the gifs)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894693">

</div>
</div>

<div id="replyto_54894693"></div>

<ul id="group_54894693">
	<li id="hiddens_54894693" class="hide"></li>
</ul>

<ul id="commtree_54894693"><li id="tree_54897257" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897257" class="commentstatus"></div>
<div id="comment_54897257" class="cw">
	<div id="comment_top_54897257" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897257" name="comment_link_54897257" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897257" onclick="return D2.setFocusComment(54897257)" >Re:</a>


		 	<span id="comment_score_54897257" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897257); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JaredOfEuropa">JaredOfEuropa</a>  <span class="uid"><a href="//slashdot.org/~JaredOfEuropa">( 526365 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897257"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897257">Eyeballs, my friend, eyeballs.  You get a couple of million people to register for whatever service you came up with, make it look like it can be mined for user data and/or used to shove ads down users' throats in some way, and you easily got yourself a valuation of 9 figures and up.</div>
	</div>

	<div class="commentSub" id="comment_sub_54897257">

</div>
</div>

<div id="replyto_54897257"></div>

<ul id="group_54897257">
	<li id="hiddens_54897257" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894695" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894695" class="commentstatus"></div>
<div id="comment_54894695" class="cw">
	<div id="comment_top_54894695" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894695" name="comment_link_54894695" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894695" onclick="return D2.setFocusComment(54894695)" >Really?</a>


		 	<span id="comment_score_54894695" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894695); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~U8MyData">U8MyData</a>  <span class="uid"><a href="//slashdot.org/~U8MyData">( 1281010 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894695"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894695">Bwah-ha-ha-ah!!!  Boy, do we know this one.</div>
	</div>

	<div class="commentSub" id="comment_sub_54894695">

</div>
</div>

<div id="replyto_54894695"></div>

<ul id="group_54894695">
	<li id="hiddens_54894695" class="hide"></li>
</ul>

</li><li id="tree_54894731" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54894731" class="commentstatus"></div>
<div id="comment_54894731" class="cw">
	<div id="comment_top_54894731" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894731" name="comment_link_54894731" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894731" onclick="return D2.setFocusComment(54894731)" >React &amp; Electron</a>


		 	<span id="comment_score_54894731" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894731); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Midnight+Thunder">Midnight Thunder</a>  <span class="uid"><a href="//slashdot.org/~Midnight+Thunder">( 17205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894731">		
		on Thursday July 27, 2017 @05:37PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894731">#54894731</a>)
		<small><a href="http://slashdot.org/" title="http://slashdot.org/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~Midnight+Thunder/journal/" title="Monday October 07, 2002 @03:22PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894731"><p>Slack is written in React and uses <a href="https://slack.engineering/building-hybrid-applications-with-electron-dc67686de5fb" title="slack.engineering">Electron</a> [slack.engineering]. I suspect the version of the Google's V8 JavaScript engine being used does not benefit from some of the more recent optimisations used by the one in Chrome 57?</p><p>I would be curious to see what could be done to improve things?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894731">
<span class="ind"></span><a id="reply_link_54894731" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894731" onclick="D2.replyTo(54894731); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="React &amp;amp; Electron by Midnight Thunder @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894731" data-title="React &amp;amp; Electron">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="React &amp;amp; Electron by Midnight Thunder" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894731" data-title="React &amp;amp; Electron">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="React &amp;amp; Electron by Midnight Thunder" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54894731" data-title="React &amp;amp; Electron">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54894731" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54894731" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54894731" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54894731"></div>

<ul id="group_54894731">
	<li id="hiddens_54894731" class="hide"></li>
</ul>

<ul id="commtree_54894731"><li id="tree_54894953" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894953" class="commentstatus"></div>
<div id="comment_54894953" class="cw">
	<div id="comment_top_54894953" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894953" name="comment_link_54894953" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894953" onclick="return D2.setFocusComment(54894953)" >Re:</a>


		 	<span id="comment_score_54894953" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894953); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894953"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894953"><p>Not running an entire fucking browser process just to display chat messages would be a good start.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894953">

</div>
</div>

<div id="replyto_54894953"></div>

<ul id="group_54894953">
	<li id="hiddens_54894953" class="hide"></li>
</ul>

</li><li id="tree_54895615" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895615" class="commentstatus"></div>
<div id="comment_54895615" class="cw">
	<div id="comment_top_54895615" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895615" name="comment_link_54895615" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895615" onclick="return D2.setFocusComment(54895615)" >Re:</a>


		 	<span id="comment_score_54895615" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895615); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MSG">MSG</a>  <span class="uid"><a href="//slashdot.org/~MSG">( 12810 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895615"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895615"><p>Chrome's JS memory improvements landed in 55.  The current version of Electron is build on 56, so they're probably included.</p><p>Electron apps are a resource nightmare, as is Chrome itself.  My wife is in a school for (mostly web) development.  Her system tends to run 3 apps: Chrome, Atom, and Slack, so essentially three copies of Chrome.  8GB of RAM is simply not enough to run a text editor, a chat client, and a web browser.  That's insane.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895615">

</div>
</div>

<div id="replyto_54895615"></div>

<ul id="group_54895615">
	<li id="hiddens_54895615" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54894819" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894819" class="commentstatus"></div>
<div id="comment_54894819" class="cw">
	<div id="comment_top_54894819" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894819" name="comment_link_54894819" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894819" onclick="return D2.setFocusComment(54894819)" >Amazing</a>


		 	<span id="comment_score_54894819" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894819); return false"><span class=opt>Score:</span>2</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894819"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894819"><p>People managed to do multiple chat rooms when 2400 baud was hot shit and their PC had 1/10 the processing power and memory of a modern one dollar SoC embedded controller... Fast forward 30 years and other people have apparently managed to create a multi-room chat system that is apparently capable of bringing systems with literally ten thousand times more processing power, memory and network bandwidth than ye olden PC-AT and acoustic modem to their knees.</p><p>I assume this is a conspiracy by battery manufacturers<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894819">

</div>
</div>

<div id="replyto_54894819"></div>

<ul id="group_54894819">
	<li id="hiddens_54894819" class="hide"></li>
</ul>

</li><li id="tree_54895025" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54895025" class="commentstatus"></div>
<div id="comment_54895025" class="cw">
	<div id="comment_top_54895025" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895025" name="comment_link_54895025" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895025" onclick="return D2.setFocusComment(54895025)" >A less resource intensive client...</a>


		 	<span id="comment_score_54895025" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895025); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Parker+Lewis">Parker Lewis</a>  <span class="uid"><a href="//slashdot.org/~Parker+Lewis">( 999165 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895025">		
		on Thursday July 27, 2017 @06:17PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895025">#54895025</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895025"><p>In the time Slack has not a Linux client, I've created a similar client using qtwebkit for Linux: <a href="https://github.com/raelgc/scudcloud/" title="github.com">https://github.com/raelgc/scud...</a> [github.com]. It was a bit popular, then Slack released the official client, and I thought that my simple client was dead. For my surprise, it's still alive for all people complaining about resources.</p><p>Sure, still a web container running the web version with desktop integration, but at least is using directly a web engine, not an entire browser. The reason is because Slack has no messaging API at all.</p><p>Two downsides: Slack keep changing their JS all the time, so it's a cat and mouse game. And qtwebkit itself keep breaking small stuff, so, last month I got 2 major issues: Arch Linux got the newest qtwebkit version, and it was crashing with a dump, not even a python stack (fix was downgrade. Ubuntu 16.04 faced the opposite: Slack upgraded their CSS and qwebkit version included in Ubuntu 16.04 was no more properly rendering the CSS (I pointed people to a package that upgraded 16.04 webkit.</p><p>I contacted Slack at least 2 times offering helping on Linux as a volunteer, as their client is just a "compiled" JS and I told them I can: fix some issues, help testing and improve integration with major Linux desktops, but most of the times I have no answer or the traditional "we appreciate, but no".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895025">
<span class="ind"></span><a id="reply_link_54895025" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895025" onclick="D2.replyTo(54895025); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="A less resource intensive client... by Parker Lewis @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895025" data-title="A less resource intensive client...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="A less resource intensive client... by Parker Lewis" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895025" data-title="A less resource intensive client...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="A less resource intensive client... by Parker Lewis" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895025" data-title="A less resource intensive client...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54895025" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54895025" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895025" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54895025"></div>

<ul id="group_54895025">
	<li id="hiddens_54895025" class="hide"></li>
</ul>

<ul id="commtree_54895025"><li id="tree_54895387" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895387" class="commentstatus"></div>
<div id="comment_54895387" class="cw">
	<div id="comment_top_54895387" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895387" name="comment_link_54895387" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895387" onclick="return D2.setFocusComment(54895387)" >Re:</a>


		 	<span id="comment_score_54895387" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895387); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mi">mi</a>  <span class="uid"><a href="//slashdot.org/~mi">( 197448 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895387"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895387"><p>Seconded. I am a happy ScudCloud user too &mdash; there is no "native" Slack app for FreeBSD. It is resource intensive too, but not so bad &mdash; using 1.7Gb for one account.
</p><p>Which reminds me, I really should add the port I created...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895387">

</div>
</div>

<div id="replyto_54895387"></div>

<ul id="group_54895387">
	<li id="hiddens_54895387" class="hide"></li>
</ul>

<ul id="commtree_54895387"><li id="tree_54895607" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895607" class="commentstatus"></div>
<div id="comment_54895607" class="cw">
	<div id="comment_top_54895607" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895607" name="comment_link_54895607" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895607" onclick="return D2.setFocusComment(54895607)" >Re:</a>


		 	<span id="comment_score_54895607" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895607); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Parker+Lewis">Parker Lewis</a>  <span class="uid"><a href="//slashdot.org/~Parker+Lewis">( 999165 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895607"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895607">Feel free to create a PR with the changes you need or join as a contributor!</div>
	</div>

	<div class="commentSub" id="comment_sub_54895607">

</div>
</div>

<div id="replyto_54895607"></div>

<ul id="group_54895607">
	<li id="hiddens_54895607" class="hide"></li>
</ul>

<ul id="commtree_54895607"><li id="tree_54896611" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896611" class="commentstatus"></div>
<div id="comment_54896611" class="cw">
	<div id="comment_top_54896611" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896611" name="comment_link_54896611" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896611" onclick="return D2.setFocusComment(54896611)" >Re:</a>


		 	<span id="comment_score_54896611" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896611); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mi">mi</a>  <span class="uid"><a href="//slashdot.org/~mi">( 197448 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896611"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896611"><blockquote><div><p>Feel free to create a PR</p></div></blockquote><p>Why, thank you kindly for your generous permission...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896611">

</div>
</div>

<div id="replyto_54896611"></div>

<ul id="group_54896611">
	<li id="hiddens_54896611" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_54895095" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54895095" class="commentstatus"></div>
<div id="comment_54895095" class="cw">
	<div id="comment_top_54895095" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895095" name="comment_link_54895095" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895095" onclick="return D2.setFocusComment(54895095)" >Javascript being Javascript</a>


		 	<span id="comment_score_54895095" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895095); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Gravis+Zero">Gravis Zero</a>  <span class="uid"><a href="//slashdot.org/~Gravis+Zero">( 934156 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895095">		
		on Thursday July 27, 2017 @06:28PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895095">#54895095</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895095"><p>If Javascript devs can be honest with themselves for a minute then they will realize that this is the result of using Javascript to make applications.  Simply put, Javascript was never intended to be used for making applications and poor performance is a reflection of that reality.  I'm certain they could optimize it but the overhead compared to a native application is absurd.  Don't give me that "Javascript is one languages for all platforms" line either because C++/Qt works on just as many platforms.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895095">
<span class="ind"></span><a id="reply_link_54895095" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895095" onclick="D2.replyTo(54895095); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Javascript being Javascript by Gravis Zero @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895095" data-title="Javascript being Javascript">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Javascript being Javascript by Gravis Zero" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895095" data-title="Javascript being Javascript">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Javascript being Javascript by Gravis Zero" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895095" data-title="Javascript being Javascript">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54895095" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54895095" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895095" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54895095"></div>

<ul id="group_54895095">
	<li id="hiddens_54895095" class="hide"></li>
</ul>

<ul id="commtree_54895095"><li id="tree_54895419" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54895419" class="commentstatus"></div>
<div id="comment_54895419" class="cw">
	<div id="comment_top_54895419" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895419" name="comment_link_54895419" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895419" onclick="return D2.setFocusComment(54895419)" >Not just Javascript being Javascript</a>


		 	<span id="comment_score_54895419" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895419); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mi">mi</a>  <span class="uid"><a href="//slashdot.org/~mi">( 197448 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895419">		 &lt;<a href="mailto:slashdot-2016q1%40virtual-estates.net">slashdot-2016q1@virtual-estates.net</a>&gt;
		on Thursday July 27, 2017 @07:21PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895419">#54895419</a>)
		<small><a href="http://thepeoplescube.com/" title="http://thepeoplescube.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~mi/journal/" title="Tuesday January 17, 2017 @03:28PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895419"><blockquote><div><p>If Javascript devs can be honest with themselves for a minute then they will realize that this is the result of using Javascript to make applications.</p></div></blockquote><p>I don't think, it is fair to single out JavaScript developers in particular...
</p><p>Per Moore's law, today's computers are 1024 times faster than 15 years ago. Is the "user experience" that much better? It is not. Maybe, it is 10 times better: voice recognition almost works, graphics are better, apps are smarter. But nowhere near 1000-fold improvement. Because the developers "ate" most of the gains in hardware using it for their own convenience instead of that of the end-users.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895419">
<span class="ind"></span><a id="reply_link_54895419" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895419" onclick="D2.replyTo(54895419); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54895095" onclick="return D2.selectParent(54895095)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Not just Javascript being Javascript by mi @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895419" data-title="Not just Javascript being Javascript">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Not just Javascript being Javascript by mi" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895419" data-title="Not just Javascript being Javascript">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Not just Javascript being Javascript by mi" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895419" data-title="Not just Javascript being Javascript">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54895419" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54895419" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895419" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54895419"></div>

<ul id="group_54895419">
	<li id="hiddens_54895419" class="hide"></li>
</ul>

<ul id="commtree_54895419"><li id="tree_54895697" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895697" class="commentstatus"></div>
<div id="comment_54895697" class="cw">
	<div id="comment_top_54895697" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895697" name="comment_link_54895697" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895697" onclick="return D2.setFocusComment(54895697)" >Re:</a>


		 	<span id="comment_score_54895697" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895697); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Gravis+Zero">Gravis Zero</a>  <span class="uid"><a href="//slashdot.org/~Gravis+Zero">( 934156 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895697"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895697"><p><div class="quote"><p>... today's computers are 1024 times faster than 15 years ago.<nobr> <wbr></nobr>... the developers "ate" most of the gains in hardware using it for their own convenience instead of that of the end-users.</p></div><p>Yeah, like writing programs in a shitty script languages like say... JavaScript. -_-</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895697">

</div>
</div>

<div id="replyto_54895697"></div>

<ul id="group_54895697">
	<li id="hiddens_54895697" class="hide"></li>
</ul>

<ul id="commtree_54895697"><li id="tree_54896615" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896615" class="commentstatus"></div>
<div id="comment_54896615" class="cw">
	<div id="comment_top_54896615" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896615" name="comment_link_54896615" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896615" onclick="return D2.setFocusComment(54896615)" >Re:</a>


		 	<span id="comment_score_54896615" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896615); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mi">mi</a>  <span class="uid"><a href="//slashdot.org/~mi">( 197448 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896615"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896615"><blockquote><div><p>like say... JavaScript. -_-</p></div></blockquote><p>Or Ruby. Or Scala. Or...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896615">

</div>
</div>

<div id="replyto_54896615"></div>

<ul id="group_54896615">
	<li id="hiddens_54896615" class="hide"></li>
</ul>

<ul id="commtree_54896615"><li id="tree_54897987" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897987" class="commentstatus"></div>
<div id="comment_54897987" class="cw">
	<div id="comment_top_54897987" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897987" name="comment_link_54897987" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897987" onclick="return D2.setFocusComment(54897987)" >Re:</a>


		 	<span id="comment_score_54897987" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897987); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Gravis+Zero">Gravis Zero</a>  <span class="uid"><a href="//slashdot.org/~Gravis+Zero">( 934156 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897987"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897987"><p>I agree.  Throw Python and Perl in that mess too.  Yes, I've seen Perl GUI apps.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897987">

</div>
</div>

<div id="replyto_54897987"></div>

<ul id="group_54897987">
	<li id="hiddens_54897987" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_54896623" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896623" class="commentstatus"></div>
<div id="comment_54896623" class="cw">
	<div id="comment_top_54896623" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896623" name="comment_link_54896623" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896623" onclick="return D2.setFocusComment(54896623)" >Re:</a>


		 	<span id="comment_score_54896623" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896623); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dutch+Gun">Dutch Gun</a>  <span class="uid"><a href="//slashdot.org/~Dutch+Gun">( 899105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896623"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896623"><p>Yep, this is what happens when developers insist on using the <i>only tools they know</i> instead of investing the time and effort required to learn and use the most appropriate tools for the actual job at hand.</p><p>So, as I understand it, instead of biting the bullet and simply creating an <i>actual native app</i>, web developers created an entire new framework more or less consisting of <i>an entire browser</i> (and one not known for being easy on resources to begin with) and it's Javascript interpreter, all so they could continue<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896623">

</div>
</div>

<div id="replyto_54896623"></div>

<ul id="group_54896623">
	<li id="hiddens_54896623" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54895433" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54895433" class="commentstatus"></div>
<div id="comment_54895433" class="cw">
	<div id="comment_top_54895433" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895433" name="comment_link_54895433" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895433" onclick="return D2.setFocusComment(54895433)" >Well this is a first</a>


		 	<span id="comment_score_54895433" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895433); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895433">		
		on Thursday July 27, 2017 @07:23PM (<span class="ind"></span><a href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895433">#54895433</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895433"><p>Not only does the summary not mention what Slack is, but 83 comments in and none of the comments do either. Though a lot of them seem to agree it's a resource hog. Is that really all it does? I mean you could achieve the same thing by opening Rick Astley videos on youtube, hitting play, and repeating for 30 tabs.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895433">
<span class="ind"></span><a id="reply_link_54895433" class="btn link" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895433" onclick="D2.replyTo(54895433); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Well this is a first by thegarbz @slashdot" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895433" data-title="Well this is a first">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Well this is a first by thegarbz" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895433" data-title="Well this is a first">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Well this is a first by thegarbz" data-url="https://apple.slashdot.org/comments.pl?sid=10919483&cid=54895433" data-title="Well this is a first">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://apple.slashdot.org/comments.pl?sid=10919483%26cid=54895433" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54895433" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54895433" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54895433"></div>

<ul id="group_54895433">
	<li id="hiddens_54895433" class="hide"></li>
</ul>

<ul id="commtree_54895433"><li id="tree_54896697" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54896697" class="commentstatus"></div>
<div id="comment_54896697" class="cw">
</div>

<div id="replyto_54896697"></div>

<ul id="group_54896697">
	<li id="hiddens_54896697" class="hide"></li>
</ul>

<ul id="commtree_54896697"><li id="tree_54898933" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898933" class="commentstatus"></div>
<div id="comment_54898933" class="cw">
	<div id="comment_top_54898933" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898933" name="comment_link_54898933" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898933" onclick="return D2.setFocusComment(54898933)" >Re:</a>


		 	<span id="comment_score_54898933" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898933); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898933"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898933"><p><div class="quote"><p>Well, you just mentioned somebody named Rick Astley without explaining who that is either.</p></div><p>There's a difference between not providing context for understanding when understanding is the primary goal, and not providing context for the comical result of people Googling, when the comical result is the primary goal.</p><p>But don't worry man, we at Slashdot won't give you up or let you down, and we definitely won't run and hide or desert you.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54898933">

</div>
</div>

<div id="replyto_54898933"></div>

<ul id="group_54898933">
	<li id="hiddens_54898933" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54895455" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895455" class="commentstatus"></div>
<div id="comment_54895455" class="cw">
	<div id="comment_top_54895455" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895455" name="comment_link_54895455" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895455" onclick="return D2.setFocusComment(54895455)" >Not a slack fan</a>


		 	<span id="comment_score_54895455" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895455); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~buss_error">buss_error</a>  <span class="uid"><a href="//slashdot.org/~buss_error">( 142273 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895455"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895455"><p>As noted by many, many others, Slack is a resource hog.<br>It's unusable in Firefox or Chrome in linux as it slows the whole machine down. Scrolling is sticky and laggy and a time sink because it takes so long.<br>The client is a little better, not much.<br>Also Slack forces you to have a General channel, which everyone is forced to use. With a few thousand people in it, it quickly because useless chatter that you can't shut out (you can mute it though).</p><p>I won't load the app on my phone. Others in my team have reported<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895455">

</div>
</div>

<div id="replyto_54895455"></div>

<ul id="group_54895455">
	<li id="hiddens_54895455" class="hide"></li>
</ul>

</li><li id="tree_54895769" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895769" class="commentstatus"></div>
<div id="comment_54895769" class="cw">
	<div id="comment_top_54895769" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895769" name="comment_link_54895769" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895769" onclick="return D2.setFocusComment(54895769)" >0.1% &amp; 25MB of RAM</a>


		 	<span id="comment_score_54895769" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895769); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~im_thatoneguy">im_thatoneguy</a>  <span class="uid"><a href="//slashdot.org/~im_thatoneguy">( 819432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895769"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895769"><p>I guess the windows version is better?  My slack is using 0% -&gt; 0.1% CPU at any given time and a whopping 25MB of RAM.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895769">

</div>
</div>

<div id="replyto_54895769"></div>

<ul id="group_54895769">
	<li id="hiddens_54895769" class="hide"></li>
</ul>

</li><li id="tree_54896359" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896359" class="commentstatus"></div>
<div id="comment_54896359" class="cw">
	<div id="comment_top_54896359" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896359" name="comment_link_54896359" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896359" onclick="return D2.setFocusComment(54896359)" >brower app</a>


		 	<span id="comment_score_54896359" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896359); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~buddyglass">buddyglass</a>  <span class="uid"><a href="//slashdot.org/~buddyglass">( 925859 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896359"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896359">I just load Slack in a browser on my (Mac) desktop.  Seems fine in Firefox.  Also use the iOS app on an iPhone with no issues.</div>
	</div>

	<div class="commentSub" id="comment_sub_54896359">

</div>
</div>

<div id="replyto_54896359"></div>

<ul id="group_54896359">
	<li id="hiddens_54896359" class="hide"></li>
</ul>

</li><li id="tree_54896501" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896501" class="commentstatus"></div>
<div id="comment_54896501" class="cw">
	<div id="comment_top_54896501" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896501" name="comment_link_54896501" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896501" onclick="return D2.setFocusComment(54896501)" >Slack beta</a>


		 	<span id="comment_score_54896501" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896501); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Corporate+Gadfly">Corporate Gadfly</a>  <span class="uid"><a href="//slashdot.org/~Corporate+Gadfly">( 227676 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896501"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896501"><p>Try the beta. It seems to be doing a lot better with CPU usage. Memory usage might still be an issue (I have 16G so I don't care).</p><p><a href="https://slack.com/beta/mac" title="slack.com">https://slack.com/beta/mac</a> [slack.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896501">

</div>
</div>

<div id="replyto_54896501"></div>

<ul id="group_54896501">
	<li id="hiddens_54896501" class="hide"></li>
</ul>

</li><li id="tree_54896601" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54896601" class="commentstatus"></div>
<div id="comment_54896601" class="cw">
	<div id="comment_top_54896601" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54896601" name="comment_link_54896601" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54896601" onclick="return D2.setFocusComment(54896601)" >After years of work...</a>


		 	<span id="comment_score_54896601" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54896601); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~poptix">poptix</a>  <span class="uid"><a href="//slashdot.org/~poptix">( 78287 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54896601"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54896601"><p>and numerous new chat protocols, IRC still rules them all.</p><p>poptix    4507  0.0  0.0 141996 13148 pts/4    Ssl+ Jan10  57:23  \_ irssi --config=~/.irssi/config.efnet</p><p>That's *with* 'infinite' scrollback enabled.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54896601">

</div>
</div>

<div id="replyto_54896601"></div>

<ul id="group_54896601">
	<li id="hiddens_54896601" class="hide"></li>
</ul>

<ul id="commtree_54896601"><li id="tree_54897029" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897029" class="commentstatus"></div>
<div id="comment_54897029" class="cw">
	<div id="comment_top_54897029" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897029" name="comment_link_54897029" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897029" onclick="return D2.setFocusComment(54897029)" >Re:</a>


		 	<span id="comment_score_54897029" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897029); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mouldy">Mouldy</a>  <span class="uid"><a href="//slashdot.org/~Mouldy">( 1322581 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897029"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897029">Incidentally, irssi can be used to connect to a whole bunch of non-IRC networks too. Including Slack and Gitter.</div>
	</div>

	<div class="commentSub" id="comment_sub_54897029">

</div>
</div>

<div id="replyto_54897029"></div>

<ul id="group_54897029">
	<li id="hiddens_54897029" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54898809" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898809" class="commentstatus"></div>
<div id="comment_54898809" class="cw">
	<div id="comment_top_54898809" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898809" name="comment_link_54898809" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898809" onclick="return D2.setFocusComment(54898809)" >What's Slack?</a>


		 	<span id="comment_score_54898809" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898809); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Holi">Holi</a>  <span class="uid"><a href="//slashdot.org/~Holi">( 250190 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898809"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898809">You know one of those pesky bit's of journalism. Try and tell your reader what you are talking about. No where in the summary or article does it mention what Slack does or why someone would use it, which I guess is fine because it obviously sucks.</div>
	</div>

	<div class="commentSub" id="comment_sub_54898809">

</div>
</div>

<div id="replyto_54898809"></div>

<ul id="group_54898809">
	<li id="hiddens_54898809" class="hide"></li>
</ul>

</li><li id="tree_54894395" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54894395" class="commentstatus"></div>
<div id="comment_54894395" class="cw">
</div>

<div id="replyto_54894395"></div>

<ul id="group_54894395">
	<li id="hiddens_54894395" class="hide"></li>
</ul>

<ul id="commtree_54894395"><li id="tree_54894577" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894577" class="commentstatus"></div>
<div id="comment_54894577" class="cw">
	<div id="comment_top_54894577" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894577" name="comment_link_54894577" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894577" onclick="return D2.setFocusComment(54894577)" >Re:</a>


		 	<span id="comment_score_54894577" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894577); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~vtcodger">vtcodger</a>  <span class="uid"><a href="//slashdot.org/~vtcodger">( 957785 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894577"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894577"><p>Where has all MY cpu gone?  Ironically, about three hours ago, I noticed that my PC seemed sluggish.  Fired up top.  Opera is taking 25-30% of the cpu.  What's Opera looking at?  You guessed it, Slashdot.  Killed the Slasdot tab.  Opera usage dropped to under 1%.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894577">

</div>
</div>

<div id="replyto_54894577"></div>

<ul id="group_54894577">
	<li id="hiddens_54894577" class="hide"></li>
</ul>

<ul id="commtree_54894577"><li id="tree_54894687" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54894687" class="commentstatus"></div>
<div id="comment_54894687" class="cw">
	<div id="comment_top_54894687" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54894687" name="comment_link_54894687" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54894687" onclick="return D2.setFocusComment(54894687)" >Re:</a>


		 	<span id="comment_score_54894687" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54894687); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54894687"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54894687"><p>Did you try MyCleanPC?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54894687">

</div>
</div>

<div id="replyto_54894687"></div>

<ul id="group_54894687">
	<li id="hiddens_54894687" class="hide"></li>
</ul>

</li><li id="tree_54894737" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54894737" class="commentstatus"></div>
<div id="comment_54894737" class="cw">
</div>

<div id="replyto_54894737"></div>

<ul id="group_54894737">
	<li id="hiddens_54894737" class="hide"></li>
</ul>

<ul id="commtree_54894737"><li id="tree_54895331" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54895331" class="commentstatus"></div>
<div id="comment_54895331" class="cw">
	<div id="comment_top_54895331" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54895331" name="comment_link_54895331" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54895331" onclick="return D2.setFocusComment(54895331)" >Task Manager add-on might help</a>


		 	<span id="comment_score_54895331" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54895331); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Picodon">Picodon</a>  <span class="uid"><a href="//slashdot.org/~Picodon">( 4937267 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54895331"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54895331"><p>In those situations, I use the <a href="https://addons.mozilla.org/en-GB/firefox/addon/task-manager/" title="mozilla.org">Task Manager</a> [mozilla.org] third-party add-on to find out the culprit. In my experience, the cause of CPU hogging is often one of the several add-ons I use with Firefox. Saving the session and restarting often cures the ailment, though I sometimes find that I have to close specific pages (weird interaction of combination of pages and add-ons).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54895331">

</div>
</div>

<div id="replyto_54895331"></div>

<ul id="group_54895331">
	<li id="hiddens_54895331" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_54895525" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895525" class="commentstatus"></div>
<div id="comment_54895525" class="cw">
</div>

<div id="replyto_54895525"></div>

<ul id="group_54895525">
	<li id="hiddens_54895525" class="hide"></li>
</ul>

<ul id="commtree_54895525"><li id="tree_54896153" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54896153" class="commentstatus"></div>
<div id="comment_54896153" class="cw">
</div>

<div id="replyto_54896153"></div>

<ul id="group_54896153">
	<li id="hiddens_54896153" class="hide"></li>
</ul>

<ul id="commtree_54896153"><li id="tree_54897131" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897131" class="commentstatus"></div>
<div id="comment_54897131" class="cw">
	<div id="comment_top_54897131" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897131" name="comment_link_54897131" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897131" onclick="return D2.setFocusComment(54897131)" >Re:</a>


		 	<span id="comment_score_54897131" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897131); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ash-Fox">Ash-Fox</a>  <span class="uid"><a href="//slashdot.org/~Ash-Fox">( 726320 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897131"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897131"><blockquote><div><p>My motherboard maxes out at 8GB, fuck you.</p></div></blockquote><p>Sounds like you're a Mac user, Mac users need to buy a new Mac to upgrade the amount of RAM available.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897131">

</div>
</div>

<div id="replyto_54897131"></div>

<ul id="group_54897131">
	<li id="hiddens_54897131" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54894897" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54894897" class="commentstatus"></div>
<div id="comment_54894897" class="cw">
</div>

<div id="replyto_54894897"></div>

<ul id="group_54894897">
	<li id="hiddens_54894897" class="hide"></li>
</ul>

<ul id="commtree_54894897"><li id="tree_54897145" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897145" class="commentstatus"></div>
<div id="comment_54897145" class="cw">
	<div id="comment_top_54897145" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897145" name="comment_link_54897145" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897145" onclick="return D2.setFocusComment(54897145)" >Re:</a>


		 	<span id="comment_score_54897145" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897145); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ash-Fox">Ash-Fox</a>  <span class="uid"><a href="//slashdot.org/~Ash-Fox">( 726320 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897145"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897145"><blockquote><div><p>Compile "Hello World" on a modern platform and you get megabytes of code, libraries, and other unnecessaries that add up to astonishingly inefficient use of resources.</p></div></blockquote><p>I don't with Visual Studio C++ or C#, Java or GCC/G++ either?</p><p>Explain.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54897145">

</div>
</div>

<div id="replyto_54897145"></div>

<ul id="group_54897145">
	<li id="hiddens_54897145" class="hide"></li>
</ul>

</li><li id="tree_54897349" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54897349" class="commentstatus"></div>
<div id="comment_54897349" class="cw">
	<div id="comment_top_54897349" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54897349" name="comment_link_54897349" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54897349" onclick="return D2.setFocusComment(54897349)" >Re:</a>


		 	<span id="comment_score_54897349" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54897349); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JaredOfEuropa">JaredOfEuropa</a>  <span class="uid"><a href="//slashdot.org/~JaredOfEuropa">( 526365 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54897349"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54897349">There are a couple of separate issues there.  Agile per se doesn't push for a higher level of abstraction, not does it necessarily result in poorer outcomes for users.  That's on the team, not the method.
<br> <br>
Hello world results in megabytes of code on many modern platforms, but for more complex programs the overhead might be a lot less, percentage-wise.  Couple of MB extra, more CPU cycles because the code isn't optimized isn't always a poor tradeoff either.  A complex algorithm that hasn't been optimized mi</div>
	</div>

	<div class="commentSub" id="comment_sub_54897349">

</div>
</div>

<div id="replyto_54897349"></div>

<ul id="group_54897349">
	<li id="hiddens_54897349" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54895921" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54895921" class="commentstatus"></div>
<div id="comment_54895921" class="cw">
</div>

<div id="replyto_54895921"></div>

<ul id="group_54895921">
	<li id="hiddens_54895921" class="hide"></li>
</ul>

<ul id="commtree_54895921"><li id="tree_54898065" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54898065" class="commentstatus"></div>
<div id="comment_54898065" class="cw">
	<div id="comment_top_54898065" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54898065" name="comment_link_54898065" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;cid=54898065" onclick="return D2.setFocusComment(54898065)" >Re:</a>


		 	<span id="comment_score_54898065" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54898065); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Lord_Jeremy">Lord_Jeremy</a>  <span class="uid"><a href="//slashdot.org/~Lord_Jeremy">( 1612839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54898065"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54898065">On my Mac, Xcode 8.3 is currently using 600MB of memory. That's with our main workspace loaded, with has a hierarchy of 13 separate Xcode projects providing a total of 150 targets (approx). Most of the code is C++, including several modules from boost in the workspace which makes the code intelligence plugins go nuts. Slack is currently using 1.5GB of memory, while I'm connected to 3 different teams. For some reason, that's across 5 helpers plus the main app. That's insane.</div>
	</div>

	<div class="commentSub" id="comment_sub_54898065">

</div>
</div>

<div id="replyto_54898065"></div>

<ul id="group_54898065">
	<li id="hiddens_54898065" class="hide"></li>
</ul>

</li></ul></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//apple.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 0;
		D2.currents()['full']     = 23;
		D2.currents()['oneline']  = 77;
		// D2.currents_total(100);

		D2.abbrev_comments({54897349:520,54896691:519,54895827:529,54894819:522,54896673:515,54899211:529,54898319:732,54895707:515,54896623:543,54895985:536,54895455:533,54898095:515,54894779:566,54896567:522,54895521:806,54898367:511,54897999:529});
		D2.noshow_comments([54894603,54895155,54895189,54894781,54895039,54895579,54897637,54896697,54894395,54894737,54895525,54896153,54894897,54895921]);
		D2.pieces_comments([54894547,54894753,54894761,54894799,54895217,54895283,54895707,54895985,54896567,54896659,54895295,54895889,54896719,54897843,54896707,54896997,54897155,54895827,54897999,54896055,54897463,54894779,54895441,54894505,54894813,54894995,54894451,54894457,54894553,54896673,54895237,54895735,54894487,54894493,54894821,54898367,54899115,54895521,54897935,54899291,54899211,54898319,54894609,54894775,54894929,54896691,54898095,54894643,54894645,54894693,54897257,54894695,54894953,54895615,54894819,54895387,54895607,54896611,54895697,54896615,54897987,54896623,54898933,54895455,54895769,54896359,54896501,54896601,54897029,54898809,54894577,54894687,54895331,54897131,54897145,54897349,54898065]);
		D2.init_hiddens([]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(329265);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>761<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/16/09/07/2328217/apple-cites-courage-as-reason-to-remove-35mm-headphone-jack?sdsrc=popbyskidbtmprev">Apple Cites 'Courage' As Reason To Remove 3.5mm Headphone Jack</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>757<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/17/05/02/1916223/ask-slashdot-what-is-the-special-appeal-of-apple-products?sdsrc=popbyskidbtmprev">Ask Slashdot: What Is the 'Special Appeal' of Apple Products?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>742<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/16/11/14/1240245/china-threatens-to-cut-sales-of-iphones-and-us-cars-if-naive-trump-pursues-trade-war?sdsrc=popbyskidbtmprev">China Threatens To Cut Sales of iPhones and US Cars if 'Naive' Trump Pursues Trade War</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>675<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/16/11/02/1544214/phil-schiller-says-the-macbook-pro-doesnt-need-an-sd-card-slot?sdsrc=popbyskidbtmprev">Phil Schiller Says the MacBook Pro Doesn't Need an SD Card Slot</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>564<span class="hide"> comments</span></span></span><a href="//apple.slashdot.org/story/16/08/30/1423225/apple-ordered-to-pay-up-to-145-billion-in-eu-tax-crackdown-cook-refutes-eus-conclusion?sdsrc=popbyskidbtmprev">Apple Ordered To Pay Up To $14.5 Billion in EU Tax Crackdown, Cook Refutes EU's Conclusion</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//yro.slashdot.org/story/17/07/27/2018258/german-court-rules-bosses-cant-use-keyboard-tracking-software-to-spy-on-workers?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/privacy_64.png" width="64" height="64" alt="Privacy"></span>
	    
					<p class="grid_12"><a href="//yro.slashdot.org/story/17/07/27/2018258/german-court-rules-bosses-cant-use-keyboard-tracking-software-to-spy-on-workers?sdsrc=nextbtmprev">German Court Rules Bosses Can't Use Keyboard-Tracking Software To Spy On Workers</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>65<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/17/07/27/1957200/why-your-call-center-is-only-getting-noisier?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/communications_64.png" width="64" height="64" alt="Communications"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/17/07/27/1957200/why-your-call-center-is-only-getting-noisier?sdsrc=prevbtmprev">Why Your Call Center is Only Getting Noisier</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>98<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//apple.slashdot.org/comments.pl?sid=10919483&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">165</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Money isn't everything -- but it's a long way ahead of what comes next.
		-- Sir Edmond Stockdale</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?264">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?647">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->